Package Details: sabaki 0.52.2-1

Git Clone URL: https://aur.archlinux.org/sabaki.git (read-only, click to copy)
Package Base: sabaki
Description: An elegant SGF editor for the game of Go
Upstream URL: http://sabaki.yichuanshen.de/
Keywords: baduk electron nodejs npm sgf
Licenses: MIT
Submitter: apetresc
Maintainer: apetresc
Last Packager: apetresc
Votes: 14
Popularity: 0.61
First Submitted: 2017-09-20 21:44 (UTC)
Last Updated: 2022-09-13 21:49 (UTC)

Latest Comments

1 2 Next › Last »

sOmbre commented on 2023-12-29 19:16 (UTC) (edited on 2023-12-30 08:53 (UTC) by sOmbre)

TypeError: Function.prototype.apply was called on undefined, which is a undefined and not a function
    at node:internal/main/run_main_module:28:49

Node.js v21.4.0
==> ERREUR : An error has occurred in check().
    Cancel…

is there any solution?

apetresc commented on 2022-08-20 12:21 (UTC)

Should be all fixed now in the upstream v0.52.1 release, let me know if you run into any other problems.

zzy-ac commented on 2022-08-20 00:57 (UTC)

@apetresc Thank you very much. I'm looking forward to it

apetresc commented on 2022-08-20 00:54 (UTC)

@zzy-ac Yup, this is an upstream issue that has been fixed on master: https://github.com/SabakiHQ/Sabaki/commit/3ee67cddd29104c48afe348bab16181bfff5e2f7

I will cut a new release of Sabaki upstream shortly, to resolve this.

zzy-ac commented on 2022-08-19 22:22 (UTC) (edited on 2022-08-19 22:23 (UTC) by zzy-ac)

Compilation error, unable to compile successfully

ERROR in ./node_modules/@sabaki/shudan/src/Goban.js 49:41 Module parse failed: Unexpected token (49:41) You may need an appropriate loader to handle this file type, currently no loaders are configured to process this file. See https://webpack.js.org/concepts#loaders | clearAnimatedVerticesHandler: null, | });

    }, this.props.animationDuration ?? 200),

| }); | } @ ./node_modules/@sabaki/shudan/src/main.js 1:0-31 4:0-31 @ ./src/components/Goban.js @ ./src/components/MainView.js @ ./src/components/App.js ==> ERROR: A failure occurred in build(). Aborting... -> error making: sabaki

Zengen117 commented on 2022-02-12 13:41 (UTC)

If installed through the AUR. The application for some reason will not allow for board and stone themes to be installed via Preferences > Themes > Install Theme. A simple error message "Installation Failed" Comes up. Installing the .Appimage version of sabaki to user account rather than building through AUR resolves this issue. Maybe some with more expertise can look into this. Was a reproduceable problem on multiple arch machines.

apetresc commented on 2020-03-13 16:25 (UTC)

@sfranchi Done :)

sfranchi commented on 2020-03-13 16:06 (UTC)

Sabaki is now at ver 50.1, package needs to be updated

apetresc commented on 2019-05-14 12:58 (UTC)

@Artemy: Indeed, thanks for the report - should be fixed in pkgrel 2 now!

Artemy commented on 2019-05-13 20:19 (UTC) (edited on 2019-05-13 20:26 (UTC) by Artemy)

After upgrade I receive: ./sabaki [2837:0513/231442.782584:FATAL:setuid_sandbox_host.cc(157)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /opt/Sabaki/chrome-sandbox is owned by root and has mode 4755. Ловушка трассировки/останова (стек памяти сброшен на диск) (Manjaro 18.0.4 KDE)

[Solved] opt/Sabaki/chrome-sandbox write mode 4755