Package Details: sabaki 0.35.1-1

Git Clone URL: https://aur.archlinux.org/sabaki.git (read-only)
Package Base: sabaki
Description: An elegant SGF editor for the game of Go
Upstream URL: http://sabaki.yichuanshen.de/
Keywords: baduk electron nodejs npm sgf
Licenses: MIT
Submitter: apetresc
Maintainer: apetresc
Last Packager: apetresc
Votes: 6
Popularity: 0.067883
First Submitted: 2017-09-20 21:44
Last Updated: 2018-08-05 03:51

Latest Comments

GeneMarston commented on 2017-10-06 19:40

Besides adding aforementioned symlink, I think you also need to add gconf as a dependecy. Doesn't work without it.

beej commented on 2017-09-22 18:55

Also maybe consider symlinking /usr/bin/sabaki -> /opt/Sabaki/sabaki, or adding a little exec wrapper shell script in /usr/bin for it.

Thanks for the package--there wasn't one here the last time I looked and I was just about to make one this morning. :)

apetresc commented on 2017-09-22 18:53

Good catch, beej. Applied your patch, testing and pushing momentarily :)

EDIT: Done, pkgrel 2.

beej commented on 2017-09-22 18:48

Apparently release 0.31.3 is broken upstream since it relies on electron 1.8.0 which was recently removed for security reasons. Sabaki upstream git has been updated to depend on electron 1.7.7, but they have not yet released a new rev. Hopefully 0.31.4 comes out soon.

Meantime, here's a PKGBUILD with a prepare() section that patches the package.json file: https://pastebin.com/nJmfs0Tt