Package Details: sabnzbd-git 0.7.0.r1013.g56a89ce-1

Git Clone URL: https://aur.archlinux.org/sabnzbd-git.git (read-only)
Package Base: sabnzbd-git
Description: A web-interface based binary newsgrabber with NZB file support.
Upstream URL: http://www.sabnzbd.org/
Keywords: downloader internet
Licenses: GPL
Conflicts: sabnzbd, sabnzbd-bzr, sabnzbd-develop-git
Submitter: dryes
Maintainer: IncredibleLaser
Last Packager: IncredibleLaser
Votes: 21
Popularity: 0.388320
First Submitted: 2011-08-23 02:27
Last Updated: 2015-10-28 16:55

Required by (0)

Sources (10)

Latest Comments

IncredibleLaser commented on 2015-10-28 16:57

I reworked this PKGBUILD, please comment. I will happily add co-maintainers!

tixetsal commented on 2015-10-16 17:54

How does one make this work?

nem commented on 2015-08-30 00:35

python2-gntp-git is not in aur anymore.

IncredibleLaser commented on 2015-02-18 10:55

I'll try to refactor the PKGBUILD this weekend, in fact my own version is already different from this one.

return13 commented on 2015-02-07 00:06

python: can't open file 'package.py': [Errno 2] No such file or directory

IncredibleLaser commented on 2014-04-12 08:56

I have removed haskell-pandoc from makedepends.

FunkyMonkeyMonk commented on 2014-02-24 06:17

Any update on when the haskell install piece will be fixed/removed/marked optional. I see the same issue as blubbe. Removing haskell also seems to do the trick.

IncredibleLaser commented on 2013-12-24 08:12

AFAIK, this leaves you without documentation (or documentation in a single format only), which I'd say is optional in most cases. If you want to keep it, use the [haskell-core] repository (see https://wiki.archlinux.org/index.php/Unofficial_User_Repositories#haskell-core). My info might be wrong here and I don't have the possibility to check / change this right now.

blubbe commented on 2013-12-24 03:52

Getting this on a fresh install:
error: target not found: haskell-pandoc

It installs/runs without any issues if I remove "haskell-pandoc" from makedepends.

IncredibleLaser commented on 2013-12-02 16:29

It now has sqlite instead of sqlite3 as a dependency. Shouldn't have mattered though because sqlite provides sqlite3, but I modified it for completeness.

IncredibleLaser commented on 2013-12-01 10:47

You are right about the sqlite-stuff. I'll fix that today. What about that haskell-bytestring? It's not in the dependencies list.

blubbe commented on 2013-12-01 09:16

On a fresh install, "sqlite3" and "haskell-bytestring" dependencies didn't exist. I installed "sqlite" and "haskell-bytestring-show" instead to satisfy them.

IncredibleLaser commented on 2013-08-15 07:41

Damn right it does... or did. Fixed that, sorry.

brenix commented on 2013-08-12 23:41

Looks like the systemd service (sabnzbd.service) still references the /opt path..

sabnzbd.service:ExecStart=/bin/sh -c "python2 /opt/sabnzbd/SABnzbd.py -l0"

IncredibleLaser commented on 2013-08-03 08:30

I adjusted the path in the sabnzbd.install according to what Slash said and hope that this doesn't need any more attention.

IncredibleLaser commented on 2013-07-20 10:24

Thanks for the input, I hope to find more time to take care of this package.

Slash commented on 2013-07-01 03:18

sabnzb.install references /opt/sabnzbd/ (instead of /usr/share/sabnzbd) which causes it to fail on install/upgrade/etc.

IncredibleLaser commented on 2013-04-14 07:01

I copied some stuff from the sabnzbd PKGBUILD and added it here.

IncredibleLaser commented on 2013-04-06 10:59

I have adopted and updated the PKGBUILD for this package. What's new?
- It now compiles without errors by enforcing python 2 for all scripts
- It now uses pacman's new VCS mechanics
- You can actually choose wether you want to compile the git master (which is, at the time of writing, 2 months old) or the developement branch. Just set $_develop to true if you want to use the most up-to-date code.

In case you are wondering about the weird solutions in the PKGBUILD (as in some stuff seems unnecessary) I first wrote the PKGBUILD to be able to switch between master and develop and then made it parseable by the AUR. This leads to a bit of useless code. Looking for your feedback.

IncredibleLaser commented on 2013-01-07 16:17

I have a small request, can you add a systemd service-file for systemd like the sabnzbd package? I wrote my own (basically just the combination of their script and your sabnzbd.sh), available at http://pastebin.com/phvj4dND. I use it as a userscript in ~/.config/systemd/user so it might not apply to a systemwide script. However, I think that it might be helpful to some to run this as user automatically.

dryes commented on 2012-04-12 12:17

skydrome: thanks, updated.

skydrome commented on 2012-04-09 07:01

sqlite3 renamed to sqlite

dryes commented on 2012-02-28 20:52

fixed below issue.

Anonymous comment on 2012-01-27 09:12

Can you fix install=('sabnzbd.install') to install=sabnzbd.install


==> ERROR: install file (('sabnzbd.install')) does not exist.

dryes commented on 2012-01-01 14:00

jordz: That seems to be a coding error rather than one with the package.

Anonymous comment on 2011-12-08 23:22

After the git checkout if gives a SyntaxError while processing the python files:

package_.py
File "tools/make_mo.py", line 147
print 'Compile %s' % mo_file
^
SyntaxError: invalid syntax

dryes commented on 2011-10-18 22:46

Updated from python-cheetah to python2-cheetah. Also added zip.

ariscop commented on 2011-09-13 12:16

package_.py
Sorry, cannot find zip in the path

sabnzdb should depend on zip

dryes commented on 2011-09-05 00:46

Updated with file association (taken from non-git package, credited in PKGBUILD), also relocated from /opt to /usr/share (as the quasi-official Ubuntu package is.)

Haven't tested thoroughly, but it runs at the very least.

dryes commented on 2011-08-29 23:58

done, thanks.

cdemoulins commented on 2011-08-29 12:17

Hi, please update the dependency "python-yenc" to "python2-yenc". The package "python-yenc" will be deleted in two weeks.

cdemoulins commented on 2011-08-29 12:17

Hi, please update the dependency "python-yenc" to "python2-yenc". The package "python-yenc" will be deleted in two weeks.

dryes commented on 2011-08-23 02:31

note: Will most likely implement file association and maybe reorganise paths/users/groups (a la standard package) later this week.

dryes commented on 2011-08-23 02:31

Ah. Missed that one, thanks for pointing it out.


git package: https://aur.archlinux.org/packages.php?ID=51772

spatz commented on 2011-08-21 20:37

Note that development has moved to git on github:
https://launchpad.net/sabnzbd/+announcement/8813

dryes commented on 2011-07-31 13:11

updated with below fix.


(haven't bumped pkgver.)

Anonymous comment on 2011-07-29 12:41

Please alsa remove the following files :
-rw-r--r-- 1 jordy jordy 94 Jul 29 03:09 .bzreol
-rw-r--r-- 1 jordy jordy 66 Jul 29 03:09 .bzrignore
-rw-r--r-- 1 jordy jordy 77 Jul 29 03:09 .bzrtab

Instead of rm -rf .bzr > rm -rf .bzr* :)

dryes commented on 2011-06-01 22:26

Updated anyway, it can't hurt.

Also updated init script with -k switch on the curl to support https protocol in conf.d.

dryes commented on 2011-06-01 22:05

Ah. It seems that was changed recently.

http://bazaar.launchpad.net/~sabnzbd/sabnzbd/0.6.x/revision/2867


Haven't time until Saturday to test properly.
You should be able to remove or comment the line: unzip -oq cherrypy.zip

Please report if this is sufficient and I'll update package.

pho commented on 2011-06-01 20:52

I'll get:

==> Starting package()...
unzip: cannot find or open cherrypy.zip, cherrypy.zip.zip or cherrypy.zip.ZIP.
==> ERROR: A failure occurred in package().
Aborting...
The build failed.

dryes commented on 2011-05-18 17:00

updated with cdemoulins' fix.

cdemoulins commented on 2011-05-16 21:26

Hi,
Could you update the path "/var/run/daemons/sabnzbd" to "/run/daemons/sabnzbd" in the init script.

Thanks

dryes commented on 2011-01-29 10:46

thought that I had.

fixed now, thanks.

Gordin commented on 2011-01-28 22:02

Could you bump pkgrel or pkgver? The dependency update is not recognized by yaourt or other aur tools.

dryes commented on 2011-01-27 22:22

updated, thanks.

Anonymous comment on 2011-01-26 19:13

Can you change pyopenssl to python2-pyopenssl ?

Anonymous comment on 2010-10-24 23:43

Thanks for the update :)

dryes commented on 2010-10-22 15:13

Updated to address recent python changes.


Note: There seems to be a fairly major bug in the latest revision causing the queue to save incorrectly. Making identical changes to the stable version produced no errors, so I suspect the problem is with SAB.

Comment below if you discover otherwise.

dryes commented on 2010-10-22 14:58

Updated to address recent python changes.


Note: There seems to be a fairly major bug in the latest revision meaning the queue doesn't correctly save. Making identical changes to the stable version produced no errors, so I suspect the problem is with SAB.

Comment below if you discover otherwise.

dryes commented on 2010-10-22 14:51

Updated to address python version issues.


note: There seems to be a fairly major bug that results in the queue not being correctly saved. Making identical changes to the stable package resulted in no issues, so as far as I can tell it's a bug with SAB. Please comment if you discover otherwise.

dryes commented on 2010-10-22 14:50

Updated to address python version issues.


note: There seems to be a fairly major bug that results in the queue not being correctly saved. Making identical changes to the stable package resulted in no issues, so as far as I can tell it's a bug with SAB. Please comment if you discover otherwise.

dryes commented on 2010-10-22 14:49

Updated to address recent python changes.


note: There seems to be a fairly major bug that results in the queue not being correctly saved. Making identical changes to the stable package resulted in no issues, so as far as I can tell it's a bug with SAB.
Please comment if you discover otherwise.

dryes commented on 2010-10-22 14:47

Updated to address python version issues.


note: There seems to be a fairly major bug that results in the queue not being correctly saved. Making identical changes to the stable package resulted in no issues, so as far as I can tell it's a bug with SAB.
Please comment if you discover otherwise.

dryes commented on 2010-10-22 14:45

Updated to address python version issues.


note: There seems to be a fairly major bug that results in the queue not being correctly saved. Making identical changes to the stable package resulted in no issues, so as far as I can tell it's a bug with SAB. Please comment if you discover otherwise.

dryes commented on 2010-08-28 12:54

Updated confd/init scripts again. This time to match those of the stable sabnzbd package (format was different, functionally similar.)

dryes commented on 2010-08-25 13:11

No idea how that happened. No mods were made to any of those files from previous revision.

Updated.

kevku commented on 2010-08-24 14:37

the sabnzbd.confd, sabnzbd.init, sabnzbd.sh files in this package have newlines in Windows/DOS format that made then unusable on my system so I had to change them to UNIX format

dryes commented on 2010-07-15 11:16

Updated conf.d/init scripts with separate fields for USERNAME/PASSWORD. This solves a number of issues, namely running as a daemon.

Taken from: https://forums.sabnzbd.org/index.php?topic=4690.0

dryes commented on 2010-07-11 16:54

Oh. Maybe not. I'm sure it was erroring before after claiming I hadn't notified Launchpad of my ID.
Removed comment, thanks for pointing that out.

IncredibleLaser commented on 2010-07-11 16:31

Does it? I checked it out without problems.

dryes commented on 2010-07-08 13:31

Requires LaunchPad account.

https://launchpad.net