Package Details: sabnzbd 3.0.0-2

Git Clone URL: https://aur.archlinux.org/sabnzbd.git (read-only, click to copy)
Package Base: sabnzbd
Description: A web-interface based binary newsgrabber with NZB file support
Upstream URL: http://www.sabnzbd.org
Keywords: network usenet
Licenses: GPL
Submitter: kvasthval
Maintainer: Revelation60 (fryfrog)
Last Packager: fryfrog
Votes: 262
Popularity: 1.41
First Submitted: 2007-11-09 16:21
Last Updated: 2020-08-04 15:16

Pinned Comments

fryfrog commented on 2020-08-01 15:19

The sabnzbd 3.0.0 release is python3, yay! I've also moved the install from /opt to /usr/lib/sabnzbd and /var/lib/sabnzbd. The .install file should move things around as needed, but please post if it doesn't.

Latest Comments

« First ‹ Previous ... 5 6 7 8 9 10 11 12 13 14 15 ... Next › Last »

nightah commented on 2016-04-28 06:01

Looks like we're pulling from the upstream "Source Code (.tar.gz)" option on github (https://github.com/sabnzbd/sabnzbd/releases), there's a significant amount of diffs between the above version and (SABnzbd-1.0.1-src.tar.gz) though both are labelled as 1.0.1 release and functionally do not seem different.

If we want the versioning represented appropriately we can change the package to pull down the Linux source package (SABnzbd-1.0.1-src.tar.gz).

Do so by removing lines 32-35 in the PKGBUILD.

You also need to modify lines 15 and 30 respectively in the PKGBUILD to read as:

source=("https://github.com/${pkgname}/${pkgname}/releases/download/${pkgver}/${_pkgname}-${pkgver}-src.tar.gz"

cp -r "${srcdir}/${_pkgname}-${pkgver}/"* "${pkgdir}/opt/${pkgname}"

terminalmage commented on 2016-03-23 19:41

Yeah, I noticed this too, if anything this appears to be an upstream issue, because the tar archive for v1.0.0 is coming from upstream.

Anonymous comment on 2016-03-23 19:39

I just update sabnzbd with this package but it states it is version 0.8.x.
Within help as well as in the tab of my browser

Is this intended ?

Update: it can be easily corrected by editing /opt/sabnzbd/sabnzbd/version.py

mac1202 commented on 2016-03-23 07:29

upgrading from 1.0.0-1 to 1.0.0-2 I have to redo all the configuration, it's this normal ?

francoism90 commented on 2016-03-20 17:35

@Revelation60: could you update the systemd file? It should point to the config file:
ExecStart=/opt/sabnzbd/SABnzbd.py -10 -f /opt/sabnzbd/sabnzbd.ini

Thanks. :)

PS. I have updated the SABnzbd Wiki, would be great if you guys could take a look and fix/improve when needed. :)

Revelation60 commented on 2016-03-16 10:17

Sabnzbd is updated to version 1.0.0. This is a major update, so some reconfiguration using the web wizard is required. Remember to update the API key in /etc/conf.d/sabnzbd if you want to open .nzb files with sabnzbd.

Revelation60 commented on 2016-02-01 15:23

Done. Hopefully it is ok now.

Spyhawk commented on 2016-01-30 09:18

Please update the .SRCINFO file too, as the information provided by the RPC interface isn't correct and is needed by some helpers.

Paviluf commented on 2015-11-30 18:00

I think it's better to start sabnzbd only when you want to use it instead of having it always running for the obvious reason that you don't always download something.

Thanks to look at it !

Revelation60 commented on 2015-11-30 16:55

Ah, I was looking at a wrong version it seems. Anyway, I will see if I can make a hybrid that also works to start sabnzbd.

That being said, justin8 is right, the default procedure would be to start it as a service.