Package Details: safeeyes 2.0.8-1

Git Clone URL: (read-only)
Package Base: safeeyes
Description: A Free and Open Source tool for Linux users to reduce and prevent repetitive strain injury (RSI).
Upstream URL:
Keywords: eye-strain rsi safeeyes utility
Licenses: GPL3
Submitter: Yamakaky
Maintainer: gobinath
Last Packager: gobinath
Votes: 22
Popularity: 1.345486
First Submitted: 2016-10-25 04:33
Last Updated: 2019-01-22 03:05

Latest Comments

di72nn commented on 2018-08-13 18:45

The package needs to be rebuilt, otherwise this happens:

$ safeeyes
Traceback (most recent call last):
  File "/usr/bin/safeeyes", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 3095, in <module>
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 3079, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 3108, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 570, in _build_master
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 888, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 774, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'safeeyes==2.0.6' distribution was not found and is required by the application

FredBezies commented on 2018-01-17 12:34

python-setuptools must be added in depends().

addictgamer commented on 2018-01-05 04:31

Had to install package python-setuptools, otherwise makepkg failed.

imdn commented on 2017-10-05 21:36

Like @third_man commented python-gobject is a necessary dependency. Without it you will encounter the following error:

AttributeError: module 'gi' has no attribute 'require_version'

third_man commented on 2016-10-26 05:06

Please add python2-gobject as dependency. It provides necessary gi module.

knight_corvi commented on 2016-10-25 17:20

Are you using GNOME+Wayland by any chance?
The application doesn't seem to be working for me. The process is there, but there is no tray icon I can click on the legacy tray bar. I will look further into the issue at any rate.