Package Details: saleae-logic-beta 1.2.29-1

Git Clone URL: https://aur.archlinux.org/saleae-logic-beta.git (read-only)
Package Base: saleae-logic-beta
Description: High speed USB logic analyzer.
Upstream URL: http://www.saleae.com/
Licenses: unknown
Conflicts: saleae-logic
Provides: saleae-logic
Submitter: tiago
Maintainer: masser
Last Packager: masser
Votes: 15
Popularity: 0.428986
First Submitted: 2014-06-27 14:43
Last Updated: 2018-08-02 04:48

Latest Comments

1 2 Next › Last »

asura commented on 2018-03-14 10:53

For those who have problems which require that the program runs as root you can add this udev rule. Create a file /etc/udev/rules.d/99-saleae.rules with the contents below. Afterwards just reconnect the USB device.

https://pastebin.com/raw/KNSMm5hq

c-mauderer commented on 2017-07-02 07:38

It seems that the libopenssl-1.0-compat dependency does not exist.

But currently the version of the beta packet is the same as for the non-beta version of saleae-logic. So that's not really a problem.

alexei commented on 2017-05-25 00:24

I got this error: This application failed to start because it could not find or load the Qt platform plugin "xcb" in "".

Fix, add this to /usr/bin/logic script:
export LD_LIBRARY_PATH=/opt/saleae-logic/:$LD_LIBRARY_PATH /opt/saleae-logic/Logic

PS. That /usr/bin/logic script should be removed altogether, though. I don't think users want the stdout/stderr silenced.

masser commented on 2017-05-21 07:25

2craftyguy
libopenssl-1.0-compat is orphan package in AUR.

alxjsn commented on 2017-05-20 18:50

It would be nice to include the creation of a symlink as well such as:

ln -s "/opt/saleae-logic/Logic" "${pkgdir}/usr/bin/logic"

craftyguy commented on 2017-05-20 15:41

There's a bug in your PKGBUILD, line 39 should be:

install -Dm644 "$srcdir/Saleae+Users+Guide.pdf" "$pkgdir/usr/share/doc/saleae-logic/"


Also, need to add libopenssl-1.0-compat as a dependency, and add LD_LIBRARY_PATH=/usr/lib/openssl-1.0-compat in /usr/bin/logic, since this app is still linked against libopenssl-1.0..

masser commented on 2017-03-14 08:41

x86 version is no longer supported

masser commented on 2016-06-01 04:32

2alexei, fixed, thank.

alexei commented on 2016-05-31 19:24

The icon URL is dead. Please just add the file to the package. Here's a live URL where you can get it from now: http://kde-look.org/CONTENT/content-files/133473-SaleaeLogic.svg

simeonfelis commented on 2016-04-20 07:21

I had to copy the udev rules to /etc:

sudo cp src/Logic\ 1.2.7\ \(64-bit\)/Drivers/99-SaleaeLogic.rules /etc/udev/rules.d

The udev rules in /usr/lib/udev/rules.d/99-SaleaeLogic.rules was not evaluated after replugging the Analyzer.