Package Details: salome-geom 7.6.0-2

Git Clone URL: (read-only)
Package Base: salome-geom
Description: Generic platform for Pre and Post-Processing for numerical simulation - GEOM Module
Upstream URL:
Licenses: LGPL
Submitter: mickele
Maintainer: mickele
Last Packager: mickele
Votes: 8
Popularity: 0.000943
First Submitted: 2010-06-05 18:16
Last Updated: 2016-06-03 17:15

Dependencies (5)

Sources (3)

  • occ691.patch
  • salome-geom.profile

Latest Comments

Tomatopaste commented on 2016-05-06 12:00

I got the same error. Using an older version of the 'opencascade' package than (6.9.1-2) helps. For me, version (6.9.0-2) is sufficient.

tapia commented on 2016-02-03 20:33

Hi! This module is not compiling. I get this error:

/tmp/yaourt-tmp-tapia/aur-salome-geom/src/geom/src/GEOMImpl/GEOMImpl_IMeasureOperations.cxx: In member function ‘bool GEOMImpl_IMeasureOperations::FastIntersect(Handle_GEOM_Object, Handle_GEOM_Object, double, float, Handle_TColStd_HSequenceOfInteger&, Handle_TColStd_HSequenceOfInteger&)’:
/tmp/yaourt-tmp-tapia/aur-salome-geom/src/geom/src/GEOMImpl/GEOMImpl_IMeasureOperations.cxx:1649:8: error: ‘BRepExtrema_OverlappedSubShapes’ has not been declared
for (BRepExtrema_OverlappedSubShapes::Iterator anIt1 (aBSP.OverlapSubShapes1(
/tmp/yaourt-tmp-tapia/aur-salome-geom/src/geom/src/GEOMImpl/GEOMImpl_IMeasureOperations.cxx:1649:84: error: ‘anIt1’ was not declared in this scope
ema_OverlappedSubShapes::Iterator anIt1 (aBSP.OverlapSubShapes1()); anIt1.More(
/tmp/yaourt-tmp-tapia/aur-salome-geom/src/geom/src/GEOMImpl/GEOMImpl_IMeasureOperations.cxx:1654:8: error: ‘BRepExtrema_OverlappedSubShapes’ has not been declared
for (BRepExtrema_OverlappedSubShapes::Iterator anIt2 (aBSP.OverlapSubShapes2(
/tmp/yaourt-tmp-tapia/aur-salome-geom/src/geom/src/GEOMImpl/GEOMImpl_IMeasureOperations.cxx:1654:84: error: ‘anIt2’ was not declared in this scope
ema_OverlappedSubShapes::Iterator anIt2 (aBSP.OverlapSubShapes2()); anIt2.More(
src/GEOMImpl/CMakeFiles/GEOMImpl.dir/build.make:326: recipe for target 'src/GEOMImpl/CMakeFiles/GEOMImpl.dir/GEOMImpl_IMeasureOperations.cxx.o' failed
make[2]: *** [src/GEOMImpl/CMakeFiles/GEOMImpl.dir/GEOMImpl_IMeasureOperations.cxx.o] Error 1
CMakeFiles/Makefile2:1578: recipe for target 'src/GEOMImpl/CMakeFiles/GEOMImpl.dir/all' failed
make[1]: *** [src/GEOMImpl/CMakeFiles/GEOMImpl.dir/all] Error 2
Makefile:138: recipe for target 'all' failed
make: *** [all] Error 2

Any ideas?

Anonymous comment on 2010-09-19 14:03

@mickele: you're right, here's what I found in the SALOME version 5.1.4 Release

Summary: EDF GEOM : in CVS
Change: Obsolete packages GEOMDS, PARTITION and NMTAlgo have been removed.

mickele commented on 2010-09-19 08:10

I haven't found libPARTITION in salome-geom-5.1.4.
On "" I saw it was included in salome-geom-3.2.6, so probably if you need that library you have to install that version of salome-geom.

Anonymous comment on 2010-09-16 13:44


I need libPartition to be installed and couldn't find it in the salome-geom package, is there a way to configure the build to have it installed?

Here's the output of the compilation process :

Checking salomegeometry Sketcher library ... yes
Checking salomegeometry ShHealOper library ... yes
Checking salomegeometry Partition library ... no
libPartition not found (part of salomegeom).


mickele commented on 2010-08-01 15:23

Updated to 5.1.4!

mickele commented on 2010-06-27 13:16

5.1.3-2 - this updated contains a lot of bugfix.

mickele commented on 2010-06-12 08:38


Anonymous comment on 2010-06-08 12:58

Good Job :)