Package Details: salome-gui 7.8.0-4

Git Clone URL: https://aur.archlinux.org/salome-gui.git (read-only)
Package Base: salome-gui
Description: Generic platform for Pre and Post-Processing for numerical simulation - GUI Module
Upstream URL: http://www.salome-platform.org
Keywords: FEM postprocessing
Licenses: LGPL
Submitter: mickele
Maintainer: mickele
Last Packager: mickele
Votes: 12
Popularity: 0.000047
First Submitted: 2010-06-05 18:16
Last Updated: 2017-04-13 20:37

Latest Comments

mickele commented on 2017-03-03 19:53

@Corsinux x12r13
I wrote a patch to compile with sip-4.19 (7.8.0-3).
Give it a try.

mickele commented on 2017-02-04 12:19

Problem is related to recent update of sip and pyqt.
Other packages have the same issue (see https://bbs.archlinux.org/viewtopic.php?id=222605 for example).
At the moment the only solution is downgrading sip and related packages.

x12r13 commented on 2017-01-30 22:52

i have exactly the same problem as user Corsinux!

Corsinux commented on 2017-01-28 08:40

Hello !

I can't build the packagesalome-gui.It' stop with a makepkg error at 82 %.
The error message is :

[ 82%] Building CXX object src/SALOME_PYQT/SALOME_PYQT_GUILight/CMakeFiles/SalomePyQtGUILight.dir/SALOME_PYQT_PyModule.cxx.o
/yaourt_temp/yaourt-tmp-corsinux/aur-salome-gui/src/GUI_SRC/src/SALOME_PYQT/SALOME_PYQT_GUILight/SALOME_PYQT_PyModule.cxx: Dans la fonction membre « void PyModuleHelper::setWorkSpace() »:
/yaourt_temp/yaourt-tmp-corsinux/aur-salome-gui/src/GUI_SRC/src/SALOME_PYQT/SALOME_PYQT_GUILight/SALOME_PYQT_PyModule.cxx:1816:58: erreur : « sipType_QWidget » was not declared in this scope
PyObjWrapper pyws( sipBuildResult( 0, "D", aWorkspace, sipType_QWidget , NULL) );
^~~~~~~~~~~~~~~
/yaourt_temp/yaourt-tmp-corsinux/aur-salome-gui/src/GUI_SRC/src/SALOME_PYQT/SALOME_PYQT_GUILight/SALOME_PYQT_PyModule.cxx: Dans la fonction membre « void PyModuleHelper::internalContextMenu(const QString&, QMenu*) »:
/yaourt_temp/yaourt-tmp-corsinux/aur-salome-gui/src/GUI_SRC/src/SALOME_PYQT/SALOME_PYQT_GUILight/SALOME_PYQT_PyModule.cxx:2267:56: erreur : « sipType_QMenu » was not declared in this scope
PyObjWrapper sipPopup( sipBuildResult( 0, "D", menu, sipType_QMenu, NULL ) );
^~~~~~~~~~~~~
/yaourt_temp/yaourt-tmp-corsinux/aur-salome-gui/src/GUI_SRC/src/SALOME_PYQT/SALOME_PYQT_GUILight/SALOME_PYQT_PyModule.cxx: Dans la fonction membre « void PyModuleHelper::internalLoad(const QStringList&, bool&) »:
/yaourt_temp/yaourt-tmp-corsinux/aur-salome-gui/src/GUI_SRC/src/SALOME_PYQT/SALOME_PYQT_GUILight/SALOME_PYQT_PyModule.cxx:2478:58: erreur : « sipType_QStringList » was not declared in this scope
PyObjWrapper sipList( sipBuildResult( 0, "D", theList, sipType_QStringList, NULL ) );
^~~~~~~~~~~~~~~~~~~
/yaourt_temp/yaourt-tmp-corsinux/aur-salome-gui/src/GUI_SRC/src/SALOME_PYQT/SALOME_PYQT_GUILight/SALOME_PYQT_PyModule.cxx: Dans la fonction membre « void PyModuleHelper::internalDropObjects(const DataObjectList&, SUIT_DataObject*, int, Qt::DropAction) »:
/yaourt_temp/yaourt-tmp-corsinux/aur-salome-gui/src/GUI_SRC/src/SALOME_PYQT/SALOME_PYQT_GUILight/SALOME_PYQT_PyModule.cxx:2632:58: erreur : « sipType_QStringList » was not declared in this scope
PyObjWrapper sipList( sipBuildResult( 0, "D", theList, sipType_QStringList, NULL) );
^~~~~~~~~~~~~~~~~~~
make[2]: *** [src/SALOME_PYQT/SALOME_PYQT_GUILight/CMakeFiles/SalomePyQtGUILight.dir/build.make:178: src/SALOME_PYQT/SALOME_PYQT_GUILight/CMakeFiles/SalomePyQtGUILight.dir/SALOME_PYQT_PyModule.cxx.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:2987: src/SALOME_PYQT/SALOME_PYQT_GUILight/CMakeFiles/SalomePyQtGUILight.dir/all] Error 2
make: *** [Makefile:139: all] Error 2
==> ERREUR : Une erreur s’est produite dans build().
Abandon...
==> ERREUR : Makepkg n'a pas pu construire salome-gui.

Thank you for your help.

Tomatopaste commented on 2016-12-21 13:26

Update the md5 checksum for the source file in the PKGBUILD.
Replace the last entry by 0f6de10ad9d9c646fce3ca21a7dab46a

ArnaudNux commented on 2016-06-03 23:53

==> Connecting to git server...
Cloning into 'gui'...
remote: Counting objects: 61189, done.
remote: Compressing objects: 100% (19194/19194), done.
remote: Total 61189 (delta 50656), reused 51063 (delta 41834)
Receiving objects: 100% (61189/61189), 36.66 MiB | 1.44 MiB/s, done.
Resolving deltas: 100% (50656/50656), done.
Checking connectivity... done.
Note: checking out 'V7_6_0'.

You are in 'detached HEAD' state. You can look around, make experimental
changes and commit them, and you can discard any commits you make in this
state without impacting any branches by performing another checkout.

If you want to create a new branch to retain commits you create, you may
do so (now or later) by using -b with the checkout command again. Example:

git checkout -b <new-branch-name>

HEAD is now at e203c34... INT PAL 0022812: TC6.4.0: prefernces work only for a new study (edited)
==> GIT checkout done or server timeout
==> Starting build()...
/tmp/yaourt-tmp/aur-salome-gui/./PKGBUILD: line 64: /opt/salome/env.d/salome-kernel.sh: No such file or directory
==> ERROR: Makepkg was unable to build salome-gui.

mickele commented on 2015-09-28 03:11

Hi guys!
I modified sphinx detection, now you shouldn't have that error.

screwit commented on 2015-09-27 15:38

Hi mickele, Im getting the same error mentioned by mauritiusdadd when building.

ArnaudNux commented on 2015-05-22 23:54

-- Graphviz directory matches what was previously exposed by another prereq, all good!
CMake Warning at /opt/salome/kernel/salome_adm/cmake_files/SalomeMacros.cmake:506 (MESSAGE):
Package Sphinx couldn't be found - did you set the corresponing root dir
correctly? It currently contains SPHINX_ROOT_DIR=/usr Append
-DSALOME_CMAKE_DEBUG=ON on the command line if you want to see the original
CMake error.
Call Stack (most recent call first):
/opt/salome/kernel/salome_adm/cmake_files/FindSalomeSphinx.cmake:25 (SALOME_FIND_PACKAGE_AND_DETECT_CONFLICTS)
CMakeLists.txt:117 (FIND_PACKAGE)


-- Sphinx was not found.
CMake Error at /opt/salome/kernel/salome_adm/cmake_files/SalomeMacros.cmake:502 (MESSAGE):
Package CAS couldn't be found - did you set the corresponing root dir
correctly? It currently contains CAS_ROOT_DIR=/opt/opencascade Append
-DSALOME_CMAKE_DEBUG=ON on the command line if you want to see the original
CMake error.
Call Stack (most recent call first):
/opt/salome/kernel/salome_adm/cmake_files/FindSalomeCAS.cmake:27 (SALOME_FIND_PACKAGE_AND_DETECT_CONFLICTS)
CMakeLists.txt:139 (FIND_PACKAGE)


-- Configuring incomplete, errors occurred!
See also "/tmp/yaourt-tmp-arnaud/aur-salome-gui/src/gui/CMakeFiles/CMakeOutput.log".
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build salome-gui.
==> Restart building salome-gui ? [y/N]
==> -----------------------------------
==>

mickele commented on 2014-12-13 16:24

PKGBUILD modified according to mauritiusdadd's suggestion (7.4.0-3)

mauritiusdadd commented on 2014-12-13 09:57

Hi, when I try to build the package, I get the following error:

--
-- Optional packages - Detection report
-- ====================================
--
-- * CppUnit -> Found
-- * Doxygen -> Found
-- * Graphviz -> Found
-- * Sphinx -> NOT Found - SALOME_BUILD_DOC can be switched OFF to skip this prerequisite.
-- * OpenGL -> Found
-- * VTK -> Found
-- * Qwt -> Found
--
--
CMake Error at /opt/salome/kernel/salome_adm/cmake_files/SalomeMacros.cmake:319 (MESSAGE):
Some required prerequisites have NOT been found. Take a look at the report
above to fix this.
Call Stack (most recent call first):
CMakeLists.txt:187 (SALOME_PACKAGE_REPORT_AND_CHECK)

can you please add the following option to cmake?
-DSPHINX_EXECUTABLE=/usr/bin/sphinx-build2

nejsem commented on 2013-04-20 07:52

The URL is returning 404. Please, replace the url with one from the mirrorlist http://www.filewatcher.com/m/src5.1.4.tar.gz.120063320-0.html

mickele commented on 2010-08-01 15:23

Updated to 5.1.4!

algoban commented on 2010-07-10 20:38

Ok

i compiled again and now its works

algoban commented on 2010-07-10 17:41

Yes i checked it and i have this file.

thank you for your answer

mickele commented on 2010-07-10 09:53

@algoban
Error is caused by a missing header, Standard.hxx, that should be included in opencascade package. On my system, (opencascade 6.3.0-10) it is in /opt/opencascade/inc/Standard.hxx.
Do you have this file?

algoban commented on 2010-07-09 12:24

Hi

When i try to compile i have the following problem

In file included from CASCatch_CatchSignals.cxx:25:0:
CASCatch_CatchSignals.hxx:28:24: fatal error: Standard.hxx: No such file or directory
compilation terminated.
make[2]: *** [libCASCatch_la-CASCatch_CatchSignals.lo] Error 1
make[2]: se sale del directorio `/tmp/yaourt-tmp-al/aur-salome-gui/src/src5.1.3/GUI_SRC_5.1.3/src/CASCatch'
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio `/tmp/yaourt-tmp-al/aur-salome-gui/src/src5.1.3/GUI_SRC_5.1.3/src'
make: *** [all-recursive] Error 1
Abortando...
==> ERROR: Makepkg was unable to build salome-gui.

I dont know what to do.

Thank you for the help

mickele commented on 2010-06-27 13:17

5.1.3-2 - this updated contains a lot of bugfix.