Package Details: salome-med 7.6.0-3

Git Clone URL: https://aur.archlinux.org/salome-med.git (read-only)
Package Base: salome-med
Description: Generic platform for Pre and Post-Processing for numerical simulation - MED Module
Upstream URL: http://www.salome-platform.org
Licenses: LGPL
Submitter: mickele
Maintainer: mickele
Last Packager: mickele
Votes: 6
Popularity: 0.005617
First Submitted: 2010-06-05 18:17
Last Updated: 2016-06-03 17:16

Dependencies (9)

Required by (2)

Sources (2)

  • salome-med.profile
  • scotch-bz2.diff

Latest Comments

mickele commented on 2015-09-28 17:44

I modified sphinx detection (7.6.0-2).
Give it a try!

screwit commented on 2015-09-28 11:25

Thank you! take your time!

mickele commented on 2015-09-28 11:24

Ok, I'll upload modified PKGBUILD this night (now I can't!)

screwit commented on 2015-09-28 11:21

Thanks mickele, now I'm getting the Sphinx error,

* Sphinx -> NOT Found - SALOME_BUILD_DOC can be switched OFF to skip this prerequisite.

mickele commented on 2015-09-28 09:58

You must install med-salome (https://aur.archlinux.org/packages/med-salome/). It's a slightly modified version of med to compile on x86_64.
It replaces med package, but isn't compatible with that. So if you install med-salome you have to rebuild all app using med (gmsh, code-aster etc).

screwit commented on 2015-09-28 09:53

Hi! I have med-3.0.8-3 installed but still getiing this problem, please help, TIA


==> Making package: salome-med 7.6.0-1 (Mon Sep 28 20:48:14 IST 2015)
==> Checking runtime dependencies...
==> Missing dependencies:
-> med-salome>=3.0.8
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.

mickele commented on 2015-02-27 18:29

@pychuang
you shouldn't have problems having built scotch without libbz2.

pychuang commented on 2015-02-26 21:37

I finally built and installed this package successfully.

I re-built and re-installed the package "scotch" but disable the support of bzip2. I'm not sure what will happen if I use Salome and scotch without bzip2 support...
At least I get this Salome package compiled and installed now...

pychuang commented on 2015-02-26 02:12

Hi,

I got error messages while building this package:

/usr/lib/libscotch.so: undefined reference to `BZ2_bzReadGetUnused'
/usr/lib/libscotch.so: undefined reference to `BZ2_bzWriteClose'
/usr/lib/libscotch.so: undefined reference to `BZ2_bzReadOpen'
/usr/lib/libscotch.so: undefined reference to `BZ2_bzRead'
/usr/lib/libscotch.so: undefined reference to `BZ2_bzWriteOpen'
/usr/lib/libscotch.so: undefined reference to `BZ2_bzWrite'
/usr/lib/libscotch.so: undefined reference to `BZ2_bzReadClose'
collect2: error: ld returned 1 exit status
src/MEDPartitioner/CMakeFiles/medpartitioner.dir/build.make:111: recipe for target 'src/MEDPartitioner/medpartitioner' failed
make[2]: *** [src/MEDPartitioner/medpartitioner] Error 1
CMakeFiles/Makefile2:832: recipe for target 'src/MEDPartitioner/CMakeFiles/medpartitioner.dir/all' failed
make[1]: *** [src/MEDPartitioner/CMakeFiles/medpartitioner.dir/all] Error 2
Makefile:127: recipe for target 'all' failed
make: *** [all] Error 2

I had installed bzip2.

Any ideas? Thanks!

mickele commented on 2014-12-13 16:46

PKGBUILD changed according to mauritiusdadd's suggestion (7.4.0-2)

mauritiusdadd commented on 2014-12-13 10:58

Hi,
during the compilation I get the following error:

/home/daddona/AUR/salome-med/src/MED_SRC_7.4.0/src/MEDPartitioner/MEDPARTITIONER_ScotchGraph.cxx:30:20: fatal error: scotch.h: No such file or directory #include "scotch.h"

you shoud change the cmake option SCOTCH_INCLUDE_DIRS to
-DSCOTCH_INCLUDE_DIRS=/usr/include/scotch \

mickele commented on 2010-08-01 15:24

Updated to 5.1.4!

mickele commented on 2010-06-27 13:17

5.1.3-2 - this updated contains a lot of bugfix.