Package Details: sasm 3.9.0-1

Git Clone URL: https://aur.archlinux.org/sasm.git (read-only)
Package Base: sasm
Description: Simple crossplatform IDE for NASM, MASM, GAS, FASM assembly languages
Upstream URL: http://dman95.github.io/SASM/english.html
Keywords: sasm-git
Licenses: GPL3
Conflicts: fasm
Submitter: yaroslav
Maintainer: twa022
Last Packager: twa022
Votes: 17
Popularity: 0.165526
First Submitted: 2015-05-27 17:40
Last Updated: 2017-09-20 23:23

Latest Comments

Light2Yellow commented on 2017-08-12 12:03

I have no time to maintain it, sorry. Adopt.

eisterman commented on 2017-08-05 23:50

PKGBUILD require an edit. qmake at now have been renamed as qmake-qt4 if you don't have qt5 (that isn't in dependencies).
So for the people who don't have qt5 installed is better have qmake-qt4 who is in dependecies (in qt4).
The PKGBUILD need to check if the qt version is > of 5 or not. If not use qmake-qt4 and not qmake.

fasm can't be in conflict with sams, you can use it from sams!

Light2Yellow commented on 2017-05-18 19:20

The package was orphaned.
I updated it to 3.8.0 and added fasm to conflicts as proposed below, though no idea whether it's the right decision.
Feel free to propose your changes.

generalt commented on 2017-04-04 11:59

change pkgver to 3.8.0 and sha256sums to:
c61ac0de8959e2d5e2d6fa20718f97bfbc0ed79c0c7d80f14b4dedcab93dd0d7

Georgios commented on 2017-03-25 20:01

And now we are at 3.8.0

haxabja commented on 2016-10-26 17:55

Please update the PKGBUILD so that it uses v3.6.0.

salviati commented on 2016-09-01 00:45

Conflicts with fasm

yaroslav commented on 2016-04-04 05:30

@liljaylj
Fixed.

liljaylj commented on 2016-04-04 00:15

==> Validating source files with sha256sums...
v3.5.0.tar.gz ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build sasm.

yaroslav commented on 2015-08-14 18:05

tech4david,
"Qt 4.8 and above". Not everyone has the qt4.

All comments