Package Details: savage-xr 1.0-1

Git Clone URL: https://aur.archlinux.org/savage-xr.git (read-only)
Package Base: savage-xr
Description: Savage: The Battle for Newerth is an online multiplayer team-based FPS/RTS hybrid. Completely free as of September 2006. (Includes XR Patches)
Upstream URL: http://www.newerth.com/
Licenses: custom: "Unknown"
Submitter: giner
Maintainer: Slash
Last Packager: Slash
Votes: 17
Popularity: 0.050515
First Submitted: 2010-03-27 19:37
Last Updated: 2015-06-08 17:51

Required by (0)

Sources (3)

Latest Comments

hebrew commented on 2015-04-29 20:05

>I'd like to know how you got it to work.

First I'll point out that I downloaded the installer from savage website and run it to install savage, I didn't use this package.

next renamed the entire /libs folder and enabled each .so file one by one.
I got it working with:
libcrypto.so.0.9.8
libcurl.so.4
libfmodex.so
libssl.so.0.9.8
libjpeg.so.62
libpng12.so.0
libpython2.7.so.1.0

from the libs folder and it works with a bit of a sound cracking at startup.

Slash commented on 2015-02-07 22:44

I had an issue with libz.so.1 (as mentioned below) and libglib-2.0.so.0 (./savage.bin: symbol lookup error: /usr/lib32/libharfbuzz.so.0: undefined symbol: g_bytes_unre).

Renaming those two libraries allows the game to continue, but it immediately segfaults for me. I tried renaming the libs/ directory and forcing it to use system as many system libs as possible, but savage segfaults after the auto-updater closes before actually doing anything. If anyone still has it working on 64bit (and there system is up to date), I'd like to know how you got it to work.

Tjuh commented on 2014-04-26 09:55

Ignore my previous statement. I had to manually remove libz.so.1 from the lib directory in order to get it to work.

Tjuh commented on 2014-04-24 10:10

I'm getting an error after building and installing. When trying to start the game I get: ./savage.bin: ./libs/libz.so.1: version `ZLIB_1.2.3.4' not found (required by /usr/lib32/libpng16.so.16)

daenyth commented on 2012-12-20 16:41

64bit also needs lib32-glu

daenyth commented on 2012-12-20 16:39

Once I install lib32 deps, it gives me this even when I set LD_LIBRARY_PATH to /usr/lib32/ with lib32-mesa installed.

./savage.bin: error while loading shared libraries: libGLU.so.1: cannot open shared object file: No such file or directory

daenyth commented on 2012-12-20 16:32

Deps need to include lib32-libxinerama and lib32-libxft on 64bit

omer666 commented on 2012-10-02 09:44

Savage XR 1.0 is out
=> http://www.newerth.com/smf/index.php/topic,15825.0.html

leper commented on 2011-10-31 18:32

After some trying i got savage running on x86_64 with those packages needed as the only dependencies:

lib32-alsa-lib (this one does not show up when running namcap but I only get a blank screen and nothing happens if it isn't installed)
lib32-libxft
lib32-libxinerama
lib32-mesa
lib32-sdl



lib32-pcre isn't needed and is identified by namcap as an unneeded dependency "savage-xr W: Dependency included and not needed ('lib32-pcre')"

giner commented on 2011-02-27 16:55

> although it doesn't respect the split between the 'build' and 'package' functions
What do you mean? It really caused a problem before I separated it.

All comments