Package Details: savage2 2.1.1.1-2

Git Clone URL: https://aur.archlinux.org/savage2.git (read-only, click to copy)
Package Base: savage2
Description: Savage 2: A Tortured Soul is an fantasy themed online multiplayer team-based FPS/RTS/RPG hybrid. Completely free as of December 2008.
Upstream URL: https://savage2.com/
Licenses: custom: "Savage 2"
Submitter: Tjuh
Maintainer: Slash
Last Packager: Slash
Votes: 65
Popularity: 0.001933
First Submitted: 2008-07-14 15:10 (UTC)
Last Updated: 2023-05-03 21:47 (UTC)

Latest Comments

1 2 3 4 5 6 Next › Last »

hildigerr commented on 2023-05-02 21:13 (UTC)

Also depends on ncurses5-compat-libs

csts commented on 2023-04-24 21:19 (UTC)

As you mentioned below -above needs correction- Upstream URL is:
https://savage2.net/

hildigerr commented on 2023-04-21 15:33 (UTC)

'Savage2-2.1.1.1-linux-x64-installer.run' failed validity check. Firefox detected a potential security threat and did not continue to savage2.com.

I believe the upstream URL has changed to https://savage2.net/ and the installer should come from https://savage2.net/downloads/Savage2-2.1.1.1-linux-x64-installer.run

Slash commented on 2020-01-28 01:31 (UTC)

I updated the PKGBUILD to remove the offending library

queenmedley commented on 2020-01-27 02:21 (UTC)

Just delete /opt/savage2/libs/libstdc++.so.6 to use /usr/lib/libstdc++.so.6 instead.

fhdrin commented on 2020-01-13 19:04 (UTC)

./savage2.bin: /opt/savage2/libs/libstdc++.so.6: version CXXABI_1.3.8' not found (required by /usr/lib/libicuuc.so.65) ./savage2.bin: /opt/savage2/libs/libstdc++.so.6: versionGLIBCXX_3.4.11' not found (required by /usr/lib/libicuuc.so.65)

Slash commented on 2019-12-15 20:13 (UTC)

Savage 2 is now maintained by the community at https://savage2.net/, so it is no longer necessary to download the installer from a mirror.

Slash commented on 2017-04-08 00:50 (UTC)

@noogar: The only working mirror is ModDB. You cannot link directly to the downloads as far as I know, you have to go through their website to obtain a download token.

raspher commented on 2017-04-07 12:51 (UTC)

@Slash, you can do this automatically in PKGBUILD... upstream and sources error 404

Slash commented on 2016-03-21 03:54 (UTC)

The Savage2 installer files are missing from the official s2games.com server. You'll need to manually download the appropriate .run file from one of the "Off Site HTTP Downloads" mirrors manually before attempting to build this package: http://savage2.com/en/download.php