Package Details: savage2 2.1.0.8-1

Git Clone URL: https://aur.archlinux.org/savage2.git (read-only)
Package Base: savage2
Description: Savage 2: A Tortured Soul is an fantasy themed online multiplayer team-based FPS/RTS/RPG hybrid. Completely free as of December 2008.
Upstream URL: http://savage2.com/
Licenses: custom: "Savage 2"
Submitter: Tjuh
Maintainer: Slash
Last Packager: Slash
Votes: 65
Popularity: 0.000000
First Submitted: 2008-07-14 15:10
Last Updated: 2015-06-08 17:51

Required by (0)

Sources (6)

Latest Comments

Slash commented on 2016-03-21 03:54

The Savage2 installer files are missing from the official s2games.com server.

You'll need to manually download the appropriate .run file from one of the "Off Site HTTP Downloads" mirrors manually before attempting to build this package:

http://savage2.com/en/download.php

erayaydin commented on 2015-07-17 16:45

==> ERROR: Failure while downloading Savage2-2.1.0.8-linux-x64-installer.run
Aborting...

Slash commented on 2015-02-07 22:22

There are a few sites with 2.1.0.8, but you will need to download manually:

* http://www.atomicgamer.com/files/100476/savage-2-client-v2-1-0-8-linux-64-free-to-play

* http://www.moddb.com/games/savage-2-a-tortured-soul/downloads/savage-2-a-tortured-soul-v2108-linux-64-bit

http://www.playsavage2.com/ is supposed to be an active community site, but it lists 2.1.0.1 as the version you should download.

Finally, http://na1.cedeqien.com/ provides an unofficial 2.1.1.0 patch/expansion. I am not involved with the Savage 2 community at all, so I'm not sure what is considered the de-facto version of Savage 2 (or maybe there isn't one because the game is dead?).

Slash commented on 2014-12-14 22:30

Strange, 2.1.0.8 appears to have disappeared off their servers and only 2.1.0.7 is available. Does anyone know what's going on?

Ravenman commented on 2014-11-27 22:24

I can't install this game:

==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> N

==> savage2 dependencies:
- mesa (already installed)
- libxml2 (already installed)
- unzip (already installed)


==> Edit savage2.install ? [Y/n] ("A" to abort)
==> -------------------------------------------
==> N

==> Continue building savage2 ? [Y/n]
==> ---------------------------------
==>
==> Building and installing package
==> Making package: savage2 2.1.0.8-1 (Thu Nov 27 17:20:44 COT 2014)
==> WARNING: Using a PKGBUILD without a package() function is deprecated.
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Downloading Savage2-2.1.0.8-linux-installer.run...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 360 100 360 0 0 1102 0 --:--:-- --:--:-- --:--:-- 1100
curl: (22) The requested URL returned error: 404 Not Found
==> ERROR: Failure while downloading Savage2-2.1.0.8-linux-installer.run
Aborting...
==> ERROR: Makepkg was unable to build savage2.
==> Restart building savage2 ? [y/N]
==> --------------------------------
==>

Tjuh commented on 2014-06-20 07:47

This game also requires glu as a dependency.

py_crash commented on 2012-12-30 13:48

savage 2.1.0.8 is out

Slash commented on 2012-08-22 22:41

I updated the LD_LIBRARY_PATH in savage2.sh. savage2.sh used to be part of the installer files, but it appears to be missing from 2.1.0.7. I didn't have time to delve to deeply into it, so I copied the format of "modelviewer.sh" and "dedicated_server.sh".

Fandekasp commented on 2012-08-20 09:46

Btw Slash (thinking about it as I saw the upgrade today), there is something wrong with your sh script.

Please modify l.21 of savage2.sh to:
export LD_LIBRARY_PATH="$(pwd):$(pwd)/libs:$(pwd)/game:$LD_LIBRARY_PATH"


I had a big headache figuring out why I couldn't run savage2 with bumblebee and optirun because of that line (OpenGL versions are differents depending on the graphic card driver).
Thanks !

Fandekasp commented on 2012-08-20 09:45

Btw Slash (thinking about it as I saw the upgrade today), there is something wrong with your sh script.

Please modify l.21 of savage2.sh to:
export LD_LIBRARY_PATH="$(pwd):$(pwd)/libs:$(pwd)/game:$LD_LIBRARY_PATH"


I had a big headache figuring out why I couldn't run savage2 with bumblebee and optirun because of that line (OpenGL versions are differents depending on the graphic card driver).
Thanks !

All comments