Package Details: sawfish-git 1.12.0.7.g7ffe711-1

Git Clone URL: https://aur.archlinux.org/sawfish-git.git (read-only)
Package Base: sawfish-git
Description: A window manager extensible using a Lisp-based scripting language.
Upstream URL: http://sawfish.wikia.com
Licenses: GPL
Conflicts: sawfish
Provides: sawfish=1.11
Submitter: haawda
Maintainer: haawda
Last Packager: haawda
Votes: 5
Popularity: 0.000000
First Submitted: 2009-06-12 22:20
Last Updated: 2016-12-01 23:27

Latest Comments

haawda commented on 2013-04-22 19:14

fixed in rep-gtk-git.

metak commented on 2013-04-22 18:20

I've noticed it that librep package was outdated and sawfish-git failed to build. (configure.in: bump required librep to 0.92.3)

metak commented on 2013-04-22 18:17

I've noticed it that librep package was outdated and sawfish-git failed to build. (configure.in: bump required librep to 0.92.3)

metak commented on 2013-04-22 18:11

Build fails with regular librep because it requires librep-git (configure.in: bump required librep to 0.92.3).

haawda commented on 2013-04-22 17:54

librep is pulled by rep-gtk-git. I can change it there to librep-git.

metak commented on 2013-04-22 08:17

I think 'librep-git' is missing in deps...

haawda commented on 2013-04-06 13:01

pacman-4.1-compatible PKGBUILD

haawda commented on 2013-03-29 03:24

Project moved to github.

haawda commented on 2012-12-02 22:19

Sawfish now can manage tiling. Documentation is under /usr/share/doc/sawfish-git.

haawda commented on 2012-11-24 20:54

Since I had serious problems with several mozilla based applications, I applied a patch from the sawfish mailing list.

haawda commented on 2012-06-11 17:55

switched back to master, upstream merge.

haawda commented on 2012-04-13 18:11

switched to "local-master"-branch, because the main branch is too close to the tarball release provided by the "sawfish" package.

haawda commented on 2011-08-19 20:49

cleanup desktop files

haawda commented on 2011-08-03 17:26

Sorry stupid mistake. fixed

trizen commented on 2011-08-02 08:01

Please add 'emacs' to makedepends()

Otherwise:
../sawfish-git/PKGBUILD: line 42: emacs: command not found
==> ERROR: A failure occurred in build().
Aborting...

haawda commented on 2011-04-16 16:21

Pulls from git://git.tuxfamily.org/gitroot/sawfish/main.git now. That introduced some other changes to the PKGBUILD.

haawda commented on 2011-04-06 19:58

Revised install file and added configure option --without-pango. Without that option the build failed.

haawda commented on 2010-08-20 18:25

Added option libtool. Removed unused configure option.

haawda commented on 2010-08-20 17:27

Added option !libtool. Removed unused configure option.

haawda commented on 2010-07-31 15:23

Definitely needs a git-version of librep. librep in [extra] will not work.

haawda commented on 2010-07-31 14:49

Another sed line needed.

haawda commented on 2010-07-21 01:40

had to add two sed lines for gnome.jl and kde.jl. Shortened the PKGBUILD a bit (pacman 3.4).