Package Details: scalarr 1.0.2-1

Git Clone URL: https://aur.archlinux.org/scalarr.git (read-only)
Package Base: scalarr
Description: A command-line interface for Sonarr
Upstream URL: https://github.com/nichobi/scalarr
Licenses: GPL
Submitter: nichobi
Maintainer: nichobi
Last Packager: nichobi
Votes: 1
Popularity: 0.48
First Submitted: 2019-10-15 18:58
Last Updated: 2019-10-16 22:05

Latest Comments

nichobi commented on 2019-10-15 21:15

These seem to be issues with sbt setting itself up, before it's even loaded the Scalarr project. Do you get the same result if you just run sbt by itself?

fryfrog commented on 2019-10-15 20:18

https://repo1.maven.org/maven2/org/scala-sbt/main_2.12/1.3.0/main_2.12-1.3.0.jar
  100.0% [##########] 2.4 MiB (15.2 MiB / s)
https://repo1.maven.org/maven2/org/scala-sbt/zinc-persist_2.12/1.3.0/zinc-persist_2.12-1.3.0.jar
  100.0% [##########] 1.7 MiB (14.2 MiB / s)
https://repo1.maven.org/maven2/org/apache/ant/ant/1.9.9/ant-1.9.9.jar
  100.0% [##########] 2.0 MiB (11.2 MiB / s)
[info] Fetched artifacts of
[error] java.io.IOError: java.lang.RuntimeException: /packages cannot be represented as URI
[error] Use 'last' for the full log.
Project loading failed: (r)etry, (q)uit, (l)ast, or (i)gnore? r
[info] Loading settings for project scalarr-1-0-0-build from plugins.sbt,assembly.sbt ...
[info] Loading project definition from /home/fryfrog/aur/scalarr/src/scalarr-1.0.0/project
[error] java.io.IOError: java.lang.RuntimeException: /packages cannot be represented as URI
[error] Use 'last' for the full log.
Project loading failed: (r)etry, (q)uit, (l)ast, or (i)gnore? q
==> ERROR: A failure occurred in build().
    Aborting...

When done manually, I wonder if there are any other good example sbt packages?

fryfrog commented on 2019-10-15 20:17

downloading file:////home/fryfrog/.sbt/preloaded/org/scala-sbt/util-scripted_2.12/1.3.0/util-scripted_2.12-1.3.0.jar ...
downloading file:////home/fryfrog/.sbt/preloaded/com/github/cb372/scalacache-core_2.12/0.20.0/scalacache-core_2.12-0.20.0.jar ...
downloading file:////home/fryfrog/.sbt/preloaded/com/github/ben-manes/caffeine/caffeine/2.5.6/caffeine-2.5.6.jar ...
        [SUCCESSFUL ] org.scala-sbt.ipcsocket#ipcsocket;1.0.0!ipcsocket.jar (4ms)
downloading file:////home/fryfrog/.sbt/preloaded/org/scala-sbt/ivy/ivy/2.3.0-sbt-cb9cc189e9f3af519f9f102e6c5d446488ff6832/ivy-2.3.0-sbt-cb9cc189e9f3af519f9f102e6c5d446488ff6832.jar ...
        [SUCCESSFUL ] org.scala-sbt#zinc-core_2.12;1.3.0!zinc-core_2.12.jar (22ms)
        [SUCCESSFUL ] com.google.protobuf#protobuf-java;3.7.0!protobuf-java.jar(bundle) (40ms)
        [SUCCESSFUL ] com.lihaoyi#fastparse_2.12;0.4.2!fastparse_2.12.jar (16ms)
        [SUCCESSFUL ] org.scala-sbt#util-scripted_2.12;1.3.0!util-scripted_2.12.jar (6ms)
        [SUCCESSFUL ] org.scala-sbt#sbinary_2.12;0.4.4!sbinary_2.12.jar (13ms)
        [SUCCESSFUL ] com.github.cb372#scalacache-core_2.12;0.20.0!scalacache-core_2.12.jar (7ms)
        [SUCCESSFUL ] org.scala-sbt#zinc-persist_2.12;1.3.0!zinc-persist_2.12.jar (34ms)
        [SUCCESSFUL ] com.github.ben-manes.caffeine#caffeine;2.5.6!caffeine.jar (16ms)
        [SUCCESSFUL ] org.scala-sbt.ivy#ivy;2.3.0-sbt-cb9cc189e9f3af519f9f102e6c5d446488ff6832!ivy.jar (21ms)
        [SUCCESSFUL ] com.trueaccord.scalapb#scalapb-runtime_2.12;0.6.0!scalapb-runtime_2.12.jar (39ms)
        [SUCCESSFUL ] org.scala-sbt#scripted-plugin_2.12;1.3.0!scripted-plugin_2.12.jar (236ms)
        [SUCCESSFUL ] org.scala-sbt#logic_2.12;1.3.0!logic_2.12.jar (248ms)
        [SUCCESSFUL ] org.scala-sbt#main-settings_2.12;1.3.0!main-settings_2.12.jar (248ms)
        [SUCCESSFUL ] org.scala-sbt#run_2.12;1.3.0!run_2.12.jar (246ms)
        [SUCCESSFUL ] org.scala-sbt#sbt;1.3.0!sbt.jar (257ms)
        [SUCCESSFUL ] org.scala-sbt#test-agent;1.3.0!test-agent.jar (192ms)
        [SUCCESSFUL ] org.scala-sbt#scripted-sbt-redux_2.12;1.3.0!scripted-sbt-redux_2.12.jar (272ms)
        [SUCCESSFUL ] org.scala-sbt#zinc-lm-integration_2.12;1.3.0!zinc-lm-integration_2.12.jar (273ms)
        [SUCCESSFUL ] com.eed3si9n#sjson-new-scalajson_2.12;0.8.2!sjson-new-scalajson_2.12.jar (256ms)
        [SUCCESSFUL ] org.scala-sbt#tasks_2.12;1.3.0!tasks_2.12.jar (213ms)
        [SUCCESSFUL ] org.scala-sbt#task-system_2.12;1.3.0!task-system_2.12.jar (232ms)
        [SUCCESSFUL ] org.scala-sbt#core-macros_2.12;1.3.0!core-macros_2.12.jar (203ms)
        [SUCCESSFUL ] org.scala-sbt#testing_2.12;1.3.0!testing_2.12.jar (251ms)
        [SUCCESSFUL ] org.scala-sbt#actions_2.12;1.3.0!actions_2.12.jar (323ms)
        [SUCCESSFUL ] org.scala-sbt#command_2.12;1.3.0!command_2.12.jar (321ms)
        [SUCCESSFUL ] org.scala-sbt#completion_2.12;1.3.0!completion_2.12.jar (293ms)
        [SUCCESSFUL ] org.scala-sbt#collections_2.12;1.3.0!collections_2.12.jar (332ms)
        [SUCCESSFUL ] org.scala-sbt#io_2.12;1.3.0!io_2.12.jar (344ms)
        [SUCCESSFUL ] org.scala-sbt#protocol_2.12;1.3.0!protocol_2.12.jar (267ms)
        [SUCCESSFUL ] org.scala-sbt#main_2.12;1.3.0!main_2.12.jar (422ms)
        [SUCCESSFUL ] org.scala-lang#scala-library;2.12.8!scala-library.jar (504ms)
        [SUCCESSFUL ] io.get-coursier#lm-coursier-shaded_2.12;2.0.0-RC3-3!lm-coursier-shaded_2.12.jar (544ms)

:: problems summary ::
:::: WARNINGS
                ::::::::::::::::::::::::::::::::::::::::::::::

                ::              FAILED DOWNLOADS            ::

                :: ^ see resolution messages for details  ^ ::

                ::::::::::::::::::::::::::::::::::::::::::::::

                :: org.scala-lang#scala-reflect;2.12.8!scala-reflect.jar

                :: org.scala-lang#scala-compiler;2.12.8!scala-compiler.jar

                ::::::::::::::::::::::::::::::::::::::::::::::



:: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
[error] [launcher] download failed: org.scala-lang#scala-reflect;2.12.8!scala-reflect.jar
[error] [launcher] download failed: org.scala-lang#scala-compiler;2.12.8!scala-compiler.jar
[error] [launcher] error during sbt launcher: error retrieving required libraries
  (see /home/fryfrog/.sbt/boot/update.log for complete log)
[error] [launcher] could not retrieve sbt 1.3.0
==> ERROR: A failure occurred in build().
    Aborting...
Error making: scalarr

Does not build using yay, will try manually.