Package Details: scamper 20240229-1

Git Clone URL: https://aur.archlinux.org/scamper.git (read-only, click to copy)
Package Base: scamper
Description: a tool that actively probes the Internet in order to analyze topology and performance
Upstream URL: https://www.caida.org/catalog/software/scamper/
Keywords: network-analysis networking ping
Licenses: GPL-2.0-or-later
Submitter: Spider.007
Maintainer: hendrikcech (marek22k)
Last Packager: marek22k
Votes: 4
Popularity: 0.094323
First Submitted: 2013-10-24 12:44 (UTC)
Last Updated: 2024-02-29 19:57 (UTC)

Latest Comments

marek22k commented on 2024-01-19 17:09 (UTC)

A new scamper version (cvs-20240117) is available. If you like, you can add me as a co-maintainer - then I can update scamper. I always find out quite quickly as I have subscribed to the Mailling list.

marek22k commented on 2023-12-26 00:21 (UTC) (edited on 2023-12-28 13:16 (UTC) by marek22k)

I would suggest to use SPDX-License identifier (here license=('GPL-2.0-or-later')) (see https://wiki.archlinux.org/title/PKGBUILD#license and https://rfc.archlinux.page/0016-spdx-license-identifiers/). And the homepage changed to url="https://www.caida.org/catalog/software/scamper/". And maybe you could add something like make -j "$(nproc)" to use all available CPU's cores. Maybe something like that:

# Maintainer: hendrikcech <hendrik.cech@gmail.com>
# Contributor: Spider.007 <archPackage@spider007.net>
# Contributor: Marek Küthe <m.k@mk16.de>

pkgname=scamper
pkgver=20230614d
pkgrel=1
pkgdesc="a tool that actively probes the Internet in order to analyze topology and performance"
url="https://www.caida.org/catalog/software/scamper/"
source=("https://www.caida.org/catalog/software/scamper/code/$pkgname-cvs-$pkgver.tar.gz")
sha512sums=('98fdfd4a7119b1e588358e8e985a8201ed8b75e3e5bda5b46fd9f3d9da2881a234053026ad8c108ad183f41aaadfa24e9fdf7e2c1f66c5d2221f48127d0107c9')
depends=('openssl' 'zlib' 'bzip2' 'xz')
license=('GPL-2.0-or-later')
arch=('i686' 'x86_64')

build() {
    cd "$pkgname-cvs-$pkgver"

    ./configure --prefix=/usr
    make -j "$(nproc)"
}

package() {
    cd "$pkgname-cvs-$pkgver"

    make DESTDIR="$pkgdir/" install
}

It also needs a few more deps depends=('openssl' 'zlib' 'bzip2' 'xz') (see ldd /path/to/scamper)

vivien commented on 2022-03-22 11:20 (UTC)

Working with the following PKGBUILD:


pkgname='scamper'

pkgver='20211212a'
pkgrel='1'

pkgdesc='A tool that actively probes the Internet in order to analyze topology and performance'

arch=('x86_64')
url='http://www.caida.org/tools/measurement/scamper/'
license=('GPL2')

depends=('openssl')

source=("http://www.caida.org/tools/measurement/scamper/code/$pkgname-cvs-$pkgver.tar.gz")

sha256sums=('d986b429655dce36629d1821ea6f32d65cc418f7d22b1ea4330621bffb35c18c')

build() {
  cd "${srcdir}/${pkgname}-cvs-${pkgver}"
  ./configure --prefix=/usr/
  make
}

package() {
  cd "${srcdir}/${pkgname}-cvs-${pkgver}"
  make "DESTDIR=${pkgdir}" install
  chmod u+s "${pkgdir}/usr/bin/scamper"
}

zbisch commented on 2021-05-21 20:36 (UTC) (edited on 2021-05-21 20:36 (UTC) by zbisch)

Getting an error when trying to validate the source code (with yay).

==> Validating source files with sha256sums...
    scamper-cvs-20191102b.tar.gz ... FAILED
==> ERROR: One or more files did not pass the validity check!
error downloading sources: scamper

zorun commented on 2017-11-06 21:52 (UTC)

@Spider.007: yes, you need to depend on openssl-1.0, and use this trick: export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig like here: https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/nodejs#n41

Spider.007 commented on 2017-11-05 10:36 (UTC)

@zorun do you have a fix for the openssl-1.1 incompatibility?

zorun commented on 2017-10-29 15:28 (UTC)

@Spider.007: I am available for co-maintaining this package if needed.

Spider.007 commented on 2013-10-31 08:24 (UTC)

@rectec, thanks!

rectec commented on 2013-10-31 02:00 (UTC)

Builds well, runs well. :)