Package Details: scangearmp-mp280 1.60-4

Git Clone URL: https://aur.archlinux.org/scangearmp-mp280.git (read-only)
Package Base: scangearmp-mp280
Description: Canon Scanner Driver (mp280 series)
Upstream URL: http://support-my.canon-asia.com/contents/MY/EN/0100303302.html
Licenses: custom
Submitter: None
Maintainer: lahwaacz
Last Packager: lahwaacz
Votes: 8
Popularity: 0.004129
First Submitted: 2012-02-06 02:02
Last Updated: 2015-07-27 10:56

Latest Comments

lahwaacz commented on 2016-09-13 17:22

That's impossible to solve because there is a version mismatch. scangearmp-mp280 is at version 1.60, but there is no scangearmp-common=1.60 package. Either way, you'd get a conflict with your scangearmp-common=2.00 package.

JNNYBLZ commented on 2016-09-13 14:12

error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/bin/scangearmp'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/lib/bjlib/canon_mfp_net.ini'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/lib/libcncpcmcm.so.8.0.1'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/lib/libcncpmsimg.so.1.0.2'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/lib/libcncpmslld.so.1.0.1'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/lib/libsane-canon_mfp.so'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/cs/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/da/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/de/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/el/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/es/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/fi/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/fr/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/hu/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/id/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/it/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/ja/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/ko/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/nb/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/nl/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/pl/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/pt/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/ru/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/sv/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/th/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/tr/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/zh/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/locale/zh_TW/LC_MESSAGES/scangearmp.mo'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/scangearmp/pixmaps/image_curve_h_grad_226.xpm'
error: file owned by 'scangearmp-common' and 'scangearmp-mp280': 'usr/share/scangearmp/pixmaps/image_curve_v_grad_226.xpm'

got these errors from pacman, yet must have both packages installed to use my scanner

lahwaacz commented on 2013-01-29 22:24

fix_configure.patch from scangearmp-mg6100 AUR package is needed to build this package

lahwaacz commented on 2013-01-26 09:35

I can't compile the package, I get this error:
Running autoconf ...
configure.in:15: error: possibly undefined macro: AM_INIT_AUTOMAKE
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
configure.in:16: error: possibly undefined macro: AM_CONFIG_HEADER
configure.in:17: error: possibly undefined macro: AC_PROG_LIBTOOL
configure.in:18: error: possibly undefined macro: AM_MAINTAINER_MODE
configure.in:22: error: possibly undefined macro: AM_PROG_CC_STDC
configure.in:62: error: possibly undefined macro: AM_GLIB_GNU_GETTEXT
Running ./configure --enable-maintainer-mode --prefix=/usr --enable-libpath=/usr/lib LDFLAGS=-lm -L/home/lahwaacz/stuff/scangearmp-mp280/src/scangearmp-source-1.60-1/scangearmp/../com/libs_bin64 ...
configure: WARNING: unrecognized options: --enable-maintainer-mode
./configure: line 2044: syntax error near unexpected token `scangearmp,'
./configure: line 2044: `AM_INIT_AUTOMAKE(scangearmp, 1.60-1)'

Revelation60 commented on 2012-09-23 09:52

Could you update your package to fix the following errors:

unknown key 'SYSFS{idVendor}' in /etc/udev/rules.d/80-canon_mfp.rules:10
34]: invalid rule '/etc/udev/rules.d/80-canon_mfp.rules:10'

SYSFS is called ATTR now.