Package Details: scidavis 1.14-1

Git Clone URL: https://aur.archlinux.org/scidavis.git (read-only)
Package Base: scidavis
Description: Application for Scientific Data Analysis and Visualization, fork of QtiPlot
Upstream URL: http://scidavis.sourceforge.net/
Licenses: GPL
Submitter: leidola
Maintainer: arcanis
Last Packager: arcanis
Votes: 44
Popularity: 0.152391
First Submitted: 2008-08-18 22:21
Last Updated: 2016-08-12 10:51

Latest Comments

arcanis commented on 2016-08-23 09:22

pkgbuild forces qt4: https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=scidavis#n30

JohnRobson commented on 2016-08-22 19:16

@arcanis, I'm using QT5 by default, but maybe this builder should select QT4 automatically.

arcanis commented on 2016-08-12 15:10

didnt run it yet, just updated and compiled. Will check later

sirocco commented on 2016-08-12 14:16

Can anyone plot anything with last version (1.14 or 1D13) of scidavis?

I have a segmentation fault with

scidavis[8815]: segfault at 79 ip 00007f4e4d8aa915 sp 00007ffe6afef8e0 error 4 in libQtGui.so.4.8.7[7f4e4d522000+ae5000]

in dmesg log.

arcanis commented on 2016-07-19 13:31

/usr/lib/qt/mkspecs/features/qt_config.prf belongs to qt5 package. This package should build with qt4 (i.e. using qmake-qt4). Which qt4 version are you using?

JohnRobson commented on 2016-07-19 00:27

==> Starting build()...
/usr/lib/qt/mkspecs/features/qt_config.prf:3: Missing ] terminator [found /]
/usr/lib/qt/mkspecs/features/default_pre.prf:13: defined(function, type): unexpected type [var].
/usr/lib/qt/mkspecs/features/default_pre.prf:65: Unknown test function: cache
/usr/lib/qt/mkspecs/features/default_pre.prf:66: Unknown test function: cache
Project ERROR: addExclusiveBuilds() requires at least two arguments
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build scidavis.

chron commented on 2016-07-13 13:20

The Scidavis sources are unreachable for me... Is anyone else having problems?

manouchk commented on 2016-07-10 02:26

Scidavis crashes on plotting.
Reproducing the bug: fill first and second column with row numbers and make a plot (scatter or line plot).

arcanis commented on 2016-05-31 15:03

fixed, sorry for delay

kmiernik commented on 2016-05-22 09:27

I've got compilation error:
Makefile:2092: recipe for target '../tmp/scidavis/FitDialog.o' failed
make[1]: Leaving directory '/var/cache/pacman/pkg/scidavis2608/scidavis/src/scidavis.1.D9/libscidavis'
Makefile:45: recipe for target 'sub-libscidavis-make_default-ordered' failed

arcanis commented on 2016-01-11 19:07

@rugaliz sorry for the delay I've been some busy, but it usually requires some time to make it working with our libraries

rugaliz commented on 2016-01-10 21:34

hi
will we be getting scidavis 1d9 anytime soon?

cheers

chron commented on 2015-04-21 12:44

You could take a look at saxonbeta's pyqt4.patch from qtiplot-opj, he found a nice way of doing it.

from PyQt4 import QtCore
import sipconfig
sipcfg = sipconfig.Configuration()
print " ".join([sipcfg.sip_bin, "-I", sipcfg.default_sip_dir + "/PyQt4", QtCore.PYQT_CONFIGURATION['sip_flags']])

arcanis commented on 2015-04-20 21:51

thanks, seems to be fixed now. The patch is required because for some time pyqtconfig method has been dropped by upstream. I've reported to the upstream about problem - https://sourceforge.net/p/scidavis/scidavis-bugs/243/ - but there was no changes applied

chron commented on 2015-04-20 19:59

Or ask arcanis to modify his patch.
Just noticed that :)

chron commented on 2015-04-20 19:39

Hehe... The python patch is the reason it won't build ^^, in /scidavis.1.D8/scidavis/python-sipcmd.py it changed:

print " ".join([config.sip_bin, "-I", config.pyqt_sip_dir, config.pyqt_sip_flags] + flags)

to:

print " ".join(["/usr/bin/sip", "-I", "/usr/share/sip", "-x VendorID -t WS_X11 -t Qt_4_8_6 -x Py_v3"] + flags)

which won't work for us because Arch installs the files scidavis wants from pyqt4-common to /usr/share/sip/PyQt4/.

Just add 'sed -i "s|/usr/share/sip|/usr/share/sip/PyQt4/|g" ${srcdir}/${pkgname}.${pkgver}/${pkgname}/python-sipcmd.py' to the end of the prepare function and it builds.

Working PKGBUILD here: https://paste.xinu.at/bAK0S/

rami commented on 2015-02-13 13:21

Currently fails. The real reason seems to be:

make[1]: Entering directory '/tmp/yaourt-tmp-raphael/aur-scidavis/src/scidavis.1.D8/scidavis'
/usr/bin/qmake-qt4 -o Makefile scidavis.pro
Project MESSAGE: Building with preset linux_package
sip: Deprecation warning: ../scidavis/src/scidavis.sip:34: %Module version number should be specified using the 'version' argument
sip: Unable to find file "QtCore/QtCoremod.sip"

Does anyone know a fix for this?

rami commented on 2015-02-13 10:39

Fails with
../scidavis/src/PythonScripting.cpp:65:28: fatal error: sipAPIscidavis.h: No such file or directory

arcanis commented on 2014-07-23 08:29

https://sourceforge.net/p/scidavis/scidavis-bugs/243/

vit commented on 2014-03-06 03:01

IS there anyone, who is familiar with python and sip? There is a problem with python scripting described here: https://sourceforge.net/p/scidavis/scidavis-bugs/234/ maybe someone could help to solve this.

arcanis commented on 2014-02-10 17:43

@redshift
yep, thank you

redshift commented on 2014-02-10 09:13

Hi, I noticed that glu was needed to build. thanks.

arcanis commented on 2014-02-02 10:58

Oh, sorry, I tried build it with qwt and forgot edit dependencies list. Yep, qwt5 is needed, but not qwt

VDP76 commented on 2014-02-02 10:17

sirocco is right, qwt5 is needed. Please, add it to the depends in the PKGBUILD.

sirocco commented on 2014-02-02 09:58

without qwt5:
scidavis: error while loading shared libraries: libqwt5.so.1: cannot open shared object file: No such file or directory

arcanis commented on 2014-01-20 18:02

@Nonolapero
thanks. I'll upload the new version soon (when I have built it)

Nonolapero commented on 2014-01-20 14:55

A new project leader published a new version 1.D.1
http://sourceforge.net/projects/scidavis/files/SciDAVis/1.D1/

arcanis commented on 2013-09-12 18:59

added patch to fix building of fitting modules

arcanis commented on 2013-09-10 02:02

Dependencies were updated. Patch to fix bugs was added

mmm commented on 2013-04-27 20:41

This is not out-of-date (Apr/2013), but latest stable build is from 2010. Btw, QtiPlot (this forked from it) is in [extra]. Also consider RapidMiner..

vit commented on 2013-04-23 03:29

I'll consult with developers. But I'm not shure if will get the answer.

manouchk commented on 2013-04-22 18:47

If one substitute lupdate, lrelease and qmake in PKGBUILD respectively by lupdate-qt4, lrelease-qt4 and qmake-qt4, things go a bit further but soon fail by a compilation error.

manouchk commented on 2013-04-22 18:45

If one substitute lupdate, lrelease and qmake respectively by lupdate-qt4, lrelease-qt4 and qmake-qt4, things go a bit further but soon fail by a compilation error.

manouchk commented on 2013-04-19 05:11

On the forum, it was suggested that qt4 package contain lupdate-qt4 instead of lupdate. That maybe an idea in order to solve the problem.

manouchk commented on 2013-04-19 00:01

Scidavis fails to compile now. Missing the command "lupdate" which is not found by runnig pacman -Ss lupdate.

Polly commented on 2013-04-14 14:13

I recommend to check qtiplot, it fulfills many needs scidavis can manage. Unfortunately there's not much (or none at all?) movement in the development of scidavs.

Anonymous comment on 2012-03-04 01:48

Does anyone know what going on with this project. I really like it, but it seems to not be maintain much by upstream, or am I wrong.

Anonymous comment on 2012-01-10 15:59

If someone has a solution and wants to fix the package, I'll orphan.

Nonolapero commented on 2012-01-06 16:41

With python-pyqt 4.9 scidavis crashes at startup, it's necessary to downgrade python2-pyqt to 4.8.

Anonymous comment on 2011-11-05 20:21

Now available in the [archlinuxfr] repo.

Anonymous comment on 2011-08-06 22:16

Thank you, sidavis semms to need qwt5, wich is is the AUR, I'll upload an updated PKGBUILD soon.

mokasin commented on 2011-08-06 13:06

Doesn't compile on my system
In file included from src/scidavis.sip:851:0:
./src/Legend.h:36:23: fatal error: qwt_array.h: No such file or directory
compilation terminated.

If I install pyqwt and python-numarray I get one step further but then it doesn't find qwt_double_rect.h and so on.

Did I miss something?

Nonolapero commented on 2011-06-16 08:12

Scidavis need to be compiled with muparser 1.32 to avoid some bugs when opening file who contains fit functions.

Anonymous comment on 2011-06-05 13:12

Adopted and updated.

Anonymous comment on 2011-06-05 13:12

Updated

Polly commented on 2011-05-30 15:29

Scidavis depends on module mesa. Please add the dependency.

manouchk commented on 2011-05-26 23:39

I replaced extra/python2-qt by extra/python2-pyqt

It looks like there is a problem with a patch:
...
patching file python.pri
patch unexpectedly ends in middle of line
Hunk #1 succeeded at 19 with fuzz 1.
...

Anonymous comment on 2011-05-08 14:19

scidavis 0.2.4-5 needs python2-qt, but python2-qt was replaced by extra/python2-pyqt

manouchk commented on 2011-03-14 20:33

There is a recent bug, probably linked with the last update(at least it was not present in July of 2010), when loading a project with a fitted function represented in a graph. The functions are lost.

It gives an error pop-up window entitled "Input Function error" containing:
NonLinearFit1:0

Undefined token ";=978.16764340164;t0=23.022..........;x0+0.5*g*(x-t0)^2" found at position 21.

With two functions I got an error for each functions! My guess is that error may correspond to caracter "=" and "*", that wouldn be parsed well

Anonymous comment on 2011-01-23 10:56

Pleas change depency from "'pyqt>=4.2' 'sip>=4.6'" to "'python2-qt>=4.2' 'python2-sip>=4.6'"

Anonymous comment on 2010-10-24 22:51

Applied the suggested changes (with minor adjustments). Thanks.

manouchk commented on 2010-10-23 23:36

The pkgbuild proposed by robal works fine here when end-of-line caracters are fixed in order to be compatible with ABS. This package should be updated!

manouchk commented on 2010-10-23 23:35

The pkgbuild works fine here when end-of-line caracters are fixed in order to be compatible with ABS. This package should be updated!

Anonymous comment on 2010-10-22 13:43

here's a modified PKGBUILD:http://aur.pastebin.com/JT7xPBQM and here is a link to the patch:http://aur.pastebin.com/YwTGEJ7d
PS. sry for my english.

manouchk commented on 2010-10-22 11:02

Does not compile here after updating to python2 2.7.

It fails like that:

patching file scidavis.pro
patching file src/ApplicationWindow.cpp
/tmp/yaourt-tmp-manu/aur-scidavis/src/scidavis-0.2.4/scidavis/python.pri(5):replace(var, before, after) requires three arguments
File "python-includepath.py", line 5
print " ".join([sysconfig.get_python_inc(), config.sip_inc_dir])
^
SyntaxError: invalid syntax
File "<string>", line 1
from distutils import sysconfig; print '-lpython'+sysconfig.get_config_var('VERSION')
^
SyntaxError: invalid syntax
/tmp/yaourt-tmp-manu/aur-scidavis/src/scidavis-0.2.4/scidavis/python.pri(25):Function 'system' is not implemented

manouchk commented on 2010-10-21 20:57

Does not compile here after updating to python2 2.7.

It fail while patching!!

patching file scidavis.pro
patching file src/ApplicationWindow.cpp
/tmp/yaourt-tmp-manu/aur-scidavis/src/scidavis-0.2.4/scidavis/python.pri(5):replace(var, before, after) requires three arguments
File "python-includepath.py", line 5
print " ".join([sysconfig.get_python_inc(), config.sip_inc_dir])
^
SyntaxError: invalid syntax
File "<string>", line 1
from distutils import sysconfig; print '-lpython'+sysconfig.get_config_var('VERSION')
^
SyntaxError: invalid syntax
/tmp/yaourt-tmp-manu/aur-scidavis/src/scidavis-0.2.4/scidavis/python.pri(25):Function 'system' is not implemented

vit commented on 2010-10-19 04:07

Please update dependencies, python 2 now is in python2 package.

Anonymous comment on 2010-10-06 18:44

Hm, beats me why it worked during my first test run... revision 3 should compile now.

vit commented on 2010-10-06 14:19

The same. Can't compile.

Anonymous comment on 2010-10-06 14:09

Can't compile...

src/ApplicationWindow.cpp:138:28: fatal error: QAssistantClient: No such file or directory
compilation terminated.
make: *** [../tmp/scidavis/ApplicationWindow.o] Error 1

Anonymous comment on 2010-10-05 22:31

Added missing dependency. Thanks for the hint.

sirocco commented on 2010-10-05 07:45

Try to install qt-assistant-compat

Eded commented on 2010-10-05 03:40

Don't work with qt 4.7+