Package Details: scilab-git 6.2.0.r216.g81a9cc04933-1

Git Clone URL: https://aur.archlinux.org/scilab-git.git (read-only, click to copy)
Package Base: scilab-git
Description: A scientific software package for numerical computations.
Upstream URL: https://www.scilab.org
Licenses: GPL2, BSD, custom:CeCILL
Conflicts: scilab
Provides: scilab
Submitter: MRWITEK
Maintainer: bartus
Last Packager: bartus
Votes: 8
Popularity: 0.000000
First Submitted: 2013-05-09 17:05 (UTC)
Last Updated: 2021-07-22 10:22 (UTC)

Dependencies (37)

Required by (1)

Sources (8)

Pinned Comments

bartus commented on 2022-03-14 10:36 (UTC)

Sorry lads, I'm at the Polish Ukraine border helping allocate refugees. Expect no update until this hell is over, wish us luck. Have no time nor access to my rig and AUR keys to test/post updates. If you have a patch, ping me on email - I'll add you as co-maintainer. Posted with my old script - https://github.com/bartoszek/aur-post

bartus commented on 2020-06-21 21:48 (UTC)

This package is also hosted on GitHub.

Latest Comments

bartus commented on 2022-03-14 10:36 (UTC)

Sorry lads, I'm at the Polish Ukraine border helping allocate refugees. Expect no update until this hell is over, wish us luck. Have no time nor access to my rig and AUR keys to test/post updates. If you have a patch, ping me on email - I'll add you as co-maintainer. Posted with my old script - https://github.com/bartoszek/aur-post

Xwang commented on 2020-10-20 18:55 (UTC)

Today I get the following error while building the package:


File "./src/modelica_compiler/scicosOptimizingCompiler.ml", line 1:
Error: Files /usr/lib/ocaml/num/nums.cmxa and /usr/lib/ocaml/stdlib.cmxa
       make inconsistent assumptions over implementation Stdlib__sys
Command exited with non-zero status 2

Should I open a bug upstream? Is it an ocaml arch packaging issue?

bartus commented on 2020-06-21 21:48 (UTC)

This package is also hosted on GitHub.

eolianoe commented on 2018-11-15 16:01 (UTC)

@dkibet: That's because some patches are being merged by upstream cannot be applied anymore. I need to clean and check the PKGBUILD according to the latest sources but I do not have access to an Arch machine for now (I'll check the build as soon as possible)

dkibet commented on 2018-11-15 14:06 (UTC)

I am getting.

Hunk #1 FAILED at 735. 1 out of 1 hunk FAILED -- saving rejects to file modules/hdf5/sci_gateway/cpp/sci_hdf5_listvar_v3.cpp.rej ==> ERROR: A failure occurred in prepare().

what am i doing wrong?

the_ragi commented on 2018-04-04 15:10 (UTC)

I'm getting this error:

patching file modules/xcos/src/java/org/scilab/modules/xcos/palette/PaletteSearcher.java Hunk #1 FAILED at 52. 1 out of 2 hunks FAILED -- saving rejects to file modules/xcos/src/java/org/scilab/modules/xcos/palette/PaletteSearcher.java.rej

Any help/advice is appreciated

eolianoe commented on 2018-01-05 12:26 (UTC)

@elsuizo: it's building fine here, are you sure that arpack is installed?

elsuizo commented on 2017-12-11 01:17 (UTC)

I got this error:

configure: error: ARPACK library found, but seems not to work properly. Please make sure you are using arpack-ng

thanks in advance

eolianoe commented on 2017-01-24 10:14 (UTC)

@petronny: thanks for the lucene package. I will add the dependency when I will find a way to properly build the package

petronny commented on 2017-01-23 09:44 (UTC) (edited on 2017-01-26 15:43 (UTC) by petronny)

I have created a package called apache-lucene to fix the previous error. Please add it as a dependency. It can be compiled now, but still throws [javac] /build/scilab-git/src/scilab/scilab/modules/xcos/src/java/org/scilab/modules/xcos/palette/PaletteSearcher.java:55: error: no suitable method found for open(IndexWriter,boolean) No idea how to fix it...

petronny commented on 2017-01-23 07:32 (UTC)

I got this error, checking gluegen2-rt... /usr/share/java/jogl/gluegen2-rt.jar checking for Java_jogamp_common_jvm_JVMUtil_initialize in -lgluegen2-rt... yes checking jhall... /usr/share/java/javahelp/jhall.jar checking lucene-core... no configure: error: Could not find or use the Java package/jar lucene-core used by Lucene (looking for package org.apache.lucene.LucenePackage) But there is no package named lucene ,java-lucene etc. Please fix it

xyproto commented on 2015-10-30 20:32 (UTC)

java-commons-beanutils does not exist. Please update the PKGBUILD, if possible.

MRWITEK commented on 2014-09-08 17:06 (UTC)

Scilab currently can't build with up to date jogl so you can use the following link to build jogl-2.1.5 http://pkgbuild.com/git/aur-mirror.git/tree/jogl?id=14b88908976a71587de409d427ad6e58055de742 Also there is problem with suitesparse (umfpack) so if you need to you can downgrade that package and remove --without-umfpack line from PKGBUILD.

MRWITEK commented on 2014-09-06 15:27 (UTC)

Thank you, eolianoe! I used your fix for the PKGBUILD. Also I'll report a bug describing this. In other news, I somehow missed gcc-fortran dependency earlier.

eolianoe commented on 2014-09-03 16:33 (UTC)

With the new version of suitesparse (umfpack) you need to add a prepare function to build: prepare() { cd ${srcdir}/scilab/scilab/ # Temporary fix for the new version of suitesparse (4.3.1). sed -i "s/-lamd/-lamd -lsuitesparseconfig/g" configure sed -i "s/umf_divcomplex/SuiteSparse_divcomplex/g" configure }

MRWITEK commented on 2014-03-18 17:14 (UTC)

By default pacman uses extra/beanshell2. The jar shipping with sources by developers is from www.beanshell.org, though. Can't say if it breaks something.

giniu commented on 2014-03-16 21:10 (UTC)

can it depend on beanshell2 from extra instead of bsh, or bsh is needed?

holger commented on 2014-03-04 14:54 (UTC)

Can you add a desktop file? Just add this to your PKGBUILD install -Dm644 ${srcdir}/${pkgname}.desktop \ ${pkgdir}/usr/share/applications/${pkgname}.desktop scilab-git.desktop: [Desktop Entry] Name=Scilab Comment=A scientific software package for numerical computations Icon=scilab Exec=scilab Encoding=UTF-8 Terminal=false Type=Application Categories=Application;Science;Math

nervencid commented on 2013-06-03 23:19 (UTC)

No, the same problem: Problem when exporting Xcos schema /tmp/yaourt-tmp-diegonimus/aur-scilab/src/scilab-5.4.1/modules/xcos/help/en_US/solvers/../../../demos/Controller.xcos ! java.lang.reflect.InvocationTargetException java.lang.reflect.InvocationTargetException at sun.reflect.GeneratedMethodAccessor55.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:601) at org.scilab.modules.helptools.image.XcosImageConverter.convertToPNG(Unknown Source) at org.scilab.modules.helptools.image.XcosImageConverter.convertToImage(Unknown Source) at org.scilab.modules.helptools.image.ImageConverter.getImageByFile(Unknown Source) at org.scilab.modules.helptools.HTMLDocbookTagConverter.handleImagedata(Unknown Source) at sun.reflect.GeneratedMethodAccessor26.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:601) at org.scilab.modules.helptools.DocbookTagConverter.handleDocbookTag(Unknown Source) at org.scilab.modules.helptools.DocbookTagConverter.endElement(Unknown Source) at com.icl.saxon.aelfred.SAXDriver.endElement(SAXDriver.java:792) at com.icl.saxon.aelfred.XmlParser.parseElement(XmlParser.java:1042) at com.icl.saxon.aelfred.XmlParser.parseContent(XmlParser.java:1222) at com.icl.saxon.aelfred.XmlParser.parseElement(XmlParser.java:1037) at com.icl.saxon.aelfred.XmlParser.parseContent(XmlParser.java:1222) at com.icl.saxon.aelfred.XmlParser.parseElement(XmlParser.java:1037) at com.icl.saxon.aelfred.XmlParser.parseContent(XmlParser.java:1222) at com.icl.saxon.aelfred.XmlParser.parseElement(XmlParser.java:1037) at com.icl.saxon.aelfred.XmlParser.parseContent(XmlParser.java:1222) at com.icl.saxon.aelfred.XmlParser.parseElement(XmlParser.java:1037) at com.icl.saxon.aelfred.XmlParser.parseContent(XmlParser.java:1222) at com.icl.saxon.aelfred.XmlParser.parseElement(XmlParser.java:1037) at com.icl.saxon.aelfred.XmlParser.parseContent(XmlParser.java:1222) at com.icl.saxon.aelfred.XmlParser.parseElement(XmlParser.java:1037) at com.icl.saxon.aelfred.XmlParser.parseContent(XmlParser.java:1222) at com.icl.saxon.aelfred.XmlParser.parseElement(XmlParser.java:1037) at com.icl.saxon.aelfred.XmlParser.parseContent(XmlParser.java:1222) at com.icl.saxon.aelfred.XmlParser.parseElement(XmlParser.java:1037) at com.icl.saxon.aelfred.XmlParser.parseContent(XmlParser.java:1222) at com.icl.saxon.aelfred.XmlParser.parseElement(XmlParser.java:1037) at com.icl.saxon.aelfred.XmlParser.parseDocument(XmlParser.java:510) at com.icl.saxon.aelfred.XmlParser.doParse(XmlParser.java:163) at com.icl.saxon.aelfred.SAXDriver.parse(SAXDriver.java:320) at javax.xml.parsers.SAXParser.parse(SAXParser.java:392) at javax.xml.parsers.SAXParser.parse(SAXParser.java:328) at org.scilab.modules.helptools.DocbookTagConverter.convert(Unknown Source) at org.scilab.modules.helptools.SciDocMain.process(Unknown Source) Caused by: java.lang.NoClassDefFoundError: Could not initialize class org.scilab.modules.xcos.Xcos at org.scilab.modules.xcos.graph.XcosDiagram.installStylesheet(Unknown Source) at org.scilab.modules.xcos.graph.XcosDiagram.init(Unknown Source) at org.scilab.modules.xcos.utils.XcosDelegates.convertToPNG(Unknown Source) ... 39 more Problem when exporting Xcos schema /tmp/yaourt-tmp-diegonimus/aur-scilab/src/scilab-5.4.1/modules/xcos/help/en_US/solvers/../../../demos/Kalman.xcos ! java.lang.reflect.InvocationTargetException Warning: the macro loadmatfile is used in an example and is undocumented (load.xml). Warning (should be fixed): invalid internal link to loadmatfile in file:/tmp/yaourt-tmp-diegonimus/aur-scilab/src/scilab-5.4.1/modules/m2sci/help/en_US/matfile2sci.xml at line 53 Total files without example: 704 Total generated html files: 2618 An error occurred during the conversion: java.lang.NullPointerException at java.util.Arrays$ArrayList.init(Arrays.java:2842) at java.util.Arrays.asList(Arrays.java:2828) at org.scilab.modules.gui.utils.ScilabSwingUtilities.findThemeSubdir(Unknown Source) at org.scilab.modules.gui.utils.ScilabSwingUtilities.lookupIcon(Unknown Source) at org.scilab.modules.gui.utils.ScilabSwingUtilities.findIconHelper(Unknown Source) at org.scilab.modules.gui.utils.ScilabSwingUtilities.findIconHelper(Unknown Source) at org.scilab.modules.gui.utils.ScilabSwingUtilities.findIconHelper(Unknown Source) at org.scilab.modules.gui.utils.ScilabSwingUtilities.findIcon(Unknown Source) at org.scilab.modules.gui.utils.ScilabSwingUtilities.findIcon(Unknown Source) at org.scilab.modules.helptools.SciDocMain.process(Unknown Source) xmltoformat: /tmp/yaourt-tmp-diegonimus/aur-scilab/src/scilab-5.4.1/modules/helptools/javaHelp/scilab_en_US_help/ scilab_en_US_help.jar has not been generated. make: *** [doc] Error 1

MRWITEK commented on 2013-06-02 21:40 (UTC)

This is wild guess but you can try to install and configure gtk2 theme, like: https://aur.archlinux.org/packages/clearlooks-phenix-gtk-theme-git/ manual: https://awesome.naquadah.org/wiki/Customizing_GTK_Apps

nervencid commented on 2013-06-02 18:42 (UTC)

Thank you a lot for your answer, but this error continues: Problem when exporting Xcos schema /tmp/yaourt-tmp-diegonimus/aur-scilab-git/src/scilab/scilab/modules/xcos/help/en_US/solvers/../../../demos/Kalman.zcos ! java.lang.reflect.InvocationTargetException Warning: the macro loadmatfile is used in an example and is undocumented (load.xml). Warning (should be fixed): invalid internal link to loadmatfile in file:/tmp/yaourt-tmp-diegonimus/aur-scilab-git/src/scilab/scilab/modules/m2sci/help/en_US/matfile2sci.xml at line 53 Total files without example: 709 Total generated html files: 2741 An error occurred during the conversion: java.lang.NullPointerException at java.util.Arrays$ArrayList.<init>(Arrays.java:2842) at java.util.Arrays.asList(Arrays.java:2828) at org.scilab.modules.gui.utils.ScilabSwingUtilities.findThemeSubdir(Unknown Source) at org.scilab.modules.gui.utils.ScilabSwingUtilities.lookupIcon(Unknown Source) at org.scilab.modules.gui.utils.ScilabSwingUtilities.findIconHelper(Unknown Source) at org.scilab.modules.gui.utils.ScilabSwingUtilities.findIconHelper(Unknown Source) at org.scilab.modules.gui.utils.ScilabSwingUtilities.findIconHelper(Unknown Source) at org.scilab.modules.gui.utils.ScilabSwingUtilities.findIcon(Unknown Source) at org.scilab.modules.gui.utils.ScilabSwingUtilities.findIcon(Unknown Source) at org.scilab.modules.helptools.SciDocMain.process(Unknown Source) xmltoformat: /tmp/yaourt-tmp-diegonimus/aur-scilab-git/src/scilab/scilab/modul es/helptools/javaHelp/scilab_en_US_help/scilab_en_US_help.jar has not bee n generated. make: *** [doc] Error 1

MRWITEK commented on 2013-06-02 14:45 (UTC)

And, of course, it works!

MRWITEK commented on 2013-06-02 14:42 (UTC)

Thank you for your feedback. Yes, all of this dependencies needed at buildtime and/or runtime but currently I have no free time for determining which of these are for buildtime only. Anyway, I used all needed dependencies from build instruction and found out which packages are in prerequirements tarball from the official site. It took quite much time. Now the package should build for everybody. Finally.

nervencid commented on 2013-06-02 03:29 (UTC)

Thank you for our answer, i apreciate it a lot: There are a lot of dependences, excuse me for my ignorance on linux but, thats is necessary? But finally got this message: Use external version of scirenderer checking flexdock... /usr/share/java/flexdock/flexdock.jar checking minimal version (1.2.3) of flexdock... configure: error: Wrong version of flexdock. Expected at least 1.2.3. Found 1.2.0 Thank you for your answer

MRWITEK commented on 2013-05-29 14:18 (UTC)

My apologies for old mistakes about getting sources from SourceForge.net. Everything is should be fixed. jgoodies-looks package successfully builds on my side all this time.

nervencid commented on 2013-05-29 04:31 (UTC)

I re downloaded the package but i get this error now: Failed to connect to 2001:1ab0:7e1f:1:230:48ff:fed1:9c0a: La red es inaccesible when downloading offo-hyphenation-binary_v2.0.zip... but i don't know my internet connection is working fine....

MRWITEK commented on 2013-05-28 09:12 (UTC)

Can't reproduce this. Maybe you have corrupted download. Please, check if redownloading works.

nervencid commented on 2013-05-27 22:57 (UTC)

jgoodies-looks-2_5_3.zip failed integrity validation One o more packages didn't passed integrity verification

MRWITEK commented on 2013-05-25 21:18 (UTC)

Fixed.

nervencid commented on 2013-05-25 20:11 (UTC)

There is a problem with this package: docbook-xsl-saxon-1.00.tar.bz2 I couldn't download it