Package Details: scotch-mpich 6.0.5a-1

Git Clone URL: https://aur.archlinux.org/scotch-mpich.git (read-only)
Package Base: scotch-mpich
Description: Software package and libraries for graph, mesh and hypergraph partitioning, static mapping, and sparse matrix block ordering. This is the parallel version using the MPICH implementation (MPICH/ptesmumps).
Upstream URL: http://www.labri.fr/perso/pelegrin/scotch/
Licenses: custom:CeCILL-C
Conflicts: ptscotch-mpich, scotch
Provides: ptscotch-mpich, scotch
Submitter: eleftg
Maintainer: haawda
Last Packager: haawda
Votes: 1
Popularity: 0.000000
First Submitted: 2015-03-05 06:58
Last Updated: 2018-06-21 20:05

Dependencies (4)

Required by (16)

Sources (1)

Latest Comments

sigvald commented on 2018-06-21 09:47

This package has the same problem as the package just called scotch, namely it will give you an error if you have less than 4 cores. You must add the --oversubscribe flag to mpirun. I changed check() in PKGBUILD to the following:

check() {
  cd "${srcdir}/scotch_${pkgver}/src"

  sed -i 's/mpirun/mpirun --oversubscribe/' check/Makefile

  make ptcheck LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:../../lib"
}

(One could of course also change one of the lines in prepare)