Package Details: screencloud 1.3.1-3

Git Clone URL: https://aur.archlinux.org/screencloud.git (read-only)
Package Base: screencloud
Description: Easy to use screenshot sharing application.
Upstream URL: https://github.com/olav-st/screencloud
Licenses: GPL2
Conflicts: screencloud-git
Provides: screencloud-git=1.3.1
Submitter: lybin
Maintainer: lybin
Last Packager: lybin
Votes: 34
Popularity: 3.107781
First Submitted: 2012-09-24 12:40
Last Updated: 2016-08-21 11:24

Latest Comments

grochat commented on 2016-08-21 10:34

Fail if cmake is not present.

SunRed commented on 2016-08-16 23:57

Error when opening with SFTP module installed - even with python-crypto:

Error in file: /home/XXX/.local/share/screencloud/ScreenCloud/plugins/sftp/main.py
Traceback (most recent call last):
File "<string>", line 5, in <module>
File "/home/XXX/.local/share/screencloud/ScreenCloud/plugins/sftp/modules/paramiko/__init__.py", line 30, in <module>
from paramiko.transport import SecurityOptions, Transport
File "/home/XXX/.local/share/screencloud/ScreenCloud/plugins/sftp/modules/paramiko/transport.py", line 50, in <module>
from paramiko.dsskey import DSSKey
File "/home/XXX/.local/share/screencloud/ScreenCloud/plugins/sftp/modules/paramiko/dsskey.py", line 26, in <module>
from Crypto.PublicKey import DSA
ImportError: No module named 'Crypto.PublicKey'

Bermond commented on 2015-11-12 19:27

I'm also getting this error when installing with packer:
error: 'screencloud-1.2.0-2-x86_64.pkg.tar.xz': duplicate target

lybin commented on 2015-10-30 23:57

If you know how to fix - show me diff. I don't use aura. Thank you.

s0r00t commented on 2015-10-30 18:17

Building fails with Aura, check https://github.com/aurapm/aura/issues/14.

"When I built it, I got this: error: '/var/cache/pacman/pkg/screencloud-1.2.0-1-64.pkg.tar.xz': duplicate target

Notice the difference? This file here is actually a source file, as defined in the PKGBUILD. After building, aura copies files that match .pkg.tar.xz and tries to install them. For this file to be named in the same way as built packages is the cause of the problem here."

lybin commented on 2015-02-15 15:31

updated

orschiro commented on 2015-01-21 15:05

Should xrandr be a dependency? I get the following message during build process:

Checking for xrandr .. [failure]

remhume commented on 2014-06-14 13:35

i needed to install the package 'python2-crypto' additionally so that the SFTP-upload won't crash.
i guess that should be added to the dependencies - correct me if i'm wrong.

olav_st commented on 2014-03-31 18:10

Author here, just wanted to point out that some dependencies are no longer required. The current dependencies are: 'qt4' 'quazip' 'libqxt' 'python2' while 'python2-crypto' is optional.

kmicu commented on 2014-03-28 15:34

"skips validation because package updated, but version not changed"
It skips validation, because you have md5sums=('SKIP') in PKGBUILD.
You shoud have e.g. md5sums=('3dd2f2b7dc4e1859cfd13b16e0dc7cc7') (for current x86_64 version)

This is proper PKGBUILD's validation part with sums checking for current version:
https://www.refheap.com/67395

"To ensure the security of pkgs submitted to the AUR please ensure that you have correctly filled the md5sum field. The md5sum's can be generated using the updpkgsums command." [1]

[1] https://wiki.archlinux.org/index.php/Arch_Packaging_Standards#Submitting_packages_to_the_AUR

All comments