Package Details: sdbus-cpp 0.8.3-4

Git Clone URL: https://aur.archlinux.org/sdbus-cpp.git (read-only, click to copy)
Package Base: sdbus-cpp
Description: sdbus-c++ is a high-level C++ D-Bus library for Linux designed to provide expressive, easy-to-use API in modern C++
Upstream URL: https://github.com/Kistler-Group/sdbus-cpp
Licenses: LGPL2.1
Conflicts: sdbus-cpp-git
Submitter: cirk2
Maintainer: cirk2
Last Packager: cirk2
Votes: 9
Popularity: 1.33
First Submitted: 2019-11-29 23:39
Last Updated: 2021-07-15 06:59

Latest Comments

cirk2 commented on 2021-07-05 22:42

that is strange, the dependency for systemd-libs is there. So libsystemd should be installed at build and runtime.

yeah ok the pkgconfig for libsystemd is in the systemd package...

bartus commented on 2021-07-04 11:29

Missing systemd in makedepends array.

-- Checking for module 'libsystemd>=236'
--   Package 'libsystemd', required by 'virtual:world', not found
CMake Error at CMakeLists.txt:21 (message):
  libsystemd of version at least 236 is required, but was not found (you may
  turn BUILD_LIBSYSTEMD on for sdbus-c++ to try downloading and building
  libsystemd in as part of sdbus-c++ during configuration)

cirk2 commented on 2021-05-27 11:29

TIL: git isn't in base-devel

nullobsi commented on 2021-05-23 23:27

Could you please add git as a make dependency to this and the git version?

cirk2 commented on 2020-11-04 09:08

The next version will most likely contain a custom exception to the base LGPL Licence (see https://github.com/Kistler-Group/sdbus-cpp/blob/master/COPYING-LGPL-Exception) 0.8.3 was tagged right before that change.

vsemyonoff commented on 2020-02-02 21:59

Thank you

vsemyonoff commented on 2020-02-02 19:31

Please add doxygen to build time dependency list because makepkg fails without it or disable documentation generation while building package.