Package Details: sdl2_compat12-git r285.646ecd7-1

Git Clone URL: https://aur.archlinux.org/sdl2_compat12-git.git (read-only, click to copy)
Package Base: sdl2_compat12-git
Description: Provides a binary-compatible API for programs written against SDL 1.2, but it uses SDL 2.0 behind the scenes.
Upstream URL: https://github.com/libsdl-org/sdl12-compat.git
Licenses: zlib
Conflicts: sdl
Provides: sdl
Submitter: archi42
Maintainer: archi42 (PedroHLC)
Last Packager: archi42
Votes: 2
Popularity: 0.000003
First Submitted: 2020-03-01 19:10 (UTC)
Last Updated: 2021-08-13 22:13 (UTC)

Required by (445)

Sources (3)

Pinned Comments

archi42 commented on 2020-03-01 19:55 (UTC)

Careful: I tested the lib32 variant of this with UT99, and while a lot of the game works, some parts aren't exactly great (e.g. crash on Alt+Tab and mouse look is bounded by the mouse reaching the screen border; didn't try a lot of gaming due to that). You're probably better off with the full sdl 1.2!

Latest Comments

1 2 Next › Last »

archi42 commented on 2021-08-13 22:15 (UTC)

@autumnontape Thanks for testing this. I've added armv7h as a supported arch.

autumnontape commented on 2021-08-13 19:54 (UTC)

I've built this package on an armv7h Arch Linux ARM device and am using it without problems (barring ones that are also present on my x86_64 laptop, of course, this still being alpha-quality software). Would you consider adding armv7h to the archs?

PedroHLC commented on 2021-05-30 00:38 (UTC)

Hi @pix3l, sorry, my mistake, I had tested with and without DCMAKE_INSTALL_PREFIX before, and both were installing in /usr. But looks like that changed upstream with commit 848ad42. I'll fix ASAP.

pix3l commented on 2021-05-30 00:31 (UTC)

diff --git a/PKGBUILD b/PKGBUILD index e994847..5246820 100644 --- a/PKGBUILD +++ b/PKGBUILD @@ -25,7 +25,7 @@ pkgver() {

build() { cd sdl12-compat - cmake . + cmake -DCMAKE_INSTALL_PREFIX=/usr . make }

otherwise it will get installed into /usr/local

resolving dependencies... looking for conflicting packages... :: sdl2_compat12-git and sdl are in conflict. Remove sdl? [y/N] y error: failed to prepare transaction (could not satisfy dependencies) :: removing sdl breaks dependency 'sdl=1.2.15' required by perl-alien-sd

archi42 commented on 2021-05-25 23:23 (UTC) (edited on 2021-05-25 23:28 (UTC) by archi42)

Hi @PedroHLC, sorry for not checking back with you. I'll add you as a Co-Maintainer. Feel free to apply your suggested updates. See also lib32-sdl2_compat12-git :)

PedroHLC commented on 2021-05-25 23:09 (UTC) (edited on 2021-05-25 23:13 (UTC) by PedroHLC)

Hi @archi42.

As I said previously, you can drop the prepare, and COPYING is now named LICENSE.txt. Now, there is a new dependency: "glu".

I would like again to suggest changing line 42 to: make DESTDIR="$pkgdir" install That should make the PKGBUILD update-proof.

If you don't have the time, please add me as a collaborator, and I will apply those changes...

PedroHLC commented on 2021-03-13 12:51 (UTC)

Seems like the patches aren't required anymore. And "COPYING" was renamed to "LICENSE.txt".

Also, any special reason to not use make DESTDIR=... install?

archi42 commented on 2021-02-14 22:49 (UTC)

@shoober420: Thanks for the hint! I've updated the PKGBUILD accordingly.

@dreieck: I've updated the PKGBUILD. Sorry for the late action, it seems the notification got lost somewhere or I just forgot about it :(

I applied both changes to this package and the lib32 variant as well.

shoober420 commented on 2021-02-14 16:18 (UTC) (edited on 2021-02-14 16:18 (UTC) by shoober420)

@archi42 Could you please update the source link to “git+https://github.com/libsdl-org/sdl12-compat

Thank you for this package. This is a really cool alternative when a program you like hasn’t updated to sdl2 yet. Freesynd and uhexen2 come to mind.

I highly recommend the UT469 patch to play UT.

https://github.com/OldUnreal/UnrealTournamentPatches

dreieck commented on 2020-05-28 21:24 (UTC)

Can you change

provides=('sdl')

to something like

provides=('sdl=<version>')?

sdl_mixer and sdl_image for example do depend on sdl>=1.2.12 and sdl>=1.2.13, respectively.