Package Details: sendemail 1.56-1

Git Clone URL: https://aur.archlinux.org/sendemail.git (read-only)
Package Base: sendemail
Description: A lightweight command line SMTP email client written in Perl
Upstream URL: http://caspian.dotconf.net/menu/Software/SendEmail/
Licenses: GPL
Submitter: lp76
Maintainer: severach
Last Packager: severach
Votes: 24
Popularity: 0.427351
First Submitted: 2006-10-31 11:55
Last Updated: 2015-07-08 23:04

Latest Comments

bluelupo commented on 2015-12-31 15:26

Hi Maintainer,

when you run the "sendEmail" program the following error occurs:

invalid SSL_version specified at /usr/share/perl5/vendor_perl/IO/Socket/SSL.pm line 568.

Installing sendEmail via yaourt went smoothly and an error did not occur.

system infos:
# pacman -Qi sendemail
Name : sendemail
Version : 1.56-1
Beschreibung : A lightweight command line SMTP email client written in Perl
Architektur : i686
URL : http://caspian.dotconf.net/menu/Software/SendEmail/
Lizenzen : GPL
Gruppen : Nichts
Stellt bereit : Nichts
Hängt ab von : perl perl-net-ssleay perl-io-socket-ssl
Optionale Abhängigkeiten: Nichts
Benötigt von : Nichts
Optional für : Nichts
In Konflikt mit : Nichts
Ersetzt : Nichts
Installationsgröße : 79,00 KiB
Packer : Unknown Packager
Erstellt am : Do 31 Dez 2015 15:55:21 CET
Installiert am : Do 31 Dez 2015 15:55:32 CET
Installationsgrund : Ausdrücklich installiert
Installations-Skript : Nein
Verifiziert durch : Nichts

# uname -r
4.3.3-3-MANJARO

Regards
bluelupo

connaisseur commented on 2014-11-01 07:52

Got hit (AGAIN!) by some SSLv3 Version wrong issue.

Found that the Debian Guys got a fix for this. With this fix it works for me, finally. Created a new PKGBUILD and placed it on pastebin.com:

http://pastebin.com/GAd7ZwQK

Enjoy!

psytoolkit commented on 2014-09-21 18:11

This package had problems. I wrote a similar programme, called send_email_via_smtp, which is now also on AUR.

psytoolkit commented on 2014-07-01 12:53

Instead of this package, smpt-cli works without problems.

psytoolkit commented on 2014-07-01 11:31

The patch link does not work. What does it mean to "restrict perl-io-socket-ssl<=1.66", I do not know how to deal with that.

connaisseur commented on 2013-04-15 05:42

Guys,

with latest perl-io-socket-ssl release the patch to sendEmail has to look like this:

diff -ruN a/sendEmail-v1.56/sendEmail.pl b/sendEmail-v1.56/sendEmail.pl
--- a/sendEmail-v1.56/sendEmail.pl 2009-09-29 18:25:27.000000000 +0200
+++ b/sendEmail-v1.56/sendEmail.pl 2013-04-15 07:28:22.543469705 +0200
@@ -1903,7 +1903,7 @@
if ($conf{'tls_server'} == 1 and $conf{'tls_client'} == 1 and $opt{'tls'} =~ /^(yes|auto)$/) {
printmsg("DEBUG => Starting TLS", 2);
if (SMTPchat('STARTTLS')) { quit($conf{'error'}, 1); }
- if (! IO::Socket::SSL->start_SSL($SERVER, SSL_version => 'SSLv3 TLSv1')) {
+ if (! IO::Socket::SSL->start_SSL($SERVER, SSL_version => 'SSLv3', SSL_verify_mode => '0')) {
quit("ERROR => TLS setup failed: " . IO::Socket::SSL::errstr(), 1);
}
printmsg("DEBUG => TLS: Using cipher: ". $SERVER->get_cipher(), 3);

graysky commented on 2013-04-10 15:29

Thanks galaux.
@lp76 - Please update: https://gist.github.com/graysky2/5355647

galaux commented on 2013-04-06 20:52

Or in the meantime, here is the patch that makes it:

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/net-mail/sendEmail/files/1.56-overzealous-version-check.patch?view=markup

graysky commented on 2013-01-16 14:44

You should restrict perl-io-socket-ssl<=1.66 as newer versions break functionality. The author has been emailed on 01-Jan-2013.