Package Details: session-desktop 1.6.7-1

Git Clone URL: https://aur.archlinux.org/session-desktop.git (read-only, click to copy)
Package Base: session-desktop
Description: Private messaging from your desktop
Upstream URL: https://getsession.org
Keywords: loki messenger session signal
Licenses: GPL-3.0
Conflicts: session-desktop-appimage, session-desktop-bin, session-desktop-git
Provides: session-messenger-desktop
Submitter: xXR01I1Xx
Maintainer: sperg512
Last Packager: sperg512
Votes: 5
Popularity: 0.047558
First Submitted: 2020-03-23 07:39
Last Updated: 2021-07-05 16:22

Latest Comments

1 2 3 Next › Last »

odd-1 commented on 2021-06-15 11:47

Hope your exams went well!

Unfortunatelly, at the step packaging platform=linux arch=x64 electron=8.2.0 appOutDir=release/linux-unpacked targets [ 'tar.xz' ]

this error: ⨯ Cannot read property 'options' of undefined stackTrace= TypeError: Cannot read property 'options' of undefined at module.exports (/var/tmp/pamac-build-user/session-desktop/src/session-desktop/build/afterPackHook.js:19:38) at Packager.afterPack (/var/tmp/pamac-build-user/session-desktop/src/session-desktop/node_modules/app-builder-lib/src/packager.ts:541:29)

Can/should I do something and if yes, what?

sperg512 commented on 2021-05-25 13:02

sorry I've been busy with exams, I'll push out a new PKGBUILD in a few hours once I'm done

alexnortung commented on 2021-05-24 17:48

Installing does not work at the moment. I get an error:

error session-desktop@1.6.3: The engine "node" is incompatible with this module. Expected version "^10.19.0". Got "10.13.0"
error Found incompatible module.

It seems like the PKGBUILD is installing the 10.13.0 version of node. But for some reason it expects 10.19.0.

trizen commented on 2021-05-23 19:39

I got this error:

[1/6] Validating package.json...
error session-desktop@1.6.3: The engine "node" is incompatible with this module. Expected version "^10.19.0". Got "10.13.0"
error Found incompatible module.

By changing 10.13.0 to 10.19.0 in PKGBUILD (lines 24 and 29), the issue is fixed.

power_frontier commented on 2021-04-06 01:12

I get an error:

electron-builder version=22.3.6 os=5.4.105-1-MANJARO • loaded configuration file=package.json ("build" field) • rebuilding native dependencies dependencies=@journeyapps/sqlcipher@4.0.0, node-sass@4.9.3 platform=linux arch=x64 • packaging platform=linux arch=x64 electron=8.2.0 appOutDir=release/linux-unpacked • building target=tar.xz arch=x64 file=release/session-desktop-linux-x64-1.5.0.tar.xz ==> Entrando en entorno fakeroot... ==> Iniciando package()... tar: /var/tmp/pamac-build-frontier/session-desktop/src/session-desktop/release/session-desktop-linux-x64-1.5.2.tar.xz: No se puede efectuar open: No existe el fichero o el directorio tar: Error is not recoverable: exiting now ==> ERROR: Se produjo un fallo en package(). Cancelando...

Any clue?

sperg512 commented on 2021-03-19 07:42

@AverytheFurry the package itself doesnt install config files in user home directories, that's just done on first launch

AverytheFurry commented on 2021-03-19 06:00

Removing ~/.config/Session & then reinstalling fixed it!

AverytheFurry commented on 2021-03-19 05:54

Thanks for updating the package! It seems there's some issues though with old user data converting to the new version. paru -Rns does not remove the user data for some reason, maybe this is something that could be fixed in the package configuration? I'm not very knowledgable about packages. Thank you very much for maintaining!

AverytheFurry commented on 2021-03-18 04:10

Much appreciated! Hopefully it works!

sperg512 commented on 2021-03-18 02:10

@AverytheFurry yes, tried it a few days ago but there was some other error with building, then i had to sleep and kinda forgot about it. Later I'll try and fix it again.