Package Details: setools 4.1.1-3

Git Clone URL: https://aur.archlinux.org/setools.git (read-only)
Package Base: setools
Description: Policy analysis tools for SELinux
Upstream URL: https://github.com/SELinuxProject/setools/wiki
Keywords: selinux
Licenses: GPL, LGPL
Groups: selinux
Conflicts: selinux-setools
Provides: selinux-setools=4.1.1-3
Submitter: Siosm
Maintainer: IooNag
Last Packager: IooNag
Votes: 17
Popularity: 0.000256
First Submitted: 2013-11-03 20:05
Last Updated: 2018-09-16 11:53

Dependencies (20)

Sources (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

xangelux commented on 2013-02-11 06:00

Can't build it, as the other user says needs a bunch of things to build, does it need an update?

Siosm commented on 2012-05-06 09:50

-optdepends=('glib2:needed to build graphical tools'
-'gtk2>=2.8:needed to build graphical tools'
-'bwidget>=1.8:needed to build graphical tools')
+optdepends=('glib2: needed to build graphical tools'
+'gtk2>=2.8: needed to build graphical tools'
+'bwidget>=1.8: needed to build graphical tools')

Siosm commented on 2012-05-06 09:47

-optdepends=('glib2:needed to build graphical tools'
-'gtk2>=2.8:needed to build graphical tools'
-'bwidget>=1.8:needed to build graphical tools')
+optdepends=('glib2: needed to build graphical tools'
+'gtk2>=2.8: needed to build graphical tools'
+'bwidget>=1.8: needed to build graphical tools')

Nicky726 commented on 2011-12-14 13:25

Thanx, addopted your changes now builds fine.

chenxiaolong commented on 2011-12-12 06:48

Nevermind. It seems that running 'autoreconf -vfi' is required before the patches will work. Here's my fixed PKGBUILD with the patches from the links below: http://pastie.org/3003770

chenxiaolong commented on 2011-12-12 05:44

I can't seem to get patch '0006-Changes-to-support-named-file_trans-rules.patch' to work though :(

chenxiaolong commented on 2011-12-12 05:38

Link to source RPM: http://koji.fedoraproject.org/koji/buildinfo?buildID=273744

chenxiaolong commented on 2011-12-12 05:37

@Nicky726: Could you add the patches from the Fedora source RPM? http://koji.fedoraproject.org/koji/rpminfo?rpmID=2789748

That should fix the incompatibility issue.

Anonymous comment on 2011-11-28 19:04

sys: arch 3.1.2 x86_64. as advised: downloaded selinux all 20111128, tar, makepkg -s
all selinux packages installed except sysvinit (and setools)
same error as ajes 20111015

ajes commented on 2011-10-15 17:14

checking for corrected libsepol boolean expand behavior... configure: error: this version of libsepol is incompatible with SETools
==> ERROR: A failure occurred in build().