Package Details: setzer-git 0.4.1.r32.gf99cef8-1

Git Clone URL: https://aur.archlinux.org/setzer-git.git (read-only, click to copy)
Package Base: setzer-git
Description: LaTeX editor written in Python with Gtk
Upstream URL: https://www.cvfosammmm.org/setzer/
Keywords: editor gtk latex python text writer
Licenses: GPL3
Conflicts: setzer
Provides: setzer
Submitter: FalkAlexander
Maintainer: haawda
Last Packager: haawda
Votes: 4
Popularity: 0.001139
First Submitted: 2019-10-24 17:16 (UTC)
Last Updated: 2021-11-02 08:22 (UTC)

Latest Comments

1 2 Next › Last »

haawda commented on 2021-03-20 15:20 (UTC)

Download url dos not work, but because thi package is named -git, you should pull from the git repo anyway.

juxuanu commented on 2021-03-04 11:19 (UTC)

@halcek I checked one by one the mentioned needed packages' equivalents for Arch in the Readme and added them to the PKGBUILD.

Let me know if something else is needed! :-)

halcek commented on 2021-03-04 10:11 (UTC)

@juxuanu Oh, sorry, I remembered that incorrectly, just checked https://github.com/cvfosammmm/Setzer again, it should be 'python-gobject', gtksourceview3 should be 'gtksourceview4', and 'gettext' is another needed dependancy according to the readme there.

juxuanu commented on 2021-03-03 10:48 (UTC)

@halcek I just pushed the architecture change. About the dependency, how do you know it is needed?

halcek commented on 2021-03-03 09:23 (UTC)

@juxuanu Thank you for adopting the package, can you change to arch=('any') in the PKGBUILD, so that the package can also be built on ARM devices?

Also, 'pydf' should also be added into depends= ,.

juxuanu commented on 2021-02-28 16:24 (UTC) (edited on 2021-02-28 16:25 (UTC) by juxuanu)

This package was orphanated. I took the package as a maintainer and updated the missing dependency and the version.

I'm thinking about making the version follow the tagged releases instead of the latest commit.

Let me know if something's missing or wrong. :-)

haawda commented on 2021-02-13 10:15 (UTC)

The architecture should be arch=('any').

juxuanu commented on 2021-02-12 23:08 (UTC)

This PKGBUILD is missing a dependency. Add 'python-pdfminer' to the depends array.

archisman commented on 2021-02-07 07:06 (UTC)

I get this error the following errors when I try to run it.

ValueError: Namespace GtkSource not available for version 4

and

ModuleNotFoundError: No module named 'pdfminer'

I was able to fix it after editing the PKGBUILD

depends=('gtk3' 'gtksourceview4' 'poppler-glib' 'texlive-core' 'gspell' 'python-pyxdg' 'python-pdfminer')

I still get the following error, but at least the program seems to work

** (setzer:178432): WARNING **: 12:34:11.098: Error loading plugin: libnuspell.so.4: cannot open shared object file: No such file or directory