Package Details: sfxr 1.2.1-5

Git Clone URL: https://aur.archlinux.org/sfxr.git (read-only)
Package Base: sfxr
Description: Random sound effect generator for games, etc.
Upstream URL: http://www.drpetter.se/project_sfxr.html
Keywords: audio effects generator sfx sound
Licenses: MIT
Submitter: severach
Maintainer: severach (csolisr)
Last Packager: csolisr
Votes: 6
Popularity: 0.365190
First Submitted: 2015-08-10 06:29
Last Updated: 2015-08-26 15:31

Latest Comments

mis commented on 2016-06-28 13:57

Just some improvement suggestions for the PKGBUILD.

The install file isn't needed anymore. Superseded by gtk-update-icon-cache pacman hook.

Adding this to the package() function installs the license provided in the readme file:
grep -A 21 "Copyright" readme.txt > LICENSE
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"

The hicolor-icon-theme dependency isn't mandatory, pulled in by gtk3.

sekret commented on 2015-08-27 11:30

Thanks for the update! Unfortunately I forgot one thing, but it's not THAT important:

In PKGBUILDs, using || return 1 isn't required anymore, in fact it's been a long time since this got deprecated. So this doesn't require a pkgrel bump, but please just remove it.

sekret commented on 2015-08-23 18:39

Your default build function builds the package with gtk3 as a dependency. So you should change one of them! :)