Package Details: shadow-beta 0.7.6-8

Git Clone URL: https://aur.archlinux.org/shadow-beta.git (read-only)
Package Base: shadow-beta
Description: Shadow launcher
Upstream URL: http://shadow.tech
Licenses: unknown
Provides: shadow-beta
Submitter: agentcobra
Maintainer: agentcobra
Last Packager: agentcobra
Votes: 4
Popularity: 1.193879
First Submitted: 2018-07-11 07:49
Last Updated: 2018-09-20 06:01

Pinned Comments

Nover commented on 2018-09-19 22:55

Hey guys ! The node Warnings doesn't block the usage of the app, don't worry.

After the installation, you may experience issues as the app does not support NVIDIA GPU right now, and moreover needs a good VA API installation. This can't be done on this package, that is why a tutorial has been written for you, Linux users: https://nicolasguilloux.github.io/blade-shadow-beta/

We will be more careful for the next release. I created a bunch of VM to test it but as the app directly talks to the GPU, it's pretty hard to debug. Please, visit the git of the Linux Community on Shadow, and report your issues on the Discord of your country. ;)

Latest Comments

brando56894 commented on 2018-09-23 21:43

Ah, that explains the freezes on both my laptop and my server, laptop has an mx940 and my server has a GTX 1070.

agentcobra commented on 2018-09-20 06:08

it's a beta package for a beta apps. I'm trying to maintain it and be usable release after release

Nover commented on 2018-09-19 22:55

Hey guys ! The node Warnings doesn't block the usage of the app, don't worry.

After the installation, you may experience issues as the app does not support NVIDIA GPU right now, and moreover needs a good VA API installation. This can't be done on this package, that is why a tutorial has been written for you, Linux users: https://nicolasguilloux.github.io/blade-shadow-beta/

We will be more careful for the next release. I created a bunch of VM to test it but as the app directly talks to the GPU, it's pretty hard to debug. Please, visit the git of the Linux Community on Shadow, and report your issues on the Discord of your country. ;)

brando56894 commented on 2018-09-18 20:23

@LeifJohannson

Try and run shadow-beta from the console and see if you get this same error

(node:4977) UnhandledPromiseRejectionWarning: Unhandled promise rejection (rejection id: 1): Error: kill ESRCH

Edit:

It looks like the "fixing" step fails and the needed libraries aren't available, hence the crash.

In /usr/lib/ I only had libjson-c.so.4 instead of libjson-c.so.3 and I didn't even have a copy of libubsan.so.0 in there.

Once I moved them into place, and hit the "start" button I was greeted with the login screen!...And then X or Linux itself froze because I had to do a hard reboot :-/ I still saw the above node error though.

LeifJohansson commented on 2018-09-17 17:45

The program installs fine, i just cant connect to the shadow server. Am i the only one with this problem? Since this basically stops me from using Arch as my main OS. So any help or guidance is welcome.

brando56894 commented on 2018-09-17 01:40

Where did you see that GCC v5.x was required? It's pretty odd for a program to require two versions of GCC, especially a new program. I tried a few times to get v5 to compile but it keeps failing, it's also a massive package to compile, even with a fast machine.

Just for the hell of it, I removed that dependency and the package compiled without issue (well I'll get to that in a sec). I then started the app and it works perfectly (well it opens, it won't connect, so it may be still missing a few dependencies), so I don't thing GCC5 is required at all, which massively cuts down on the installation time.

One more general recommendation, please don't use spaces (use underscores or hyphens) and capitals in path names, it makes things more difficult than they should be since Linux is case sensitive. IDK if this is just a pet peeve of mine, but I hate it.

agentcobra commented on 2018-09-16 09:11

fixed

brando56894 commented on 2018-09-16 08:50

gcc54 should be updated to gcc5 since gcc54 no longer exists