Package Details: shinysdr-git r1040.57890d3-1

Git Clone URL: https://aur.archlinux.org/shinysdr-git.git (read-only, click to copy)
Package Base: shinysdr-git
Description: SDR receiver built on GNU Radio with a web-based UI and plugins
Upstream URL: https://github.com/kpreid/shinysdr
Licenses: GPL3
Conflicts: shinysdr
Provides: shinysdr
Submitter: Mikos
Maintainer: None
Last Packager: Mikos
Votes: 5
Popularity: 0.000000
First Submitted: 2015-12-07 14:53 (UTC)
Last Updated: 2015-12-07 16:50 (UTC)

Dependencies (8)

Required by (0)

Sources (1)

Latest Comments

dreieck commented on 2021-09-30 15:09 (UTC)

If I start the installed software, it errors out with

ImportError: No module named gnuradio

Although I have all dependencies installed.

gnuradio itself is installed the currently latest version from the community repository, version 3.9.2.0-3.

dreieck commented on 2021-09-30 15:07 (UTC)

Please consider removing the -git from the optdepends, if it not explicitly need the -git-variant.

Thanks for maintaining!

dreieck commented on 2021-09-30 15:06 (UTC)

Fails in build():

==> Starting build()...
/home/felics/.cache/yay/shinysdr-git/PKGBUILD: line 33: ./fetch-js-deps.sh: No such file or directory
==> ERROR: A failure occurred in build().
    Aborting...

Also, consider moving any downloading to the source-array if possible, otherwise to prepare().

If I just remove that ./fetch-js-deps.sh, it automagically downloads lots of stuff in package() (!!), and builds something seemingly senseful.

Thanks for maintaining!

gromain commented on 2019-12-17 22:27 (UTC)

Also, you need to add python2-pyasn1-modules to the dependencies.

Phaotee commented on 2018-12-11 23:34 (UTC)

You need to add the python2-pyserial package as a dependency to this one.