Package Details: shortwave-git 1.0.1.r34.g5454d6e-1

Git Clone URL: https://aur.archlinux.org/shortwave-git.git (read-only, click to copy)
Package Base: shortwave-git
Description: Find and listen to internet radio stations
Upstream URL: https://gitlab.gnome.org/World/Shortwave
Licenses: GPL3
Conflicts: shortwave
Provides: shortwave
Submitter: flipflop97
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 7
Popularity: 0.33
First Submitted: 2019-01-30 20:00
Last Updated: 2020-05-07 16:00

Latest Comments

1 2 3 Next › Last »

Tio commented on 2020-03-23 14:01

Ah ok I see thank you!

yochananmarqos commented on 2020-03-23 03:10

@Tio: The latest version of curl will resolve the issue. You will have to wait for the next Manjaro stable update, switch to the testing or unstable branch or use Arch.

Remember, this is the Arch User Repository and other Arch-based spins are not supported by Arch and are usually taboo to mention.

Tio commented on 2020-03-23 02:46

I see....I use Manjaro Gnome and Pamac so you know. For me this git version and the non git one of shortwave get stuck with the same error

yochananmarqos commented on 2020-03-22 14:56

@Tio: I can't reproduce that error right now, however I have seen the "spurious network error" with crates.io lately.

Tio commented on 2020-03-22 13:56

Error:


Caused by:
  [28] Timeout was reached (download of `gtk v0.8.0` failed to transfer more than 10 bytes in 30s)
[3/4] Generating de.haeckerfelix.Shortwave.metainfo.xml_data_merge with a custom command.
FAILED: src/shortwave 
/var/tmp/pamac-build-tio/shortwave-git/src/Shortwave/build-aux/cargo.sh /var/tmp/pamac-build-tio/shortwave-git/src/build /var/tmp/pamac-build-tio/shortwave-git/src/Shortwave src/shortwave /usr/share/locale default
ninja: build stopped: subcommand failed.
==> ERROR: A failure occurred in build().
    Aborting...

yochananmarqos commented on 2019-12-22 15:39

@j1simon: Added.

j1simon commented on 2019-12-21 10:29

It lacks dependencies:

$ makepkg
....
   Compiling hyper v0.12.35
error: failed to run custom build command for `cairo-sys-rs v0.9.2`

Caused by:
  process didn't exit successfully: `/tmp/makepkg/shortwave-git/src/build/target/debug/build/cairo-sys-rs-bfa399f4b755b098/build-script-build` (exit code: 1)
--- stderr
`"pkg-config" "--libs" "--cflags" "cairo-gobject" "cairo-gobject >= 1.12"` did not exit successfully: exit code: 1
--- stdout


--- stderr
Package xproto was not found in the pkg-config search path.
Perhaps you should add the directory containing `xproto.pc'
to the PKG_CONFIG_PATH environment variable
Package 'xproto', required by 'xau', not found
Package 'xproto', required by 'xdmcp', not found
Package 'xproto', required by 'xau', not found
Package 'xproto', required by 'xdmcp', not found
Package 'xproto', required by 'xau', not found
Package 'xproto', required by 'xdmcp', not found
Package 'xproto', required by 'xrender', not found
Package 'renderproto', required by 'xrender', not found
Package 'xproto', required by 'x11', not found
Package 'kbproto', required by 'x11', not found
Package 'xproto', required by 'x11', not found
Package 'kbproto', required by 'x11', not found
Package 'xextproto', required by 'xext', not found
Package 'xproto', required by 'xau', not found
Package 'xproto', required by 'xdmcp', not found
Package 'xproto', required by 'xau', not found
Package 'xproto', required by 'xdmcp', not found
Package 'xproto', required by 'xau', not found
Package 'xproto', required by 'xdmcp', not found
Package 'xproto', required by 'xrender', not found
Package 'renderproto', required by 'xrender', not found
Package 'xproto', required by 'x11', not found
Package 'kbproto', required by 'x11', not found
Package 'xproto', required by 'x11', not found
Package 'kbproto', required by 'x11', not found
Package 'xextproto', required by 'xext', not found


warning: build failed, waiting for other jobs to finish...
error: build failed
[3/4] Generating de.haeckerfelix.Shortwave.appdata.xml_data_merge with a custom command.
FAILED: src/shortwave 
/tmp/makepkg/shortwave-git/src/Shortwave/build-aux/cargo.sh /tmp/makepkg/shortwave-git/src/build /tmp/makepkg/shortwave-git/src/Shortwave src/shortwave /usr/share/locale beta
ninja: build stopped: subcommand failed.
==> ERROR: A failure occurred in build().
    Aborting...

yochananmarqos commented on 2019-11-20 15:37

@r381581: It turns out you are absolutely correct. I removed it.

r381581 commented on 2019-11-20 12:15

Is there any reason for forcing the removal of Gradio with the installation of this package? I mean, okay it's a complete rewrite whose objective is to replace it, but it's 1/ A different software, with different name and different binaries and file ; 2/ still in early development and can lack features of Gradio or be way more buggy.

A user can want to have both on its computer to try this new one, help on dev and do bug reports while still having Gradio for regular use. Add a note to tell Gradio is deemed to be replaced, why not, but imho you shouldn't forbid Shortwave and Gradio to be both installed: they don't conflict with each other.

Tio commented on 2019-11-12 13:07

I see thanks. I was testing it on Manjaro Gnome Stable