Package Details: shotcut-git r2235-1

Git Clone URL: https://aur.archlinux.org/shotcut-git.git (read-only)
Package Base: shotcut-git
Description: Video editor
Upstream URL: https://github.com/mltframework/shotcut
Licenses: GPL3
Conflicts: shotcut
Provides: shotcut
Submitter: Zuf
Maintainer: nfnty
Last Packager: nfnty
Votes: 6
Popularity: 0.414398
First Submitted: 2012-12-16 17:54
Last Updated: 2017-07-17 14:28

Pinned Comments

nfnty commented on 2015-06-19 12:24

Issues and pull requests at https://github.com/nfnty/pkgbuilds

Latest Comments

woffs commented on 2017-08-01 15:48

Both 17.06 and git HEAD on i686 are starting up / failing with

Error:
This program requires OpenGL version 2.0
with the framebuffer object extension.

Apparently this is since the last major mesa update in archlinux. Anyone else with the same problem?

UPDATE:
Solved by https://wiki.archlinux.org/index.php/Intel_graphics#OpenGL_2.1_with_i915_driver

nfnty commented on 2017-04-09 17:05

@sweeper Have you reported upstream?

sweeper commented on 2017-04-09 12:18

Build is currently failing:

/usr/lib/qt/bin/qmake CONFIG-=c++11 PREFIX=/usr/ -o Makefile mvcp.pro
make[1]: /usr/lib/qt/bin/qmake: Command not found
make[1]: *** [Makefile:234: Makefile] Error 127

this seems to be to do with changes in the structure of the QT packages, it should be using /usr/bin/qmake, etc. grepping the source shows that moc is also being referenced in /usr/lib/qt/bin

nfnty commented on 2017-03-03 15:02

@jc-aur Huh? The version here is only updated when the build process is changed. It's up to the user to keep up with upstream changes.

jc-aur commented on 2017-03-03 14:51

isn't this running the latest from shotcut git repo? There are newer versions available

nfnty commented on 2016-02-04 12:56

Try using mlt-git instead of extra/mlt.

ni3k commented on 2016-02-04 09:33

Is somebody else having trouble with shotcut 16.02?
I switched from shotcut-bin (shotcut 16.01) to this package, because there should be a bug fix with the clip speed function, but now the program is unusable. Video and Audio playback is not working properly and the UI is in English, even it is set to German. Besides from the clip speed, I had no trouble with shotcut 16.01?!
I posted this problem on shotcut Google+ page but the maintaner says:
"I do not reproduce either problem on Linux when running "LANG=de_DE.UTF-8 Shotcut.app/shotcut". Maybe you are not using a build provided by us, or please try to figure out the problem and contribute on github."
So I am curios if this is only me, having trouble or if it is this AUR package?

nfnty commented on 2016-01-13 16:19

If there is a feature that was recently added but not working then either there is an optional dependency missing or it's an upstream bug. I can resolve the issue if you're able to pinpoint a specific problem. Otherwise you should report it upstream.

'build-shotcut.sh' fetches and builds all dependencies and is therefore not an option.

celrau commented on 2016-01-13 14:57

I'd suggest using the script (build-shotcut.sh) found in the source (git) to build this. There was a feature added recently which didn't work with this Shotcut but worked by building it myself with the above script, most likely some incompatibilities somewhere.

nfnty commented on 2015-09-19 20:34

@jazztickets Fixed

jazztickets commented on 2015-09-19 20:00

qt5-websockets should be added as a dependency

nfnty commented on 2015-06-19 12:24

Issues and pull requests at https://github.com/nfnty/pkgbuilds

Zuf commented on 2013-12-21 09:37

Hello. I actually don't use shotcut. If anyone wants to support this package you are welcome.

osc commented on 2013-12-19 16:31

hi

according to dan dennedy the best way currently to obtain shotcut is from the binary daily version on the site. this is due to so many dependencies and might get shotcut not to work properly (as has happened with kdenlive). so maybe a shotcut-bin package would be the best solution.

cheers

dimytch commented on 2013-10-20 09:07

Won`t compile.

http://pastebin.com/URJLiTiD

Zuf commented on 2013-03-15 17:53

You should install mlt from git.
PKGBUILD was updated. It should built without errors.

osc commented on 2013-03-12 18:30

even switching the pkgbuild qt4 qt4-qmake i get this errors compiling:

glwidget.cpp: In member function ‘virtual void Mlt::GLWidget::paintGL()’:
glwidget.cpp:149:57: error: ‘mlt_image_glsl_texture’ was not declared in this scope
glwidget.cpp: At global scope:
glwidget.cpp:248:13: warning: unused parameter ‘owner’ [-Wunused-parameter]
glwidget.cpp:259:13: warning: unused parameter ‘owner’ [-Wunused-parameter]
glwidget.cpp: In member function ‘void Mlt::GLWidget::showFrame(Mlt::QFrame)’:
glwidget.cpp:270:48: error: ‘mlt_image_glsl_texture’ was not declared in this scope
glwidget.cpp: In member function ‘virtual int Mlt::GLWidget::reconfigure(bool)’:
glwidget.cpp:442:30: error: ‘mlt_image_glsl_texture’ was not declared in this scope
make[1]: ** [glwidget.o] Erro 1

osc commented on 2013-03-12 14:36

it is not compiling...

SanskritFritz commented on 2013-03-02 18:15

Please switch qt to qt4