Package Details: shuriken 0.5.2-3

Git Clone URL: https://aur.archlinux.org/shuriken.git (read-only)
Package Base: shuriken
Description: An open source beat slicer
Upstream URL: https://rock-hopper.github.io/shuriken
Licenses: GPL
Conflicts: shuriken
Provides: shuriken
Submitter: Joermungand
Maintainer: Joermungand
Last Packager: Joermungand
Votes: 3
Popularity: 0.005296
First Submitted: 2016-01-30 21:02
Last Updated: 2018-02-01 15:35

Latest Comments

Joermungand commented on 2018-02-03 17:17

You’re welcome. Actually, he thought it was a good idea, so it is your pointing it out that will benefit both parties (and others beyond).

dvzrv commented on 2018-02-03 17:10

@Joermungand: Thanks for going upstream with it! :)

Joermungand commented on 2018-02-03 17:01

@dvzrv: Point 2: it will be solved in future versions; for now, we’ll have to make do.

Joermungand commented on 2018-02-01 15:52

@dvzrv: Point one has been taken care of. For point 2, I’ve opened an issue on GitHub, let’s see what the dev says.

dvzrv commented on 2018-02-01 10:18

@Joermungand: Please make the source tarball unique by prepending ${pkgname}-${pkgver}::.

Also, please try to persuade upstream to add the packaging folder to the source tarball and install the desktop file and icon with the make system.

Joermungand commented on 2016-12-29 15:45

Fixed by patch released upstream. Sorry about the delay.

Aquassaut commented on 2016-12-21 13:55

Build failed at first without PKGBUILD modification. It however passed when using `make CXXFLAGS=-fpermissive` instead of `make` in build(). The errors were like so:

In file included from src/wavegraphicsscene.h:30:0,
from src/mainwindow.h:36,
from src/main.cpp:24:
src/waveformitem.h:112:50: error: ‘constexpr’ needed for in-class initialization of static data member ‘const qreal WaveformItem::DETAIL_LEVEL_MAX_CUTOFF’ of non-integral type [-fpermissive]
static const qreal DETAIL_LEVEL_MAX_CUTOFF = 0.05;
^~~~

Joermungand commented on 2016-04-18 09:28

Right! Updated. Thanks.

xantares commented on 2016-04-18 09:14

hi,
- automake, libtool and pkg-config are part of base-devel, so no need to include them
- libx11 is already a dependency of qt4, so do not list it either
xan.