Package Details: shutter 0.94.3-1

Git Clone URL: https://aur.archlinux.org/shutter.git (read-only, click to copy)
Package Base: shutter
Description: A featureful screenshot tool (formerly gscrot)
Upstream URL: https://shutter-project.org/
Licenses: GPL3
Submitter: City-busz
Maintainer: PhotonX
Last Packager: PhotonX
Votes: 92
Popularity: 0.46
First Submitted: 2017-01-24 12:16
Last Updated: 2020-06-26 13:48

Required by (0)

Sources (1)

Pinned Comments

Ralf_Mardorf commented on 2017-09-03 13:25

Follow the announcement to "get a list of affected packages":

[rocketmouse@archlinux ~]$ pacman -Qqo '/usr/lib/perl5/vendor_perl'
gnome-perl
gnome-vfs-perl
gnomecanvas-perl
perl-gnome2-wnck
perl-goo-canvas
perl-gtk2-imageview
perl-gtk2-unique

Check dependencies:

[rocketmouse@archlinux ~]$ pacman -Qi gnome-perl | grep Depends\ On
Depends On : gnomecanvas-perl gnome-vfs-perl libgnomeui perl

Proper would be to check build dependencies.

Build after increasing the pkgrel of the PKGBUILDs:

[rocketmouse@archlinux ~]$ yaourt -S gnomecanvas-perl gnome-vfs-perl
[snip]
[rocketmouse@archlinux ~]$ yaourt -S gnome-perl perl-gnome2-wnck perl-goo-canvas perl-gtk2-imageview perl-gtk2-unique
[snip]

Then launch shutter:

[rocketmouse@archlinux ~]$ shutter >/dev/null 2>&1

Take a screenshot and edit the screenshot.

Latest Comments

« First ‹ Previous ... 5 6 7 8 9 10 11 12 13 14 15 ... Next › Last »

PhotonX commented on 2017-08-17 18:44

Shutter 0.94 is released implementing all the patches previously included in this package and some more.

PhotonX commented on 2017-08-11 01:53

@izznogooood: It already is, an optional one. Since Shutter's core functionality (taking screenshots) is given without it, I think, it is better to keep it an optional dependency.

izznogooood commented on 2017-08-10 21:20

Package perl-goo-canvas is required for Editing in Shutter, consider making it a dependency.

PhotonX commented on 2017-08-08 16:42

@RazZziel: Thanks for the hint! A bit radical, but if it works, itworks. :)

RazZziel commented on 2017-08-08 15:53

This was the only way I managed to build it:

PERL_USE_UNSAFE_INC=1 yaourt -S shutter

presianbg commented on 2017-08-06 09:31

@PhotonX: Nope... tried that and almost everything related to gnome.

PhotonX commented on 2017-08-06 07:30

@presianbg: Not sure but looks like perl-gnome2-wnck.

presianbg commented on 2017-08-06 07:05

xs/Gnome2.c: loadable library and perl binaries are mismatched (got handshake key 0xdb80080, needed 0xde00080)

Which package do I need to rebuild/reinstall, because I tried almost all of them and still no luck :(

Ralf_Mardorf commented on 2017-07-16 11:40

Your argument is just one argument, also consider that even if shutter would be completely broken under wayland, it wouldn't conflict with wayland, a user e.g. could switch between X and wayland, then it would become an issue, if the shutter package would conflict with the wayland package, while actually the shutter package doesn't break wayland. An example for a valid conflict would be "e.g. for fluxbox-git: conflicts=('fluxbox') and provides=('fluxbox')" - https://wiki.archlinux.org/index.php/VCS_package_guidelines#Guidelines
Simplified, so to say, if the packages don't share files, they don't conflict with each other.

PhotonX commented on 2017-07-16 11:00

@Ralf_Mardorf: Actually yeah, in principle it is still possible to use Shutter for editing and uploading screenshots, even if capture is broken.