Package Details: sidewinderd 0.4.4-1

Git Clone URL: https://aur.archlinux.org/sidewinderd.git (read-only, click to copy)
Package Base: sidewinderd
Description: Support for Microsoft SideWinder X4 / X6 and Logitech G103 / G105 / G710+.
Upstream URL: https://github.com/tolga9009/sidewinderd
Keywords: daemon g103 g105 g710 g710+ keyboard logitech macro microsoft sidewinder sidewinderd x4 x6
Licenses: MIT
Submitter: tolga9009
Maintainer: tolga9009
Last Packager: tolga9009
Votes: 11
Popularity: 0.000001
First Submitted: 2014-11-13 00:28
Last Updated: 2021-07-04 22:40

Latest Comments

« First ‹ Previous 1 2

zimmertr commented on 2016-09-22 01:41

This package is no longer working for me after an update about a week ago. The button above the macros on my keyboard that shows which mode (1,2,3) you're in is no longer illuminated and the macro keys no longer function. When I try do a package upgrade pacman fails with:

:: failed to verify sidewinderd integrity

now too.

Psykar commented on 2016-09-12 05:44

source=("${pkgname}::https://github.com/tolga9009/sidewinderd/archive/${pkgver}.tar.gz")

SHould be something like

source=("${pkgname}-${pkgver}.tar.gz::https://github.com/tolga9009/sidewinderd/archive/${pkgver}.tar.gz")

Otherwise it ends up downloading the tarball and naming it 'sidewinderd' (ie no version, no extension or anything.
It still runs fine, but leaves a confusing file with no extension behind in the build directory :)

tolga9009 commented on 2016-09-08 18:40

Updated package to version 0.4.0. Support for Logitech G105 has been added. Also, hot-plug has been implemented and encrypted home directories are now supported.

Cheers,
Tolga

tolga9009 commented on 2016-01-19 02:40

Updated package to version 0.3.0. Support for Logitech G710+ has been introduced. Lots of new code has been added. Please report, if there are any bugs.

Cheers,
Tolga

kleinph commented on 2015-06-25 23:11

Wow, that was fast.

Yep, the package builds now fine. Also nice that you moved to AUR 4!

Thanks!

BTW: yaourt is still serving the old PKGBUILD. I don't know if this is just a caching issue or it is prioritizing the old AUR.

tolga9009 commented on 2015-06-25 22:28

Updated package to version 0.2.1. This will fix the linker error about missing pthread library. Please note, that your macro files are now stored in ~/.local/share/sidewinderd instead of ~/.sidewinderd. This behaviour is conform to XDG specs.

Please report, if any issues are occuring.

tolga9009 commented on 2015-03-27 19:58

Hi everyone,

the package has been updated to version 0.2.0. Several, critical fixes have been applied. TinyXML2 also has been updated to version 3.0.0. I'm not bundling TinyXML2 together with sidewinderd anymore. You need to install tinyxml2 (https://aur.archlinux.org/packages/tinyxml2/) from AUR as a dependency, in order to make and install the package.

This update is highly recommended. Please update and report back.

Cheers,
Tolga

tolga9009 commented on 2015-03-08 19:39

Hi knezi!

This is probably due to some other package conflicting with the bundled tinyxml2 library. I've stopped bundling tinyxml2 with sidewinderd in the latest version though.

I will soon update this package to work with the AUR package "tinyxml2-git". You can find it here: https://aur.archlinux.org/packages/tinyxml2-git/. Try to install it and report back please.

Cheers,
Tolga

knezi commented on 2015-03-08 18:41

Thanks for the package. I have tried to install it, but when tried pacman -U sidewinderd-....tar.xz I got:
sidewinderd: /usr/lib64 already exist in filesystem.
Doesn't it try to make dir /usr/lib64?