Package Details: sigal 1.2.0-1

Git Clone URL: https://aur.archlinux.org/sigal.git (read-only)
Package Base: sigal
Description: Simple static gallery generator
Upstream URL: https://github.com/saimn/sigal
Keywords: gallery image python static
Licenses: MIT
Submitter: saimn
Maintainer: saimn
Last Packager: saimn
Votes: 6
Popularity: 0.542308
First Submitted: 2013-03-11 16:12
Last Updated: 2016-06-06 20:31

Latest Comments

saimn commented on 2015-12-15 20:53

@aclindsa: Fortunately this issue has just been opened: https://github.com/mitsuhiko/click/issues/490

aclindsa commented on 2015-12-15 14:58

Ah, my locale on this particular machine had been overlooked and was simply "C". I've changed it to "en_US.UTF-8" and that allowed sigal to work. Are you aware of a reason this results in a TypeError rather than a clean error message telling me my locale is incompatible?

Thanks for your help!

saimn commented on 2015-12-15 10:39

@aclindsa: I can't reproduce, what is your locale ?
The issue is in click, where this line https://github.com/mitsuhiko/click/blob/master/click/_unicodefun.py#L69 should use (b'.utf-8', b'.utf8').

aclindsa commented on 2015-12-15 01:55

I'm getting the following message with the latest when just running `sigal`:

Traceback (most recent call last):
File "/usr/bin/sigal", line 9, in <module>
load_entry_point('sigal==1.0.1', 'console_scripts', 'sigal')()
File "/usr/lib/python3.5/site-packages/click/core.py", line 716, in __call__
return self.main(*args, **kwargs)
File "/usr/lib/python3.5/site-packages/click/core.py", line 675, in main
_verify_python3_env()
File "/usr/lib/python3.5/site-packages/click/_unicodefun.py", line 69, in _verify_python3_env
if locale.lower().endswith(('.utf-8', '.utf8')):
TypeError: a bytes-like object is required, not 'str'

saimn commented on 2015-01-25 22:08

@omrihar, @anatolik: This is fixed with the new version, sorry for the delay.

anatolik commented on 2015-01-19 22:32

[anatol@brest sigal]$ sigal build ../../pictures/
Sorting media [####################################] 100%
Collecting files [------------------------------------] 0%
Traceback (most recent call last):
File "/usr/bin/sigal", line 9, in <module>
load_entry_point('sigal==0.9.1', 'console_scripts', 'sigal')()
File "/usr/lib/python3.4/site-packages/click/core.py", line 610, in __call__
return self.main(*args, **kwargs)
File "/usr/lib/python3.4/site-packages/click/core.py", line 590, in main
rv = self.invoke(ctx)
File "/usr/lib/python3.4/site-packages/click/core.py", line 936, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File "/usr/lib/python3.4/site-packages/click/core.py", line 782, in invoke
return ctx.invoke(self.callback, **ctx.params)
File "/usr/lib/python3.4/site-packages/click/core.py", line 416, in invoke
return callback(*args, **kwargs)
File "/usr/lib/python3.4/site-packages/sigal/__init__.py", line 133, in build
gal.build(force=force)
File "/usr/lib/python3.4/site-packages/sigal/gallery.py", line 565, in build
media_list = [f for album in albums
File "/usr/lib/python3.4/site-packages/sigal/gallery.py", line 565, in <listcomp>
media_list = [f for album in albums
File "/usr/lib/python3.4/site-packages/click/_termui_impl.py", line 243, in next
self.render_progress()
File "/usr/lib/python3.4/site-packages/click/_termui_impl.py", line 204, in render_progress
line = self.format_progress_line()
File "/usr/lib/python3.4/site-packages/click/_termui_impl.py", line 177, in format_progress_line
}).rstrip()
TypeError: sequence item 1: expected str instance, bytes found

saimn commented on 2015-01-15 21:48

@omrihar: sigal works on python 3, did you get any errors ?
On the website you can read "Sigal is compatible with Python 2.7 and 3.3.". Where did you read that it is python2 only ? I will be happy to fix this.

omrihar commented on 2015-01-15 14:22

For some reason when I install it, it installs to my Python 3 directory instead of Python 2 (which according to the website is what it supports). Did I do something wrong? I installed it using packer.

Thanks :-)

saimn commented on 2014-09-02 19:38

@drcouzelis: oops sorry, I forgot to add it. This is now fixed, thanks for the report.

drcouzelis commented on 2014-09-01 23:29

Surprise! Apparently "python-blinker" is now a dependency for version 0.8.0. :)

All comments