Package Details: sigil-git 0.9.6.r23.g8e6b153-1

Git Clone URL: https://aur.archlinux.org/sigil-git.git (read-only)
Package Base: sigil-git
Description: A WYSIWYG ebook editor
Upstream URL: https://github.com/Sigil-Ebook/Sigil
Licenses: GPL3
Conflicts: sigil
Provides: sigil
Submitter: yangtsesu
Maintainer: Eschwartz
Last Packager: Eschwartz
Votes: 7
Popularity: 0.002419
First Submitted: 2011-12-02 10:53
Last Updated: 2016-08-04 16:09

Dependencies (17)

Required by (0)

Sources (1)

Latest Comments

Eschwartz commented on 2015-09-27 08:36

I'll take a look at it.

imapiekindaguy commented on 2015-09-24 20:19

@Eschwartz: Thanks for bringing this to my attention. Unfortunately, I've moved away from Arch Linux in the last couple of months, and no longer use Sigil, so I'm unable to dedicate the time to fixing this package. I'm disowning the package, so anyone is free to step up to maintain it.

Eschwartz commented on 2015-09-24 17:52

Sigil 0.8.900 has been released and is going to need changes to build. Copy-pasting the message I posted when flagging it out of date in community:


http://sigil-ebook.com/2015/09/24/sigil-0-8-900-released-first-of-the-pre-sigil-0-9-0-release-series/

Note: The Sigil internals changed a lot, and among others include modified and incompatible upstream libraries which apparently should NOT be replaced by system libs.
e.g. Gumbo HTML5 parser is an actual fork:
https://github.com/Sigil-Ebook/Sigil/blob/master/internal/about.md
https://github.com/Sigil-Ebook/Sigil/blob/master/internal/gumbo/README.md

Also, for the plugin architecture, python-{lxml,PIL,regex,six,html5lib} should be dependencies (optional?) as I believe the expectation is that plugins are allowed to assume those site-packages are installed and available by default. Some parts may be required to run Sigil itself.
(Not beautifulsoup4, it is forked, bundled and namespaced as sigil_bs4 because "reasons".)


Current build directions have changed: https://github.com/Sigil-Ebook/Sigil/blob/master/docs/BuildingOnLinux.md
May need some playing around.

imapiekindaguy commented on 2015-07-20 17:54

@blackhole Ah, I don't know how much help I'll be in troubleshooting this problem, then. I don't use a Qt-based desktop environment, and sigil is one of the only Qt applications I use. You might need to seek out help either from the author of sigil, or from someone more knowledgeable about Qt applications and Plasma. Sorry I couldn't be of any help.

blackhole commented on 2015-07-20 17:26

The problem is strange. From Lxqt is starting fine, but from Plasma is crashing. Moreover, in both, sometime it hangs, for example if I change cover...

imapiekindaguy commented on 2015-07-20 17:07

@blackhole That's odd. Did you install sigil with pacman? If so, would you mind telling me the version and build date? You can find those by running pacman -Qi sigil. The version of sigil available through pacman runs fine on my machine, and I'm rebuilding sigil-git right now to test it out.

Let me know if you continue to have trouble with these packages, and I'll do my best to help you out.

blackhole commented on 2015-07-20 09:06

Ok, now is installing fine.

However Sigil official and Sigil-git are both crashing now with segmentation fault.

imapiekindaguy commented on 2015-05-09 02:19

@blackhole: Thank you for letting me know. The layout of some of the source was changed about a month ago, and I haven't built this package in quite a while. It should be fixed now (it builds fine on my machine, at any rate).

I've also added two new dependencies: qt5-multimedia and python-lxml.

blackhole commented on 2015-05-08 23:12

install: cannot stat ‘../src/Sigil/Resource_Files/icon/app_icon_16.png’: No such file or directory

imapiekindaguy commented on 2014-08-07 04:50

I've adopted this package, and updated the PKGBUILD a little to reflect the new git repository for sigil. Let me know if there are any problems with the changes.

ErkiDerLoony commented on 2013-11-03 19:16

There’s a missing makedepends: boost. ;)

yangtsesu commented on 2013-03-11 02:29

run this once:
$ rm -rf src/sigil/build/

zebulon commented on 2013-03-10 19:35

I reply to myself. You need to use:

depends=('qt5-core' 'qt5-svg' 'qt5-webkit' 'qt5-xmlpatterns' 'qt5-tools')

zebulon commented on 2013-03-06 18:36

I have this error. Does it require qt5 now ?

-- Could NOT find MiniZip
-- checking for module 'xerces-c>=3.1'
-- found xerces-c, version 3.1.1
-- checking for module 'hunspell'
-- found hunspell, version 1.3.2
-- checking for module 'libpcre16'
-- found libpcre16, version 8.32
-- Could NOT find XercesExtensions
-- Could NOT find FlightCrew
CMake Error at src/Sigil/CMakeLists.txt:38 (find_package):
By not providing "FindQt5Core.cmake" in CMAKE_MODULE_PATH this project has
asked CMake to find a package configuration file provided by "Qt5Core", but
CMake did not find one.

Could not find a package configuration file provided by "Qt5Core" with any
of the following names:

Qt5CoreConfig.cmake
qt5core-config.cmake

Add the installation prefix of "Qt5Core" to CMAKE_PREFIX_PATH or set
"Qt5Core_DIR" to a directory containing one of the above files. If
"Qt5Core" provides a separate development package or SDK, be sure it has
been installed

zebulon commented on 2013-03-05 08:38

I flagged it out of date for the new qt4 dependency.

lobisquit commented on 2013-01-16 21:16

could you please add "%U" to sigil.desktop? So you can open epub files also with "Open with..."

yangtsesu commented on 2012-10-29 10:16

It is git version,DO NOT flag out of date

mrbit commented on 2012-10-28 16:05

update ..please sigil 0.6.0 thanks

yangtsesu commented on 2012-10-10 00:19

git is git

Raymondcal commented on 2012-10-09 13:34

Hi ! Is this version the same thing as Sigil beta 0.5.906 ?
Or is it the git as of 2011/12/02 ?

weedfreak commented on 2012-09-14 13:54

Any suggestions on how to correct the error posted 17 august?

syne commented on 2012-08-26 10:40

I think you should add the line conflicts=('sigil')

weedfreak commented on 2012-08-17 13:05

Fails to build with error

Linking CXX static library ../../lib/libXerces.a
[ 48%] Built target Xerces
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build sigil-git.

weedfreak commented on 2012-08-17 13:04

Fails to build with error

Linking CXX static library ../../lib/libXerces.a
[ 48%] Built target Xerces
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build sigil-git.

weedfreak commented on 2012-08-17 13:03

Fails to build with error

Linking CXX static library ../../lib/libXerces.a
[ 48%] Built target Xerces
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build sigil-git.

yangtsesu commented on 2012-01-03 11:46

All fine here...

mrbit commented on 2012-01-02 19:11

/tmp/packerbuild-0/sigil-git/sigil-git/src/sigil/src/Sigil/Misc/SpellCheck.cpp:257:118: warning: suggest parentheses around ‘+’ inside ‘>>’ [-Wparentheses]
make[2]: *** [src/Sigil/CMakeFiles/sigil.dir/Misc/SpellCheck.cpp.o] Errore 1
make[1]: *** [src/Sigil/CMakeFiles/sigil.dir/all] Errore 2
make: *** [all] Errore 2

yangtsesu commented on 2011-12-02 10:54

Now git version have be translate to languages other than En.