Package Details: sigrok-cli-git 0.6.0.r58.gb5c8f3a-1

Git Clone URL: https://aur.archlinux.org/sigrok-cli-git.git (read-only, click to copy)
Package Base: sigrok-cli-git
Description: Client software that supports various hardware logic analyzers, CLI client (git version)
Upstream URL: http://www.sigrok.org/wiki/Sigrok-cli
Licenses: GPL3
Conflicts: sigrok-cli
Provides: sigrok-cli
Submitter: Manouchehri
Maintainer: codyps
Last Packager: codyps
Votes: 1
Popularity: 0.000000
First Submitted: 2015-09-08 22:23
Last Updated: 2019-01-18 20:50

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

kiciek commented on 2019-10-14 08:53

During ==> Making package: sigrok-cli-git 0.6.0.r58.gb5c8f3a-1 (Mon 14 Oct2019 10:43:26 CEST) I get:

sigrok-cli configuration summary:
 - Package version................. 0.8.0-git-adf8d7a
 - Prefix.......................... /usr
 - Building on..................... x86_64-pc-linux-gnu
 - Building for.................... x86_64-pc-linux-gnu

Compile configuration:
 - C compiler...................... gcc
 - C compiler version.............. gcc (GCC) 9.2.0
 - C compiler flags................ -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt
 - Additional C compiler flags..... -std=c99
 - C compiler warnings............. -Wall -Wextra
 - Linker flags.................... -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now

Detected libraries (required):
 - glib-2.0 >= 2.32.0.............. 2.62.1
 - libsigrok >= 0.5.0.............. 0.6.0-git-f6129c8f

Detected libraries (optional):
 - libsigrokdecode >= 0.5.0........ 0.6.0-git-30d27bd

make  all-am
  CC       session.o
  CC       input.o
  CC       show.o
  CC       main.o
  CC       device.o
  CC       decode.o
  CC       parsers.o
  CC       anykey.o
show.c: In function ‘show_supported_wiki’:
show.c:239:23: error: ‘struct srd_decoder’ has no member named ‘tags’
  239 |   for (GSList *t = dec->tags; t; t = t->next)
      |                       ^~
show.c: In function ‘show_pd_detail_single’:
show.c:864:10: error: ‘struct srd_decoder’ has no member named ‘tags’
  864 |   if (dec->tags) {
      |          ^~
show.c:865:16: error: ‘struct srd_decoder’ has no member named ‘tags’
  865 |    for (l = dec->tags; l; l = l->next) {
      |                ^~
make[1]: *** [Makefile:505: show.o] Error 1
make[1]: *** Waiting for unfinished jobs....
  CC       options.o
make: *** [Makefile:365: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...

codyps commented on 2018-11-03 18:27

Needs a patch to avoid the "unreleased" version number.

From 1e8bbb3fea15677f7e8fa544f5635e841efbd104 Mon Sep 17 00:00:00 2001
From: Cody P Schafer <dev@codyps.com>
Date: Sat, 3 Nov 2018 14:18:52 -0400
Subject: [PATCH] avoid the "unreleased" version number

---
 .SRCINFO | 2 +-
 PKGBUILD | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/.SRCINFO b/.SRCINFO
index 5933a69..2c79161 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
 pkgbase = sigrok-cli-git
    pkgdesc = Client software that supports various hardware logic analyzers, CLI client (git version)
-   pkgver = 0.5.0.r86.g15a14bf
+   pkgver = 0.6.0.r53.gf5735c5
    pkgrel = 1
    url = http://www.sigrok.org/wiki/Sigrok-cli
    arch = armv6h
diff --git a/PKGBUILD b/PKGBUILD
index 8a93369..0a9eb0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@

 _gitname='sigrok-cli'
 pkgname="${_gitname}-git"
-pkgver=0.5.0.r86.g15a14bf
+pkgver=0.6.0.r53.gf5735c5
 pkgrel=1
 pkgdesc="Client software that supports various hardware logic analyzers, CLI client (git version)"
 arch=('armv6h' 'armv7h' 'i686' 'x86_64')
@@ -21,7 +21,7 @@ pkgver() {
   cd "${srcdir}/${_gitname}"
   (
     set -o pipefail
-    git describe --long 2>/dev/null | sed "s/\([^-]*-g\)/r\1/;s/-/./g;s/sigrok.cli.//" ||
+    git describe --long --exclude sigrok-cli-unreleased 2>/dev/null | sed "s/\([^-]*-g\)/r\1/;s/-/./g;s/sigrok.cli.//" ||
       printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
   )
 }
@@ -41,4 +41,4 @@ package() {
   make DESTDIR="${pkgdir}" PREFIX=/usr install
 }

-# vim:set et sw=2 sts=2 tw=80:
\ No newline at end of file
+# vim:set et sw=2 sts=2 tw=80:
-- 
2.19.1