Package Details: sil 1.3.0-4

Git Clone URL: https://aur.archlinux.org/sil.git (read-only, click to copy)
Package Base: sil
Description: A game of adventure set in the first age of Middle-earth, when the world still rang with elven song and gleamed with dwarven mail. Walk the dark halls of Angband. Slay creatures black and fell. Wrest a shining Silmaril from Morgoth’s iron crown.
Upstream URL: http://www.amirrorclear.net/flowers/game/sil/
Keywords: game roguelike tolkien
Licenses: GPL2, custom, custom:angband
Submitter: metamer
Maintainer: patlefort
Last Packager: patlefort
Votes: 9
Popularity: 0.008828
First Submitted: 2016-02-17 04:45
Last Updated: 2021-06-04 11:13

Latest Comments

Gzack commented on 2020-12-05 20:36

@dalz Thanks for the tip, I was able to get GCU to work but not X11 like you pointed out.

dalz commented on 2020-12-05 08:21

@Gzack it doesn't work anymore and I couldn't figure out why, there's a couple of comments here https://aur.archlinux.org/packages/sil-q. The terminal version of the game (sil -mgcu) should be fine though.

Gzack commented on 2020-12-04 22:48

@dalz Could you provide some more information on how you were able to fix the issue? I have xorg-fonts-misc as a dependency and have rebuilt the package, but I still get the error message.

avb commented on 2020-10-01 20:46

I was getting a linker error, but this patch seems to fix it:

externs.patch: https://pastebin.com/tSZmCfrn PKGBUILD: https://pastebin.com/nTTY44Ax

dalz commented on 2019-08-30 16:27

I'm pretty sure xorg-fonts-misc is a dependency for the graphical mode, I get a "Couldn't load the requested font. (10x20)" without it.

metamer commented on 2018-08-16 05:04

@avb I've added the requested line.

avb commented on 2018-01-22 19:29

Could you please add #! /usr/bin/env bash as the first line of sil.sh? Otherwise it doesn't execute (at least for me).