Package Details: silentarmy 5-1

Git Clone URL: https://aur.archlinux.org/silentarmy.git (read-only)
Package Base: silentarmy
Description: GPU Zcash Equihash solver
Upstream URL: https://github.com/mbevand/silentarmy
Keywords: cryptocurrency equihash zcash
Licenses: MIT
Submitter: klardotsh
Maintainer: klardotsh
Last Packager: klardotsh
Votes: 3
Popularity: 0.000003
First Submitted: 2016-11-04 09:48
Last Updated: 2016-11-14 16:11

Latest Comments

teleassist commented on 2017-12-01 09:41

Need to change dependencies :

Change libcl by ocl-icd. Works fine.

kaymio commented on 2017-05-07 18:41

I've installed the opencl-amd implementation of the AMDGPU-PRO driver which should work with the FOSS AMDGPU driver. When I try to install silentarmy, or silentarmy-git for that matter, I get this output.

$ LANG=C pacman -S silentarmy
:: Package silentarmy not found in repositories, trying AUR...
:: resolving dependencies...
:: no results found for libcl (dependency tree: silentarmy libcl)

When trying to install libcl it doesn't work. After short research it means that I should install one of these: catalyst-total-pxp, freeocl-git, khronos-ocl-icd, khronos-ocl-icd-svn, libopencl.

Fitting to me seems the libopencl, as it is the AMD OpenCL library and ICD loader. When trying to install libopencl from the AUR it tells me that it's in conflict with ocl-icd (official). ocl-icd is a dependency of opencl-amd. Here the dog is byting its tail...

Do you have any suggestions on how to get silentarmy working with Arch?

klardotsh commented on 2016-11-04 10:02

Note that this is basically "v3+" - v3 itself as tagged in git doesn't seem to run properly, but the current (as of time of writing this comment) tip of git master DOES, so I took the liberty of making a "v3.0.1" here and targeting it in the PKGBUILD in the name of keeping the package sans git extension while still stable.

If this seriously grinds anyone's purist gears, let me know, and I'll try to look out for v4 when/if it drops.