Package Details: simplicitystudio3 3.3-3

Git Clone URL: https://aur.archlinux.org/simplicitystudio3.git (read-only)
Package Base: simplicitystudio3
Description: Design tools, documentation, software and support resources for EFM32™, EFM8™, 8051, Wireless MCUs and Wireless SoCs.
Upstream URL: https://www.silabs.com/products/development-tools/software/simplicity-studio-version3
Keywords: 3 efm efm32 labs silicon simplicity studio v3
Licenses: unknown
Submitter: maxime.borges
Maintainer: maxime.borges
Last Packager: maxime.borges
Votes: 1
Popularity: 0.000064
First Submitted: 2017-03-21 10:13
Last Updated: 2017-09-23 11:09

Latest Comments

maxime.borges commented on 2017-09-23 11:10

Sorry, it should be ok now, tell me if it's not.

medicineman25 commented on 2017-09-20 17:52

hey man,

I'm getting this error after "==> Starting package()..."

install: cannot stat '/tmp/packerbuild-1000/simplicitystudio3/simplicitystudio3/src/simplicitystudio3': No such file or directory
==> ERROR: A failure occurred in package().
Aborting...
The build failed.


I've tried manually creating the folder and even went as far as to chmod 777 it... but then it spits out:

install: omitting directory '/tmp/......'

maxime.borges commented on 2017-09-17 16:15

That should be fixed now, thanks.

medicineman25 commented on 2017-09-17 16:00

Please alter the following line in your PKGBUILD:

source=(http://www.silabs.com/Support%20Documents/Software/SimplicityStudio.tgz
simplicitystudio3)

to:

source=(https://www.silabs.com/Support%20Documents/Software/SimplicityStudio.tgz)

NOTE: must be https, not http. Even though http will work in a browser. Tested and confirmed.

Thanks.

maxime.borges commented on 2017-07-10 20:49

You're suggesting a modification for the PKGBUILD ? I'm not yet super confortable with AUR packages and not really sure what is your problem.

medicineman25 commented on 2017-07-09 03:39

lib32-qt4 is also a dependency. It was a core package but has now moved to AUR.

You may have trouble installing one of it's dependencies lib32-libmng. You need to update gpg keys (found in the PKGBUILD under 'valid gpg keys').

If you find that one day, after an update, your system won't detect any boards; uninstall and re-compile lib32-qt4.