Package Details: sinfo 0.0.48-4

Git Clone URL: https://aur.archlinux.org/sinfo.git (read-only)
Package Base: sinfo
Description: A monitoring tool for networked computers.
Upstream URL: http://www.ant.uni-bremen.de/whomes/rinas/sinfo/
Licenses: GPL
Submitter: None
Maintainer: monochromec
Last Packager: monochromec
Votes: 4
Popularity: 0.000000
First Submitted: 2011-10-13 15:53
Last Updated: 2016-10-06 10:06

Latest Comments

1 2 Next › Last »

Anonymous comment on 2013-02-15 03:55

Until this gets fixed, build e.g. according to http://verahill.blogspot.com.au/2013/02/335-compiling-sinfo-in-arch-linux.html

Anonymous comment on 2013-02-03 12:31

ehansen,
I had a few issues building the package:

1. There's a line missing in the PKGBUILD without which there's no makefile generated:
19c19
< ./configure || return 1
---
>

2. I'm still new to Arch, so I'm not sure which is the proper approach here, but
src/sinfo-0.0.4.7/sinfo/Makefile.am/.in and src/sinfo-0.0.4.7/sinfod/Makefile.am /.inneed to be edited and the trailing -mt needs to be removed -lboost-signals-mt and -lboot-system-mt.

diff -aur sinfo-0.0.47.original/sinfo/Makefile.am sinfo-0.0.47.patched/sinfo/Makefile.am
--- sinfo-0.0.47.original/sinfo/Makefile.am 2012-06-08 06:08:56.000000000 +1000
+++ sinfo-0.0.47.patched/sinfo/Makefile.am 2013-02-03 22:58:50.435298799 +1100
@@ -37,8 +37,8 @@
../libprotocol/libprotocol.la \
../libprotocolasio/libprotocolasio.la \
-lpthread \
- -lboost_signals-mt \
- -lboost_system-mt \
+ -lboost_signals\
+ -lboost_system\
$(CURSES_LIB)

MAINTAINERCLEANFILES = \
diff -aur sinfo-0.0.47.original/sinfo/Makefile.in sinfo-0.0.47.patched/sinfo/Makefile.in
--- sinfo-0.0.47.original/sinfo/Makefile.in 2012-07-08 16:47:10.000000000 +1000
+++ sinfo-0.0.47.patched/sinfo/Makefile.in 2013-02-03 23:01:59.581968182 +1100
@@ -273,8 +273,8 @@
../libprotocol/libprotocol.la \
../libprotocolasio/libprotocolasio.la \
-lpthread \
- -lboost_signals-mt \
- -lboost_system-mt \
+ -lboost_signals\
+ -lboost_system\
$(CURSES_LIB)

MAINTAINERCLEANFILES = \
diff -aur sinfo-0.0.47.original/sinfod/Makefile.am sinfo-0.0.47.patched/sinfod/Makefile.am
--- sinfo-0.0.47.original/sinfod/Makefile.am 2012-06-08 06:06:06.000000000 +1000
+++ sinfo-0.0.47.patched/sinfod/Makefile.am 2013-02-03 22:58:03.581965195 +1100
@@ -39,8 +39,8 @@
../libmessageio/libmessageio.la \
../librpc/librpc.la \
-lpthread \
- -lboost_signals-mt \
- -lboost_system-mt
+ -lboost_signals\
+ -lboost_system

MAINTAINERCLEANFILES = \
$(IDLXSOURCES)
diff -aur sinfo-0.0.47.original/sinfod/Makefile.in sinfo-0.0.47.patched/sinfod/Makefile.in
--- sinfo-0.0.47.original/sinfod/Makefile.in 2012-07-08 16:47:10.000000000 +1000
+++ sinfo-0.0.47.patched/sinfod/Makefile.in 2013-02-03 23:01:59.568634848 +1100
@@ -274,8 +274,8 @@
../libmessageio/libmessageio.la \
../librpc/librpc.la \
-lpthread \
- -lboost_signals-mt \
- -lboost_system-mt
+ -lboost_signals\
+ -lboost_system

MAINTAINERCLEANFILES = \
$(IDLXSOURCES)

This is to some extent indicated in the sinfo README (for BSD systems), so it should be an acceptable change.

If these changes are undertaken, the package will build without any issues.

Or am I missing something, being wet behind the ears in all things Arch?

Regards.

Anonymous comment on 2012-05-15 16:46

I will work on updating the package here. Thanks to the person who flagged this as out of date.

haawda commented on 2011-10-14 20:21

Army, are you already using pacman 4.0 from [testing]? Someone on arch general mailing list had a similar problem with an install file in array syntax. Pacman 4.0 detects such errors now an is upset.

Anonymous comment on 2011-10-14 13:36

Army:
New version uploaded.

I'm not sure why you are having that issue, as it would run just fine for me, but I fixed the install line. I also removed all of the pkill lines, as they weren't needed, but it was a paranoid precaution. But, I didn't even run into the issue with sinfo not running.

Regardless though, thanks for pointing that out to me. As said, new version is up and it doesn't give you the same issue.

Anonymous comment on 2011-10-14 04:55

I get a problem with the install file. In the PKGBUILD you have

install=('sinfo.install')

With this makepkg tells me

install file (('sinfo.install')) does not exist.

It works if you change that line to

install=sinfo.install

The install script itself produces this output

error: command failed to execute correctly

That may be caused by the fact that sinfo wasn't running. Are you sure the process has to be killed before an upgrade / removal? I've never seen anything like it in an Arch package!

Anonymous comment on 2011-10-14 03:32

The main problem is that the boost package for Arch compiles with the system setting for the target flag (target=system), which gets rid of the "-mt" portion of the library. The library itself is still multithreaded, just not named as such.

But, yes, we essentially came to the same result, just with a slightly different method.

haawda commented on 2011-10-14 03:28

Seems we were working on the same thing with similar results. See my PKGBUILD posted to the forum thread.

Anonymous comment on 2011-10-14 02:11

This version includes a fix for the previous issues that Army and Stefan mentioned in their comments. Tested makepkg without any root privileges and was successful.

Also added an install script to remove all files that were installed during process.

Anonymous comment on 2011-10-13 20:11

Army:

Wasn't in the guidelines for posting, but the issue is that Arch Linux's boost library doesn't provide libboost_signals-mt.a.

But, I'm working on a fix for it.

Also, I am taking it serious...no need to be quite defensive.