Package Details: siyuan-note-bin 3.0.16-1

Git Clone URL: https://aur.archlinux.org/siyuan-note-bin.git (read-only, click to copy)
Package Base: siyuan-note-bin
Description: A local-first personal knowledge management system.Use system-wide electron.
Upstream URL: https://b3log.org/siyuan/
Keywords: anki chatgpt electron evernote knowledge-base local-first markdown note-taking notebook notes-app notion obsidian ocr openai pdf pkm s3 self-hosted webdav
Licenses: AGPL-3.0-only
Conflicts: siyuan, siyuan-note
Provides: siyuan-note
Submitter: sukanka
Maintainer: bgt (zxp19821005)
Last Packager: zxp19821005
Votes: 16
Popularity: 0.073402
First Submitted: 2021-10-11 03:37 (UTC)
Last Updated: 2024-05-28 03:31 (UTC)

Dependencies (2)

Required by (0)

Sources (2)

Latest Comments

1 2 3 Next › Last »

pztrn commented on 2023-03-14 07:33 (UTC)

404 when trying to install.

Please, use Github Releases: https://github.com/siyuan-note/siyuan/releases

crafter_z commented on 2023-01-08 01:10 (UTC)

麻烦更新下依赖,官方源已将主线electron包改为electron22,现在依赖的electron22-bin应变更为electron

a15355447898a commented on 2023-01-05 10:23 (UTC) (edited on 2023-01-05 10:24 (UTC) by a15355447898a)

appimage的下载链接访问了一下显示404,去官网下载发现链接已经是https://release.b3log.org/siyuan/siyuan-2.6.2-linux.AppImage了

==> 获取源代码...

-> 正在下载 siyuan-2.6.1-linux.AppImage...

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:--:-- 0:00:01 --:--:-- 0

curl: (22) The requested URL returned error: 404

==> 错误: 无法下载 https://release.b3log.org/siyuan/siyuan-2.6.1-linux.AppImage

正在放弃...

-> 下载源文件时出错: siyuan-appimage

context: exit status 1

glatavento commented on 2022-10-23 05:55 (UTC)

@bgt 刚刚我又试了试,确实是 yay 不行,我刚刚试的时候不知道为啥shell里\没有unalias成

/usr/bin/yay -S siyuan-note-bin                                                 
 -> 找不到所有需要的包:
        electron21 (被这些包需要: siyuan-note-bin)

先手动装 electron21-bin 吧。。。

bgt commented on 2022-10-23 05:49 (UTC)

不过paru确实可以

bgt commented on 2022-10-23 05:45 (UTC)

奇怪,我也是yay啊

glatavento commented on 2022-10-23 05:44 (UTC) (edited on 2022-10-23 06:06 (UTC) by glatavento)

@bgt 你用的哪一个AUR helper?我试了yay和paru都可以

edit:我搞错了

$ yay -S siyuan-note-bin                                                            
:: 正在解析依赖关系...
:: 正在查找软件包冲突...
:: 正在查找内部软件包冲突...

Aur (2) electron21-bin-21.2.0-1  siyuan-note-bin-2.4.4-2

:: 继续安装? [Y/n]: ^C⏎     

$ paru -S siyuan-note-bin                                                          
:: 正在解析依赖关系...
:: 正在查找软件包冲突...
:: 正在查找内部软件包冲突...

Aur (2) electron21-bin-21.2.0-1  siyuan-note-bin-2.4.4-2

:: 继续安装? [Y/n]: ^C⏎     

bgt commented on 2022-10-23 05:39 (UTC)

但是现在下不了

 -> 找不到所有需要的包:
        electron21 (目标)

glatavento commented on 2022-10-23 05:38 (UTC)

@bgt 按说不用?electron21-bin 的 provides 里有 electron21

bgt commented on 2022-10-23 05:22 (UTC)

electron21是不是要写成electron21-bin啊