Package Details: sks 1.1.6-4

Git Clone URL: https://aur.archlinux.org/sks.git (read-only, click to copy)
Package Base: sks
Description: Synchronizing OpenPGP Key Server
Upstream URL: https://bitbucket.org/skskeyserver/sks-keyserver/
Keywords: keyserver sks
Licenses: GPL
Submitter: mortzu
Maintainer: ajdiaz
Last Packager: ajdiaz
Votes: 6
Popularity: 0.000000
First Submitted: 2011-03-02 17:32
Last Updated: 2020-08-31 18:02

Pinned Comments

ajdiaz commented on 2018-05-11 15:59

Unfortunately there is no basic conversion to ocaml 4.06, which has some changes related with return types of certain core functions (mainly now return bytes instead of string), and also it's no easy to move cryptokit 1.7 to ocaml-cryptokit package, because ocaml in arch does not support dynamic linking.

I will update the PKGBUILD to force a lower version of ocaml in dependencies. This will not resolve the problem and sks will still no buildable with current arch packages. I guess that we will need to wait to new sks release.

Any idea to resolve that is welcome of course :) Probably we should mark the package out-of-date anyway...

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

ncoder-2 commented on 2017-05-29 01:44

Getting the following while building:
ocamlc -g -c -ccopt "-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -I/usr/lib/ocaml -I ." stubs-md5.c
stubs-md5.c:21:9: error: unknown type name ‘uint32’
uint32 buf[4];
^~~~~~
stubs-md5.c:22:9: error: unknown type name ‘uint32’
uint32 bits[2];
^~~~~~
make[1]: *** [Makefile:101: stubs-md5.o] Error 2
make[1]: Leaving directory '/home/admin/dd/sks/src/sks-1.1.6/cryptokit-1.7/src'
make: *** [Makefile:292: cryptokit-1.7/src/cr

ajdiaz commented on 2016-09-17 08:21

Package does not build because of invalid GPG signature. The signatured defined in validpgpkeys is not valid for version 1.1.6 [1], instead of that we should use key C90EF1430B3AC0DFD00E6EA541259773973A612A.

[1] https://lists.gnupg.org/pipermail/gnupg-users/2016-August/056398.html

Torxed commented on 2013-12-11 14:15

Doesn't build. Not only is the upstream link broken and reported here: https://bitbucket.org/skskeyserver/sks-keyserver/issue/2/use-of-deprecated-operator-or it also contains linkage errors searching for Berkeley DB 4.6. Use SKS-HG instead found here: https://aur.archlinux.org/packages/sks-hg/

plueschopath commented on 2013-10-20 20:01

Problem seems to be solved in upstream.

plueschopath commented on 2013-10-20 19:40

The package is broken for me.

Error: Some fatal warnings were triggered (1 occurrences)
Makefile:386: recipe for target 'mArray.cmx' failed
make: *** [mArray.cmx] Error 2
==> ERROR: A failure occurred in build().
Aborting...

ogarcia commented on 2013-05-17 11:00

There is a bug in .service files for systemd. The "Type=fork" line must be "Type=simple" because the process stay in front.
And is a good idea add "TimeoutSec=300" for provide a reasonable time for startup and shutdown... ;)

mortzu commented on 2013-02-06 20:43

updated. next I'll provide a systemd service file

lutoma commented on 2013-02-06 07:24

orphan'd

mortzu commented on 2013-02-05 14:21

update or orphan

n4rky commented on 2012-10-12 22:36

Thanks for the update, but version 1.1.4 has just been released. :-/