Package Details: sky 2.1.7801-1

Git Clone URL: https://aur.archlinux.org/sky.git (read-only, click to copy)
Package Base: sky
Description: Lync and Skype for Business client on Linux
Upstream URL: https://tel.red
Licenses: custom: Copyright © 2015-2018 TEL.RED LLC
Submitter: telred
Maintainer: telred
Last Packager: telred
Votes: 61
Popularity: 0.000001
First Submitted: 2015-05-13 14:01 (UTC)
Last Updated: 2021-06-19 01:53 (UTC)

Latest Comments

tuyentv commented on 2020-08-18 04:36 (UTC)

@martin.mauch Thanks bro! I fixed that.

martin.mauch commented on 2020-08-17 10:04 (UTC)

@telred this patch makes it work: https://gist.github.com/nightscape/e73c206f29bd1f95690cdee23f5a6777

ridgea commented on 2020-08-14 08:30 (UTC)

An error occurs while installing the latest update

xz: (stdin): File format not recognized
tar: Child returned status 1
tar: Error is not recoverable: exiting now
==> ERROR: A failure occurred in package().
    Aborting...
error making: %!s(func() string=0x558e98939410)

vanek commented on 2020-07-17 08:38 (UTC) (edited on 2020-07-17 10:44 (UTC) by vanek)

it still is in the PKGBUILD. Edit: now builds

tuyentv commented on 2020-07-17 07:10 (UTC) (edited on 2020-07-17 07:11 (UTC) by tuyentv)

@@! really sorry you! I was remove depends qt-base<=5.15. Please try update again.

vanek commented on 2020-07-17 06:09 (UTC)

yay fails with: -> Could not find all required packages: qt5-base<=5.15 (Wanted by: sky)

tuyentv commented on 2020-07-15 09:56 (UTC)

@ridgea we fixed it. Please try again!

ridgea commented on 2020-07-15 08:40 (UTC) (edited on 2020-07-15 08:42 (UTC) by ridgea)

Error during installation of the latest version

==> ERROR: Failure while downloading https://tel.red/repos/archlinux/sky-archlinux-2.1-7599-x86_64.pkg.tar.xz

there is a typo, should be https://tel.red/repos/archlinux/sky-archlinux-2.1.7599-x86_64.pkg.tar.xz

dot instead of dash

KolLolZol commented on 2020-07-06 07:43 (UTC) (edited on 2020-07-06 07:45 (UTC) by KolLolZol)

@tuximail nope it is not, here is version 2.1.7520 and newest is 2.1.7589 packages are available for all other systems, tel.red said it will be updated here soon. now I am using appimage package because it solves some bugs, but I am waiting for an update here

tuximail commented on 2020-07-02 20:05 (UTC)

I am wonderint what the reason for the outdated flag is. As far as I can see, this package is based on the latest version of sky...

hogar1977 commented on 2019-08-29 07:53 (UTC)

@dawheela

I get the same segmentation fault. Maybe our qt5-base is too new? version 5.13 instead of 5.12 as mentioned below?

pezz commented on 2019-07-25 00:39 (UTC) (edited on 2019-07-25 04:50 (UTC) by pezz)

Latest version (2.1.7458.1-1) crashes every time making or receiving a call.

dawheela commented on 2019-05-13 15:32 (UTC) (edited on 2019-05-13 15:33 (UTC) by dawheela)

While installing the latest release I get the following error. Did anyone notice a similar behaviour?

Error: signal 11: /usr/lib/sky/lib/libsipw.so.1(handler+0x2a)[0x7fd0b7e0837a] /usr/lib/libc.so.6(+0x378b0)[0x7fd0b637a8b0] /usr/lib/sky/lib/libsipw.so.1(pjmedia_codec_mgr_destroy+0x20)[0x7fd0b7e8a930] /usr/lib/sky/lib/libsipw.so.1(pjmedia_endpt_create+0x118)[0x7fd0b7e8edc8] /usr/lib/sky/lib/libsipw.so.1(pjsua_media_subsys_init+0xc6)[0x7fd0b7d70ee6] /usr/lib/sky/lib/libsipw.so.1(pjsua_init+0x509)[0x7fd0b7d6b079] /usr/lib/sky/lib/libsipw.so.1(mswreg_init+0xce)[0x7fd0b7e0ac9e] /usr/lib/sky/lib/libsipw.so.1(sip_wrapper_init+0x62b)[0x7fd0b7d8e39b] /usr/lib/sky/lib/libsipw.so.1(cw_init2+0x1e)[0x7fd0b7dd61de] /usr/lib/sky/lib/libsipw.so.1(_ZN8CwConfig9configureEv+0x3e0)[0x7fd0b7d02930] zsh: segmentation fault (core dumped) sky

ogarcia commented on 2019-02-06 11:28 (UTC)

The license validator is DOWN.

% curl https://license.tel.red
curl: (7) Failed to connect to license.tel.red port 443: Connection timed out

je-vv commented on 2018-12-19 22:46 (UTC)

@mielecmichal, QT moved to 5.12 at least 2 weeks back. I'm using sky on 5.12 with no issues. Are you installing from AUR with outdated Arch?

mielecmichal commented on 2018-12-19 14:23 (UTC)

Look sky was compiled against qt 5.12 where current version is 5.11.

We get following error message: sky: /usr/lib/libQt5Core.so.5: version Qt_5.12' not found (required by sky) sky: /usr/lib/libQt5Core.so.5: versionQt_5.12' not found (required by /usr/lib/sky/lib/libsipw.so.1)

The solution for me was to install qt5-base and gt5-svg from .pkg.tar.xz But please express this in dependencies.

pezz commented on 2018-12-11 21:42 (UTC)

Is it even worth mentioning that W_KEY_LAST_LOG_LEVEL_7328=4 was set and causes crashing?

Does telred even read AUR comments?

pezz commented on 2018-11-15 02:22 (UTC)

W_KEY_LAST_LOG_LEVEL_X is still being set back to 4 and causes crashing after every upgrade.

Can you at least acknowledge the problem telred?

pezz commented on 2018-10-03 22:46 (UTC)

And again...

W_KEY_LAST_LOG_LEVEL_7279=4

pezz commented on 2018-10-03 00:03 (UTC) (edited on 2018-10-03 00:04 (UTC) by pezz)

And again after the upgrade in the conf:

W_KEY_LAST_LOG_LEVEL_7261=0

W_KEY_LAST_LOG_LEVEL_7278=4

Which leads to repeated crashing...

Unbelievable.

pezz commented on 2018-09-18 23:35 (UTC) (edited on 2018-09-18 23:35 (UTC) by pezz)

Could you PLEASE stop setting the log level back to 4 with EVERY version upgrade?

Unless you plan on fixing the crash that it causes....

Even bloody upgrade I have to edit the conf, delete old reference to this variable and set the latest to 0:

W_KEY_LAST_LOG_LEVEL_7261=0

Please fix this rubbish.

OvsInc commented on 2018-09-18 09:19 (UTC)

2.1.7261 version. I can`t activate license.

UTF_8x commented on 2018-08-23 09:29 (UTC) (edited on 2018-08-23 09:30 (UTC) by UTF_8x)

God damn proprietary trash... Drops calls every 2 minutes, segfaults every 5... Why do we even allow things like this to be here? This isn't even non-free, this is straight up commercial proprietary binary-blob trash...

So yeah. You can use Pidgin to connect to Lync. Please don't support this thing.

jakub commented on 2018-07-04 07:42 (UTC) (edited on 2018-07-04 07:44 (UTC) by jakub)

Sorry but this app is total crap. As it's non-free software it also disconnects every 2 minutes making conference attendance impossible.

qwelias commented on 2018-06-15 09:31 (UTC) (edited on 2018-06-18 19:46 (UTC) by qwelias)

2.1.7172.1-1 crash on launch

EDIT: So I've found out that this only happens on certain themes like gtk2, so if you ran into this too you can change theme in ~/.config/tel.red/Sky.conf

▶ sky
Selected style:  "gtk2"

(sky:15184): GLib-GObject-WARNING **: 12:28:45.412: cannot register existing type 'GdkDisplayManager'

(sky:15184): GLib-CRITICAL **: 12:28:45.412: g_once_init_leave: assertion 'result != 0' failed

(sky:15184): GLib-GObject-CRITICAL **: 12:28:45.412: g_object_new_with_properties: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

(sky:15184): GLib-GObject-WARNING **: 12:28:45.412: invalid (NULL) pointer instance

(sky:15184): GLib-GObject-CRITICAL **: 12:28:45.412: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(sky:15184): GLib-GObject-WARNING **: 12:28:45.412: invalid (NULL) pointer instance

(sky:15184): GLib-GObject-CRITICAL **: 12:28:45.412: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(sky:15184): GLib-GObject-WARNING **: 12:28:45.413: cannot register existing type 'GdkDisplay'

(sky:15184): GLib-CRITICAL **: 12:28:45.413: g_once_init_leave: assertion 'result != 0' failed

(sky:15184): GLib-GObject-CRITICAL **: 12:28:45.413: g_type_register_static: assertion 'parent_type > 0' failed

(sky:15184): GLib-CRITICAL **: 12:28:45.413: g_once_init_leave: assertion 'result != 0' failed

(sky:15184): GLib-GObject-CRITICAL **: 12:28:45.413: g_object_new_with_properties: assertion 'G_TYPE_IS_OBJECT (object_type)' failed
[1]    15184 segmentation fault (core dumped)  sky

je-vv commented on 2018-06-05 00:01 (UTC)

Well, version 2.1.7170.1-1 doesn't have the dependency issue, but sure crashes on sharing desktop or viewing another guy's sharing...

joe1l commented on 2018-05-30 19:45 (UTC)

is there a workaround for qt5-base<5.11 dependency that i can use to get sky up and running.

gasoo commented on 2018-05-30 11:59 (UTC) (edited on 2018-05-30 12:00 (UTC) by gasoo)

Same for me. Upon accepting screen sharing in a conference, the application crashes. I tried both, with VBSS enabled and disabled.

boecki commented on 2018-05-30 09:52 (UTC)

I have the same problem here. Sky crashes if I join a meeting and someone is trying to share his/her desktop. I already sent an email with logfile and debugger backtrace to "tel.red". I hope, they will fix this soon.

je-vv commented on 2018-05-30 06:16 (UTC) (edited on 2018-05-30 06:17 (UTC) by je-vv)

new package v2.1.7156-1 doesn't support looking at shared desktops, neither desktop sharing. It just crashes...

besides, it's once again having problems with dependencies:

+++ % pacman -S sky <br> resolving dependencies... warning: cannot resolve "qt5-base<5.11", a dependency of "sky" :: The following package cannot be upgraded due to unresolvable dependencies: sky +++

rs0x29a commented on 2018-05-25 08:19 (UTC) (edited on 2018-05-25 08:24 (UTC) by rs0x29a)

sky 2.1.7156.1-1 ....SIP registration error: Unknown pjsip error 171115 [status=171115]

2018-05-25 10:56:15.503      msw_reg.c thr0x7f344e2ERROR: !username: ***, sipDomain: ***, ntmlDomain: ***, ntlmUser: ***
2018-05-25 10:56:15.519      msw_reg.c thr0x7f344e2ERROR:  after calculating, ntmlDomain: ***, ntlmUser: ***
2018-05-25 10:56:15.519      msw_reg.c thr0x7f344e2ERROR:  video capture dev: -1, video rener dev: -2
2018-05-25 10:56:18.090 sip_auth_tls_d   wync_ua[0] WARN: !...can't get alias of namespace related to Assertion, use default values
2018-05-25 10:56:18.090    pjsua_acc.c   wync_ua[0]ERROR:  ....SIP registration error: Unknown pjsip error 171115 [status=171115]
2018-05-25 10:56:21.091 sip_endpoint.c   wync_ua[0] WARN:  .handling response on module mod-tsx-layer slow with 5007 ms
2018-05-25 10:56:21.091 sip_transport.   wync_ua[0] WARN:  ..trick, don't release tdata-->pool to avoid crash
ldd /usr/lib/sky/sky                               
        linux-vdso.so.1 (0x00007ffdaa365000)
        libavcodec.so.58 => /usr/lib/libavcodec.so.58 (0x00007f2c72e97000)
        libSDL-1.3.so.0 => /usr/lib/sky/lib/libSDL-1.3.so.0 (0x00007f2c72bd9000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0x00007f2c7289a000)
        libXss.so.1 => /usr/lib/libXss.so.1 (0x00007f2c72696000)
        libsipw.so.1 => /usr/lib/sky/lib/libsipw.so.1 (0x00007f2c71a40000)
        libQt5Widgets.so.5 => /usr/lib/libQt5Widgets.so.5 (0x00007f2c711e6000)
        libQt5Gui.so.5 => /usr/lib/libQt5Gui.so.5 (0x00007f2c70a25000)
        libQt5Network.so.5 => /usr/lib/libQt5Network.so.5 (0x00007f2c70699000)
        libQt5DBus.so.5 => /usr/lib/libQt5DBus.so.5 (0x00007f2c7040f000)
        libQt5Core.so.5 => /usr/lib/libQt5Core.so.5 (0x00007f2c6fd07000)
        libGL.so.1 => /usr/lib/libGL.so.1 (0x00007f2c6fa7c000)
        libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f2c6f85e000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f2c6f4d5000)
        libm.so.6 => /usr/lib/libm.so.6 (0x00007f2c6f140000)
        libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007f2c6ef28000)
        libc.so.6 => /usr/lib/libc.so.6 (0x00007f2c6eb6c000)
        libswresample.so.3 => /usr/lib/libswresample.so.3 (0x00007f2c6e94f000)
        libavutil.so.56 => /usr/lib/libavutil.so.56 (0x00007f2c6e6d6000)
        libvpx.so.5 => /usr/lib/libvpx.so.5 (0x00007f2c6e14c000)
        libwebpmux.so.3 => /usr/lib/libwebpmux.so.3 (0x00007f2c6df42000)
        libwebp.so.7 => /usr/lib/libwebp.so.7 (0x00007f2c6dcd4000)
        liblzma.so.5 => /usr/lib/liblzma.so.5 (0x00007f2c6daae000)
        libopencore-amrwb.so.0 => /usr/lib/libopencore-amrwb.so.0 (0x00007f2c6d89a000)
        libz.so.1 => /usr/lib/libz.so.1 (0x00007f2c6d683000)
        libgsm.so.1 => /usr/lib/libgsm.so.1 (0x00007f2c6d477000)
        libmp3lame.so.0 => /usr/lib/libmp3lame.so.0 (0x00007f2c6d1ff000)
        libopencore-amrnb.so.0 => /usr/lib/libopencore-amrnb.so.0 (0x00007f2c6cfd5000)
        libopenjp2.so.7 => /usr/lib/libopenjp2.so.7 (0x00007f2c6cd79000)
        libopus.so.0 => /usr/lib/libopus.so.0 (0x00007f2c6cb25000)
        libspeex.so.1 => /usr/lib/libspeex.so.1 (0x00007f2c6c90c000)
        libtheoraenc.so.1 => /usr/lib/libtheoraenc.so.1 (0x00007f2c6c6cd000)
        libtheoradec.so.1 => /usr/lib/libtheoradec.so.1 (0x00007f2c6c4b3000)
        libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0x00007f2c6c287000)
        libvorbisenc.so.2 => /usr/lib/libvorbisenc.so.2 (0x00007f2c6bfde000)
        libx264.so.152 => /usr/lib/libx264.so.152 (0x00007f2c6bc63000)
        libx265.so.151 => /usr/lib/libx265.so.151 (0x00007f2c6ac1d000)
        libxvidcore.so.4 => /usr/lib/libxvidcore.so.4 (0x00007f2c6a90c000)
        libva.so.2 => /usr/lib/libva.so.2 (0x00007f2c6a6ea000)
        libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f2c6a4e6000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007f2c6a2bd000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0x00007f2c6a0ab000)
        libv4l2.so.0 => /usr/lib/libv4l2.so.0 (0x00007f2c69e9c000)
        libuuid.so.1 => /usr/lib/libuuid.so.1 (0x00007f2c69c95000)
        libcurl.so.4 => /usr/lib/libcurl.so.4 (0x00007f2c69a15000)
        libcrypto.so.1.1 => /usr/lib/libcrypto.so.1.1 (0x00007f2c69598000)
        libssl.so.1.1 => /usr/lib/libssl.so.1.1 (0x00007f2c6932e000)
        libopenh264.so.0 => /usr/lib/sky/lib/libopenh264.so.0 (0x00007f2c69056000)
        libavformat.so.58 => /usr/lib/libavformat.so.58 (0x00007f2c68c0f000)
        libswscale.so.5 => /usr/lib/libswscale.so.5 (0x00007f2c68986000)
        libfreerdp.so.2.0 => /usr/lib/sky/lib/libfreerdp.so.2.0 (0x00007f2c6862a000)
        libfreerdp-client.so.2.0 => /usr/lib/sky/lib/libfreerdp-client.so.2.0 (0x00007f2c68386000)
        libfreerdp-shadow.so.2.0 => /usr/lib/sky/lib/libfreerdp-shadow.so.2.0 (0x00007f2c68165000)
        libxfreerdp-client.so.2.0 => /usr/lib/sky/lib/libxfreerdp-client.so.2.0 (0x00007f2c67ebd000)
        libpulse.so.0 => /usr/lib/libpulse.so.0 (0x00007f2c67c6c000)
        libsqlite3.so.0 => /usr/lib/libsqlite3.so.0 (0x00007f2c67957000)
        libresolv.so.2 => /usr/lib/libresolv.so.2 (0x00007f2c67740000)
        libpng16.so.16 => /usr/lib/libpng16.so.16 (0x00007f2c6750a000)
        libharfbuzz.so.0 => /usr/lib/libharfbuzz.so.0 (0x00007f2c67258000)
        libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0x00007f2c67007000)
        libsystemd.so.0 => /usr/lib/libsystemd.so.0 (0x00007f2c66d80000)
        libicui18n.so.61 => /usr/lib/libicui18n.so.61 (0x00007f2c668d5000)
        libicuuc.so.61 => /usr/lib/libicuuc.so.61 (0x00007f2c6651b000)
        libpcre2-16.so.0 => /usr/lib/libpcre2-16.so.0 (0x00007f2c662a4000)
        libdouble-conversion.so.1 => /usr/lib/libdouble-conversion.so.1 (0x00007f2c66094000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00007f2c65d7d000)
        /lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x00007f2c7499e000)
        libGLX.so.0 => /usr/lib/libGLX.so.0 (0x00007f2c65b4c000)
        libGLdispatch.so.0 => /usr/lib/libGLdispatch.so.0 (0x00007f2c65896000)
        libsoxr.so.0 => /usr/lib/libsoxr.so.0 (0x00007f2c65622000)
        libva-drm.so.2 => /usr/lib/libva-drm.so.2 (0x00007f2c6541f000)
        libva-x11.so.2 => /usr/lib/libva-x11.so.2 (0x00007f2c65219000)
        libvdpau.so.1 => /usr/lib/libvdpau.so.1 (0x00007f2c65015000)
        libdrm.so.2 => /usr/lib/libdrm.so.2 (0x00007f2c64e03000)
        libogg.so.0 => /usr/lib/libogg.so.0 (0x00007f2c64bfc000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0x00007f2c649f8000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007f2c647f2000)
        libv4lconvert.so.0 => /usr/lib/libv4lconvert.so.0 (0x00007f2c64578000)
        libnghttp2.so.14 => /usr/lib/libnghttp2.so.14 (0x00007f2c64353000)
        libidn2.so.0 => /usr/lib/libidn2.so.0 (0x00007f2c64136000)
        libpsl.so.5 => /usr/lib/libpsl.so.5 (0x00007f2c63f26000)
        libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x00007f2c63cd8000)
        libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x00007f2c639ef000)
        libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x00007f2c637bc000)
        libcom_err.so.2 => /usr/lib/libcom_err.so.2 (0x00007f2c635b8000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0x00007f2c63252000)
        libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0x00007f2c63042000)
        libmodplug.so.1 => /usr/lib/libmodplug.so.1 (0x00007f2c62cb7000)
        libbluray.so.2 => /usr/lib/libbluray.so.2 (0x00007f2c62a66000)
        libgmp.so.10 => /usr/lib/libgmp.so.10 (0x00007f2c627d3000)
        libgnutls.so.30 => /usr/lib/libgnutls.so.30 (0x00007f2c62468000)
        libssh.so.4 => /usr/lib/libssh.so.4 (0x00007f2c621ec000)
        libxkbfile.so.1 => /usr/lib/libxkbfile.so.1 (0x00007f2c61fc6000)
        libjpeg.so.8 => /usr/lib/libjpeg.so.8 (0x00007f2c61d5e000)
        libwinpr.so.1.1 => /usr/lib/sky/lib/libwinpr.so.1.1 (0x00007f2c61a76000)
        librt.so.1 => /usr/lib/librt.so.1 (0x00007f2c6186e000)
        libXmu.so.6 => /usr/lib/libXmu.so.6 (0x00007f2c61653000)
        libasound.so.2 => /usr/lib/libasound.so.2 (0x00007f2c61373000)
        libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x00007f2c61170000)
        libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x00007f2c60f66000)
        libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x00007f2c60d63000)
        libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x00007f2c60b5d000)
        libXtst.so.6 => /usr/lib/libXtst.so.6 (0x00007f2c60957000)
        libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x00007f2c6074c000)
        libpam.so.0 => /usr/lib/libpam.so.0 (0x00007f2c6053e000)
        libfreerdp-server.so.2.0 => /usr/lib/sky/lib/libfreerdp-server.so.2.0 (0x00007f2c6031f000)
        librdtk.so.1.1 => /usr/lib/sky/lib/librdtk.so.1.1 (0x00007f2c60116000)
        libXv.so.1 => /usr/lib/libXv.so.1 (0x00007f2c5ff11000)
        libXi.so.6 => /usr/lib/libXi.so.6 (0x00007f2c5fd00000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00007f2c5faf5000)
        libpulsecommon-11.1.so => /usr/lib/pulseaudio/libpulsecommon-11.1.so (0x00007f2c5f872000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00007f2c5f5a9000)
        libgraphite2.so.3 => /usr/lib/libgraphite2.so.3 (0x00007f2c5f37d000)
        liblz4.so.1 => /usr/lib/liblz4.so.1 (0x00007f2c5f166000)
        libgcrypt.so.20 => /usr/lib/libgcrypt.so.20 (0x00007f2c5ee4a000)
        libicudata.so.61 => /usr/lib/libicudata.so.61 (0x00007f2c5d2a5000)
        libpcre.so.1 => /usr/lib/libpcre.so.1 (0x00007f2c5d033000)
        libgomp.so.1 => /usr/lib/libgomp.so.1 (0x00007f2c5ce05000)
        libunistring.so.2 => /usr/lib/libunistring.so.2 (0x00007f2c5ca84000)
        libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0x00007f2c5c877000)
        libkeyutils.so.1 => /usr/lib/libkeyutils.so.1 (0x00007f2c5c673000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00007f2c5c430000)
        libp11-kit.so.0 => /usr/lib/libp11-kit.so.0 (0x00007f2c5c103000)
        libtasn1.so.6 => /usr/lib/libtasn1.so.6 (0x00007f2c5bef0000)
        libnettle.so.6 => /usr/lib/libnettle.so.6 (0x00007f2c5bcb9000)
        libhogweed.so.4 => /usr/lib/libhogweed.so.4 (0x00007f2c5ba83000)
        libXt.so.6 => /usr/lib/libXt.so.6 (0x00007f2c5b81a000)
        libsndfile.so.1 => /usr/lib/libsndfile.so.1 (0x00007f2c5b5a2000)
        libasyncns.so.0 => /usr/lib/libasyncns.so.0 (0x00007f2c5b39c000)
        libgpg-error.so.0 => /usr/lib/libgpg-error.so.0 (0x00007f2c5b17c000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00007f2c5af4a000)
        libffi.so.6 => /usr/lib/libffi.so.6 (0x00007f2c5ad41000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0x00007f2c5ab39000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0x00007f2c5a91d000)
        libFLAC.so.8 => /usr/lib/libFLAC.so.8 (0x00007f2c5a6a5000)

Latest AppImage broken -rwxr-xr-x 1 rs0x29a rs0x29a 25493504 мая 25 10:59 sky-latest-x86_64.AppImage

This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".

Available platform plugins are: xcb.

Reinstalling the application may fix this problem.
[1]    16763 abort (core dumped)  ./sky-latest-x86_64.AppImage

peshane commented on 2018-05-18 12:21 (UTC)

new package v2.1.7156-1 is working well, thanks for the update :)

peshane commented on 2018-05-16 12:53 (UTC) (edited on 2018-05-16 12:54 (UTC) by peshane)

Is it still supported ?

Actual PKGBUILD version do not works anymore (link to obsoletes libraries):

    $ ldd /usr/lib/sky/sky | awk '/not found/ {print $1}'
    /usr/lib/sky/sky:
    libavcodec.so.57
    libavcodec.so.57
    libavformat.so.57
    libswscale.so.4
    libavcodec.so.57
    libavcodec.so.57
    libavcodec.so.57

and latest AppImage broken too:

    $ LD_DEBUG=libs ./sky-latest-x86_64.AppImage
    .
    .  (lots of lines)
    .
          7945:       trying file=./lib/x86_64/libfreetype.so.6
          7945:       trying file=./lib/libfreetype.so.6
          7945:
          7945:     /usr/lib/libfontconfig.so.1: error: symbol lookup error: undefined symbol: FT_Done_MM_Var (fatal)
    This application failed to start because it could not find or load the Qt platform plugin "xcb"
    in "".

    Available platform plugins are: xcb.

    Reinstalling the application may fix this problem.

tulleydr commented on 2018-02-10 04:36 (UTC)

Is there any way to sync contact info between sky linux and your connected exchange? It seem to me that you can only search for contacts you already have added in sky and not the contacts on your exchange.

gunix commented on 2018-01-31 11:51 (UTC)

Screen sharing fails on Wayland. Just use X.

SanskritFritz commented on 2017-09-19 08:50 (UTC)

Just use the official upstream appimage: https://tel.red/linux/sky-latest-x86_64.AppImage

pezz commented on 2017-08-07 23:45 (UTC)

2.1.6918 just locks up when attempting to sign in. It's like a crap shoot these days on whether Sky works or not, can't believe how buggy this software still is.

trillanewhero commented on 2017-06-15 03:57 (UTC)

Hello, i'm getting the error: Selected style: "Windows" QSS file loaded: "/usr/lib/sky/stylesheets/stylesheet_default.qss" 2017-06-15 08:48:46.099 pjsua_core.c thr0x7f86159DEBUG: !.pjsua_core, start image_stack 2017-06-15 08:48:46.099 pjsua_core.c thr0x7f86159DEBUG: .create pjsua_var.mutex 2017-06-15 08:48:46.099 pjsua_core.c thr0x7f86159DEBUG: .create SIP endpoint 2017-06-15 08:48:46.100 pjsua_core.c thr0x7f86159DEBUG: .Create timer mutex 2017-06-15 08:48:46.100 pjsua_core.c thr0x7f86159DEBUG: .pjsua created successfully 2017-06-15 08:48:46.167 msw_reg.c thr0x7f86159DEBUG: Initiating pjsua ... DBUS API INITIALIZED QObject::connect: No such slot WSessionManager::onSetOffHookJabraHeadsetButton() sky: malloc.c:2369: sysmalloc: Assertion `(old_top == initial_top (av) && old_size == 0) || ((unsigned long) (old_size) >= MINSIZE && prev_inuse (old_top) && ((unsigned long) old_end & (pagesize - 1)) == 0)' failed. How can i fix it?

syaorandroid commented on 2017-06-13 01:37 (UTC) (edited on 2017-06-13 01:38 (UTC) by syaorandroid)

to fix the error, must install this version of qt5-base: https://www.archlinux.org/packages/extra/x86_64/qt5-base/ Hope it helps!

syaorandroid commented on 2017-06-09 20:22 (UTC)

is that fixed? I'm getting the error sky: /usr/lib/libQt5Core.so.5: version `Qt_5.9' not found (required by sky) sky: /usr/lib/libQt5Core.so.5: version `Qt_5.9' not found (required by /usr/lib/sky/lib/libsipw.so.1)

GI_Jack commented on 2017-06-08 19:04 (UTC)

qt-base 5.9 is out, package breaks, please fix

YHVH commented on 2017-05-28 19:21 (UTC)

Updated but still broken, crashes when signing in

GI_Jack commented on 2017-04-25 17:35 (UTC)

openssl-1.0 is in [extra], should base off that.

je-vv commented on 2017-04-24 17:34 (UTC)

openssl 1.1.0 already reached Arch, and now Sky is in trouble: ++++ error: failed to prepare transaction (could not satisfy dependencies) :: sky: installing openssl (1.1.0.e-1) breaks dependency 'openssl<1.1.0' ++++

je-vv commented on 2017-04-23 01:58 (UTC)

Moreover, openssl 1.* is about to be released from testing... See: https://lists.archlinux.org/pipermail/arch-dev-public/2017-April/028806.html And as sky indicates when installing, it won't work with openssl 1.*

je-vv commented on 2017-04-23 01:54 (UTC)

Latest 2.1.6669-201704211917 still broken. Same behavior as 2.1.6660-201704171056.

je-vv commented on 2017-04-21 00:10 (UTC)

Just in case, while prior version "2.1.6633-201703311250" was more stable than earlier ones, the newer version "2.1.6660-201704171056" breaks sky. On just login sky freezes, and one needs to "kill -9" sky, for it to relaunch. Once relaunched, it periodically crashes and relaunch, with a period of around 1 minute in my case. That actually breaks sky, specially when under meetings...

jetm commented on 2017-04-05 17:27 (UTC)

I am getting this segmentation fault: $ sky Selected style: "gtk2" (sky:20488): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplayManager' (sky:20488): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed (sky:20488): GLib-GObject-CRITICAL **: g_object_new: assertion 'G_TYPE_IS_OBJECT (object_type)' failed (sky:20488): GLib-GObject-WARNING **: invalid (NULL) pointer instance (sky:20488): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed (sky:20488): GLib-GObject-WARNING **: invalid (NULL) pointer instance (sky:20488): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed (sky:20488): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplay' (sky:20488): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed (sky:20488): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed (sky:20488): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed (sky:20488): GLib-GObject-CRITICAL **: g_object_new: assertion 'G_TYPE_IS_OBJECT (object_type)' failed I was testing themes and broke when I selected gkt2. I have tried to look where to change the theme from a config file, but I haven't found a config file. How could I fix Sky?

dfaught commented on 2017-04-03 13:12 (UTC)

Latest release is much more stable. I have observed no segfaults in the last 24 hours. Good work

dfaught commented on 2017-03-24 13:15 (UTC) (edited on 2017-03-24 13:26 (UTC) by dfaught)

Every 30 seconds... Error: signal 11: /usr/lib/sky/lib/libsipw.so.1(handler+0x17)[0x7fc9e4c7b747] /usr/lib/libc.so.6(+0x33a90)[0x7fc9e1daba90] /usr/lib/sky/lib/libsipw.so.1(mswabs_avatar_download_photo+0x762)[0x7fc9e4c73722] /usr/lib/sky/lib/libsipw.so.1(mswabs_get_avatar+0x603)[0x7fc9e4c73ef3] /usr/lib/sky/lib/libsipw.so.1(mswpres_download_image_proc+0x2b0)[0x7fc9e4c1e740] /usr/lib/sky/lib/libsipw.so.1(+0x275b96)[0x7fc9e4d74b96] /usr/lib/libpthread.so.0(+0x72e7)[0x7fc9e29d52e7] /usr/lib/libc.so.6(clone+0x3f)[0x7fc9e1e6454f] [1] 12802 segmentation fault (core dumped) /usr/bin/sky

dfaught commented on 2017-03-01 14:03 (UTC) (edited on 2017-03-01 14:42 (UTC) by dfaught)

Your end package name is identical to your source name. It causes a conflict when trying to build the package. Change the name of your src file or package. Or specify an alternate download name for the source: source('not_package_name:url') Still seg faults repeatedly. Stack trace hints it is trying to do something with downloading avatar photos. I'm going to have to roll back to the last usable version, for me that was 2.1.6513. It seg faulted a few times a day, but was better than a fault every 3-5 minutes.

dfaught commented on 2017-02-17 15:32 (UTC)

Removing the qt5-base<5.8.0 still works but the current version seg faults repeatedly. Approximately every 5 to 10 seconds. Completely unusable.

F1nny commented on 2017-02-16 04:01 (UTC) (edited on 2017-02-16 04:33 (UTC) by F1nny)

So why do the deps list qt5-base less than 5.8? Keeping the dep, this package is broken. However removing that dependency it seems to work fine?

pezz commented on 2017-02-14 00:15 (UTC)

This is still broken due to the qt5-base<5.8.0 requirement.

chetwisniewski commented on 2017-01-30 19:40 (UTC)

Removing the qt5-base<5.8.0 works for me.

peterix commented on 2017-01-30 11:25 (UTC)

The package is now entirely broken: * Wrong curl version required. * Depends on differently built openssl. Arch openssl does not include symbol versions. * Depends on qt5 < 5.8.0, which breaks system updates. Qt5 is one of the few dependencies that provides strong binary compatibility guarantees, so this should be unnecessary. * The bundled custom build of SDL crashes and prevents the application from starting.

peterix commented on 2017-01-10 12:47 (UTC)

Current version didn't start properly because of segmentation fault in the bundled libSDL. I removed the bundled library and replaced it with the system libSDL - now it starts.

telred commented on 2016-11-14 22:01 (UTC) (edited on 2016-11-15 22:46 (UTC) by telred)

@jevv, @jlaunay, As well as anyone got some problems with sky package at present or in the future. If your sky issues are still there or something new arise, please spend few seconds writing an email to sky support to linux (at) tel.red, posting a bug report describing your issue with logs attached. It will be much easier for our QA and developers teams to track the problem and contact requester in case any questions arise, speeding up troubleshooting significantly

je-vv commented on 2016-11-12 05:56 (UTC)

Not able to use audio at all (alsa way, no pulse): Expression 'snd_pcm_hw_params_set_channels( pcm, hwParams, self->numHostChannels )' failed in 'src/../../../portaudio/src/hostapi/alsa/pa_linux_alsa.c', line: 1309 Expression 'PaAlsaStreamComponent_InitialConfigure( &self->capture, inParams, self->primeBuffers, hwParamsCapture, &realSr )' failed in 'src/../../../portaudio/src/hostapi/alsa/pa_linux_alsa.c', line: 1876 Expression 'PaAlsaStream_Configure( stream, inputParameters, outputParameters, sampleRate, framesPerBuffer, &inputLatency, &outputLatency, &hostBufferSizeMode )' failed in 'src/../../../portaudio/src/hostapi/alsa/pa_linux_alsa.c', line: 2000 Expression 'snd_pcm_hw_params_set_channels( pcm, hwParams, self->numHostChannels )' failed in 'src/../../../portaudio/src/hostapi/alsa/pa_linux_alsa.c', line: 1309 Expression 'PaAlsaStreamComponent_InitialConfigure( &self->playback, outParams, self->primeBuffers, hwParamsPlayback, &realSr )' failed in 'src/../../../portaudio/src/hostapi/alsa/pa_linux_alsa.c', line: 1879 Expression 'PaAlsaStream_Configure( stream, inputParameters, outputParameters, sampleRate, framesPerBuffer, &inputLatency, &outputLatency, &hostBufferSizeMode )' failed in 'src/../../../portaudio/src/hostapi/alsa/pa_linux_alsa.c', line: 2000 Using apulse doesn't help solving the issue either.

bburlein commented on 2016-11-04 16:00 (UTC)

@jlaunay, is screensharing and audio working for you as well? both are intermittent for me, i'm using arch gnome3. if so, did you have to do anything to get them working? thanks!

telred commented on 2016-11-02 21:43 (UTC)

@ignite, thanks for report. This problem is fixed in 2.1.6375-3 release

ignite commented on 2016-11-02 20:26 (UTC)

The package is missing sky.sh resulting in an error https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=sky#n60

telred commented on 2016-11-02 14:22 (UTC)

It could be an openssl version problem, but not sure. We will fix that issue in our repo.

jlaunay commented on 2016-11-02 14:17 (UTC)

@telred, thanks for the suggestion, no problem with your AppImage, I can connect. I have no idea which dependency could cause this problem on my box, any idea ?

telred commented on 2016-11-02 13:53 (UTC)

Jérôme,you can try our AppImage package at tel.red/linux.php

jlaunay commented on 2016-11-02 12:34 (UTC)

I have 2 arch boxes, on the first one, using gnome3 sky works perfectly, on the second one using i3 I can't connect and get the log below : 2016-11-02 13:29:50.820 msw_reg.c thr0x7f55e97ERROR: app version, code: 6343(core:5909, lib:109, app:325), name: 2.1.6343, os_id: Others_64 2016-11-02 13:30:05.299 msw_reg.c thr0x7f55e97ERROR: username: xxxxxxx, sipDomain: xxxxxxx.fr, ntmlDomain: xxxxxxx, ntlmUser: xxxxxxx 2016-11-02 13:30:05.300 msw_reg.c thr0x7f55e97ERROR: after calculating, ntmlDomain: xxxxxxx, ntlmUser: xxxxxxx 2016-11-02 13:30:05.300 msw_reg.c thr0x7f55e97ERROR: audio capture dev: -1, audio playback dev: -2 2016-11-02 13:30:05.300 msw_reg.c thr0x7f55e97ERROR: video capture dev: -1, video rener dev: -2 2016-11-02 13:30:05.805 sip_auth_tls_d wync_ua[0]ERROR: !...did parse mexurl successfully 2016-11-02 13:30:06.791 pjsua_acc.c wync_ua[0]ERROR: ....SIP registration error: Unknown pjsip error 171115 [status=171115] No problem with credentials (same one the first box), does someone have an idea and/or have already seen this "unknow error 171115" ?

jpalko commented on 2016-10-07 05:54 (UTC)

Started complaining this to me after updating my system this morning: /usr/lib/sky/sky: /usr/lib/sky/lib/libcurl.so.4: no version information available (required by /usr/lib/sky/lib/libsipw.so.1) /usr/lib/sky/sky: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /usr/lib/sky/lib/libfreerdp-shadow.so.2.0) /usr/lib/sky/sky: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /usr/lib/sky/lib/libfreerdp.so.2.0) /usr/lib/sky/sky: /usr/lib/libssl.so.1.0.0: no version information available (required by /usr/lib/sky/lib/libfreerdp.so.2.0) /usr/lib/sky/sky: /usr/lib/libssl.so.1.0.0: no version information available (required by /usr/lib/sky/lib/libwinpr.so.1.1) /usr/lib/sky/sky: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /usr/lib/sky/lib/libwinpr.so.1.1) No additional output after those... also executing with strace it does not show anything additional after those. Tried quickly the sky.sh idea but substituted /usr/lib/sky/lib in LD_LIBRARY_PATH.

peshane commented on 2016-08-09 15:35 (UTC)

Hi, When connecting, sky just segfault few seconds/minutes later with a 139 exit code. Debug show this: 2016-08-09 17:15:55.907 sip_transport. wync_ua[0]DEBUG: !pjsip_transport_destroy 2016-08-09 17:15:55.907 activesock.c wync_ua[0] INFO: prepare pj_ioqueue_unregister asock->key which has fd: 29 2016-08-09 17:15:55.907 ioqueue_common wync_ua[0] INFO: uuuuuuuu unregister key: 20494504 prepare close key->fd: 29, after decrease current ioqueue->count: 1 2016-08-09 17:15:55.907 ioqueue_common wync_ua[0] INFO: after close key->fd, clear callback 2016-08-09 17:15:55.907 tlsc0x16de240 wync_ua[0]DEBUG: TLS transport destroyed normally /usr/bin/sky : ligne 20 : 24837 Segmentation fault (core dumped) ${_SKY_PREFIX}/sky "$@" Not sure to have something usefull in ~/.sky2/logs/native too (file wcorestack.log is ~1 minute older than the core dump) I try to force LD_LIBRARY_PATH without success. A support ticket have been open but well, I still wait. Just digging a little with a coredump, maybe be qt related, don't know: #0 0x00007fa5be4d6364 in free () from /usr/lib/libc.so.6 #1 0x00007fa5bfe396dd in QImageData::~QImageData() () from /usr/lib/libQt5Gui.so.5 #2 0x00007fa5bfe39f57 in QImage::~QImage() () from /usr/lib/libQt5Gui.so.5 #3 0x00007fa5bfe7669c in QRasterPlatformPixmap::~QRasterPlatformPixmap() () from /usr/lib/libQt5Gui.so.5 #4 0x00007fa5bfe766b9 in QRasterPlatformPixmap::~QRasterPlatformPixmap() () from /usr/lib/libQt5Gui.so.5 #5 0x00007fa5bfe67fa1 in QPixmap::~QPixmap() () from /usr/lib/libQt5Gui.so.5 #6 0x00007fa5bfe6d52f in ?? () from /usr/lib/libQt5Gui.so.5 #7 0x00007fa5bfe6dbd5 in ?? () from /usr/lib/libQt5Gui.so.5 #8 0x00007fa5bf56b303 in QObject::event(QEvent*) () from /usr/lib/libQt5Core.so.5 #9 0x00007fa5c0587e3c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5 #10 0x00007fa5c058f5b1 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5 #11 0x00007fa5bf53ec80 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5 #12 0x00007fa5bf59251e in QTimerInfoList::activateTimers() () from /usr/lib/libQt5Core.so.5 #13 0x00007fa5bf592a79 in ?? () from /usr/lib/libQt5Core.so.5 #14 0x00007fa5b1f0add7 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0 #15 0x00007fa5b1f0b040 in ?? () from /usr/lib/libglib-2.0.so.0 #16 0x00007fa5b1f0b0ec in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0 #17 0x00007fa5bf59357f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5 #18 0x00007fa5bf53d0da in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5 #19 0x00007fa5bf5455cc in QCoreApplication::exec() () from /usr/lib/libQt5Core.so.5 #20 0x0000000000425129 in main ()

frebib commented on 2016-08-03 08:11 (UTC)

Attempting to install this via pacaur yields 'no results found for qt5-base<=5.7' but installing manually by installing libcurl-compat and libjpeg6-turbo first then running the PKGBUILD works just fine.

telred commented on 2016-05-31 18:29 (UTC)

We are close to releasing a fix for this and many other build issues. Sorry for the delay.

belette commented on 2016-05-31 18:23 (UTC)

Hi, Same issue as aswieton any update for the next release update? many thanks belette

telred commented on 2016-05-18 12:33 (UTC)

Hi aswieton, Sorry, please wait for our next Arch build. We are fixing this now. I hope to release next week.

aswieton commented on 2016-05-18 07:27 (UTC)

Hi App crashed after trying to use "join meeting" option Any help? Regards Artur

tomson commented on 2016-05-10 09:31 (UTC)

@hoang: Thanks a lot. It works. I hope it will be reflected (or solved in different manner) in next release....

hoang commented on 2016-05-09 10:14 (UTC)

Hi tomson, As a quick fix you can add the path to the system libraries in sky.sh: $ cat /opt/sky_linux/sky.sh #!/bin/bash #LD_LIBRARY_PATH=/opt/sky_linux/lib /opt/sky_linux/sky "$@" LD_LIBRARY_PATH=/usr/lib:/opt/sky_linux/lib /opt/sky_linux/sky "$@" Kind regards.

tomson commented on 2016-05-09 07:32 (UTC)

Hello, after switching to plasma5, application fails immediatelly when looking for a user: /opt/sky_linux/sky: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/sky_linux/lib/libfreerdp-shadow.so.2.0) /opt/sky_linux/sky: /usr/lib/libssl.so.1.0.0: no version information available (required by /opt/sky_linux/lib/libfreerdp.so.2.0) /opt/sky_linux/sky: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/sky_linux/lib/libfreerdp.so.2.0) /opt/sky_linux/sky: /usr/lib/libssl.so.1.0.0: no version information available (required by /opt/sky_linux/lib/libwinpr.so.1.1) /opt/sky_linux/sky: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/sky_linux/lib/libwinpr.so.1.1) 2016-04-11 15:00:01.220 pjsua_core.c thr0x7f02a8fDEBUG: !.pjsua_core, start image_stack 2016-04-11 15:00:01.220 pjsua_core.c thr0x7f02a8fDEBUG: .create pjsua_var.mutex 2016-04-11 15:00:01.220 pjsua_core.c thr0x7f02a8fDEBUG: .create SIP endpoint 2016-04-11 15:00:01.220 pjsua_core.c thr0x7f02a8fDEBUG: .Create timer mutex 2016-04-11 15:00:01.220 pjsua_core.c thr0x7f02a8fDEBUG: .pjsua created successfully 2016-04-11 15:00:01.220 msw_reg.c thr0x7f02a8fDEBUG: Initiating pjsua ... Could not parse stylesheet of object 0xe210a0 /opt/sky_linux/sky: symbol lookup error: /opt/sky_linux/lib/libcurl.so.4: undefined symbol: SSLv3_client_method I have ticket (SLS-1258) on your web since 11.4.2016 without any reaction. Please answer. Application which fails during searching for a users is for nothing. Thanks in advance.

telred commented on 2016-05-06 15:59 (UTC)

We will fix these issues soon. We are totally redoing our build system.

belette commented on 2016-05-06 15:42 (UTC)

same issue as pezz : makepkg -s ==> Making package: sky 2.0.495-1 (Fri May 6 17:39:45 CEST 2016) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Downloading sky_ubuntu64_v2.0.495.deb... % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 340 100 340 0 0 1462 0 --:--:-- --:--:-- --:--:-- 1459 100 42.4M 100 42.4M 0 0 1149k 0 0:00:37 0:00:37 --:--:-- 1164k ==> Validating source files with sha256sums... sky_ubuntu64_v2.0.495.deb ... Passed ==> Extracting sources... -> Extracting sky_ubuntu64_v2.0.495.deb with bsdtar ==> Entering fakeroot environment... ==> Starting package()... open: No such file or directory elf_open: No such file or directory ==> ERROR: A failure occurred in package(). Aborting...

pezz commented on 2016-05-05 23:08 (UTC)

Yeah, doesn't build for me either. http://pastebin.com/raw/SSfQZJh5

ImNtReal commented on 2016-05-05 13:43 (UTC) (edited on 2016-05-05 13:49 (UTC) by ImNtReal)

Looks like several of the libraries have been removed from the package, any more. I had to change icu_libs to "libicudata libicui18n libicuuc", and get rid of the chrpath for libfcitxplatforminputcontextplugin.so to get it to build.

denoyse commented on 2016-04-22 13:10 (UTC)

+1 to remove autostart

telred commented on 2016-04-04 08:30 (UTC)

@ogarcia, the gstreamer0.10 library comes from our FreeRDP module. gstreamer0.10 is for multimedia (multimedia redirection, audio and video playback).

pezz commented on 2016-03-31 12:28 (UTC)

Hey @ogarcia - I have a Jira job in with tel.red to fix the auto-start thing.

ogarcia commented on 2016-03-31 11:24 (UTC)

And, @telred Why gstreamer0.10?

ogarcia commented on 2016-03-31 11:09 (UTC)

Please, remove /etc/xdg/autostart/Sky_Create_Dock.desktop from package. If user wants autostart can do it easy via his ~/.config/autostart directory.

telred commented on 2016-03-18 00:20 (UTC)

Hello pezz, Some paying users requested auto start. When we have time, we'll make it an optional setting. If you send a request to our help desk https://tel.red/img/linux1.png then it helps us record your request and notify you when it is done.

pezz commented on 2016-03-17 22:04 (UTC)

Could you PLEASE remove the xdg auto-start .desktop file from the package? At least respond why you won't...

divineant commented on 2016-03-10 12:27 (UTC)

checksum for 2.0.467 doesn't match it should be sha256sums_x86_64=('cc99fda37b920b98f42658765fc415996766bd3a030052c48b97fc5d4a45d9e2')

aswieton commented on 2016-01-28 08:26 (UTC) (edited on 2016-01-29 07:28 (UTC) by aswieton)

Fresh install: /opt/sky_linux/sky: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/sky_linux/lib/libfreerdp-shadow.so.2.0) /opt/sky_linux/sky: /usr/lib/libssl.so.1.0.0: no version information available (required by /opt/sky_linux/lib/libfreerdp.so.2.0) /opt/sky_linux/sky: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/sky_linux/lib/libfreerdp.so.2.0) /opt/sky_linux/sky: /usr/lib/libssl.so.1.0.0: no version information available (required by /opt/sky_linux/lib/libwinpr.so.1.1) /opt/sky_linux/sky: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/sky_linux/lib/libwinpr.so.1.1) static QPlatformTheme* QKdeTheme::createKdeTheme(): Unable to determine KDEHOME 2016-01-28 09:20:19.438 pjsua_core.c thr0x7f6e301DEBUG: !.pjsua_core, start image_stack 2016-01-28 09:20:19.438 pjsua_core.c thr0x7f6e301DEBUG: .create pjsua_var.mutex 2016-01-28 09:20:19.438 pjsua_core.c thr0x7f6e301DEBUG: .create SIP endpoint 2016-01-28 09:20:19.438 pjsua_core.c thr0x7f6e301DEBUG: .Create timer mutex 2016-01-28 09:20:19.438 pjsua_core.c thr0x7f6e301DEBUG: .pjsua created successfully 2016-01-28 09:20:19.439 msw_reg.c thr0x7f6e301DEBUG: Initiating pjsua ... hereeeeeeeeeeee!!!!! Sky can't login going into loop Please help

novotny commented on 2016-01-11 07:53 (UTC)

Hello Can you please remove file /etc/xdg/autostart/Sky_Create_Dock.desktop from package ? Auto-starting is very annoying and unnecessary.

pezz commented on 2015-11-05 23:23 (UTC)

Any chance you could remove this from the package: /etc/xdg/autostart/Sky_Create_Dock.desktop Auto-starting is very annoying and unnecessary.

ImNtReal commented on 2015-05-26 19:34 (UTC)

Looks like this is being replaced with sky.

audrius commented on 2015-05-13 11:06 (UTC)

Getting this error after clean install /opt/wync_linux/wync: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/wync_linux/lib/libfreerdp-shadow.so) /opt/wync_linux/wync: /usr/lib/libssl.so.1.0.0: no version information available (required by /opt/wync_linux/lib/libfreerdp.so.1.2) /opt/wync_linux/wync: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/wync_linux/lib/libfreerdp.so.1.2) /opt/wync_linux/wync: /usr/lib/libssl.so.1.0.0: no version information available (required by /opt/wync_linux/lib/libwinpr.so.1.1) /opt/wync_linux/wync: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/wync_linux/lib/libwinpr.so.1.1) 2015-05-13 14:05:45.063 pjsua_core.c thr0x7f24964DEBUG: !.pjsua_core, start image_stack 2015-05-13 14:05:45.063 msw_reg.c thr0x7f24964DEBUG: Initiating pjsua ... /usr/bin/wync: line 7: 19401 Segmentation fault (core dumped) LD_LIBRARY_PATH=/opt/wync_linux/lib /opt/wync_linux/wync "$@"

ImNtReal commented on 2015-04-29 18:29 (UTC)

Sorry about gcc-libs-multilib. That was left over from when this was a 32-bit only package.

FirefighterBlu3 commented on 2015-04-29 18:25 (UTC)

just edit the PKGBUILD and delete gcc-libs-multilib, it isn't needed

tmoore commented on 2015-04-27 23:46 (UTC)

==> Install or build missing dependencies for wync: error: target not found: gcc-libs-multilib seems to be missing pkg now I see gcc-libs-multilib-git in AUR, but not sure that's appropriate.

ImNtReal commented on 2015-03-06 13:53 (UTC)

Unfortunately, the ldconfig errors are due to the way upstream packages binary libraries. I'll play around with the PKGBUILD, and see if I can fix this one without too much trouble.

captainju commented on 2015-03-06 08:18 (UTC)

from a fresh install : ldconfig: /opt/wync_linux/lib/libXss.so.1 is not a symbolic link

dfaught commented on 2014-12-31 15:37 (UTC)

Wync appears to have a "soft" dependency on ibus. The presence of these exports export QT_IM_MODULE="ibus" export QT4_IM_MODULE="ibus" export XMODIFIERS="@im=ibus" export GTK_IM_MODULE="ibus" export DEPENDS="ibus, ibus-gtk, ibus-qt4, ibus-clutter" in /opt/wync_linux/wync.sh cause wync to seg fault if ibus isn't actually present on the system. I say it is a soft/optional dependency because if I comment them out wync executes fine and appears to not lose any functionality. Fisil's RedHat package doesn't specify those exports. I've submitted a patch of wync.sh with a check for ibus and the sub-libraries to Fisil, but I've no idea if they'll use it. You might want to consider adding ibus as a dependency or adding a post install patch to update wync.sh with a check for ibus. Or maybe both if ibus was an optional dependency. Thanks

ImNtReal commented on 2014-12-29 18:52 (UTC)

Well, something broke with newer versions, and all of the manual installing I was doing. I've decided to simplify this package, and use the built in libraries for everything, again.

commented on 2014-12-02 08:12 (UTC)

@ImNtReal: Worked, thanks!

ImNtReal commented on 2014-12-01 18:25 (UTC)

@olimination, try, again.

ImNtReal commented on 2014-12-01 16:36 (UTC)

I'm working on it. It's because the ABI got bumped on FreeRDP.

commented on 2014-11-28 09:28 (UTC)

I receive with the current build following error: /opt/wync_linux/wync: error while loading shared libraries: libxfreerdp-client.so.1.1: cannot open shared object file: No such file or directory Where do I find this dependency, because I have already installed the FreeRDP package? Thanks.

ImNtReal commented on 2014-10-20 20:28 (UTC)

Turns out the location of the sound files is hard-coded, and I don't want to put them under /usr/bin, so we will have to live with the one ELF file error.

konig commented on 2014-10-20 20:15 (UTC)

Yep, that did it; one thing though, you should add chrpath as a dependency. Thanks,

ImNtReal commented on 2014-10-20 20:00 (UTC)

Ok. I've changed it to a custom install. This should clean up all namcap errors. Give that a try.

konig commented on 2014-10-20 18:21 (UTC)

Here is something you can look at - ldconfig returns the following. ldconfig: /opt/wync_linux/lib/libSDL-1.3.so.0 is not a symbolic link ldconfig: /opt/wync_linux/lib/libXss.so.1 is not a symbolic link ldconfig: /opt/wync_linux/lib/libwinpr-nt.so.0.1 is not a symbolic link ldconfig: /opt/wync_linux/lib/libwinpr-com.so.0.1 is not a symbolic link ldconfig: /opt/wync_linux/lib/libwinpr-wtsapi.so.0.1 is not a symbolic link

ImNtReal commented on 2014-10-20 18:01 (UTC)

That's unusual. When I have it installed, the only missing library according to namcap is libmysqlclient_r.so.16 because the rest are included in the package. I can't do anything about the complaints of binary files installed in the wrong location because it is installed under /opt. I haven't seen any sort of official license text, but I guess I'll make something up to get rid of that warning.

konig commented on 2014-10-20 17:42 (UTC)

installed or not, the results returned are the same.

ImNtReal commented on 2014-10-20 17:06 (UTC)

Did you run namcap with, or without wync installed?

konig commented on 2014-10-20 16:34 (UTC)

Hey, check out what namcap reported back wync E: Missing custom license directory (usr/share/licenses/wync) wync E: Insecure RPATH '/home/towerhanoi/Qt5.3.0/5.3/gcc_64' in file ('opt/wync_linux/wync') wync E: Insecure RPATH '/home/towerhanoi/Qt5.3.0/5.3/gcc_64' in file ('opt/wync_linux/lib/libsipw.so.1.0.0') wync E: Insecure RPATH '\$ORIGIN' in file ('opt/wync_linux/lib/libiculx.so.52.1') wync E: Insecure RPATH '\$ORIGIN' in file ('opt/wync_linux/lib/libicui18n.so.52.1') wync E: Insecure RPATH '\$ORIGIN' in file ('opt/wync_linux/lib/libicuio.so.52.1') wync E: Insecure RPATH '\$ORIGIN' in file ('opt/wync_linux/lib/libicutu.so.52.1') wync E: Insecure RPATH '\$ORIGIN' in file ('opt/wync_linux/lib/libicutest.so.52.1') wync E: Insecure RPATH '\$ORIGIN' in file ('opt/wync_linux/lib/libicule.so.52.1') wync E: Insecure RPATH '\$ORIGIN' in file ('opt/wync_linux/lib/libicudata.so.52.1') wync W: Referenced library 'libwinpr-environment.so.0.1' is an uninstalled dependency wync W: Referenced library 'libfreerdp-core.so.1.1' is an uninstalled dependency wync W: Referenced library 'libwinpr-thread.so.0.1' is an uninstalled dependency wync W: Referenced library 'libwinpr-registry.so.0.1' is an uninstalled dependency wync W: Referenced library 'libSDL-1.3.so.0' is an uninstalled dependency wync W: Referenced library 'libfreerdp-common.so.1.1.0' is an uninstalled dependency wync W: Referenced library 'libwinpr-dsparse.so.0.1' is an uninstalled dependency wync W: Referenced library 'libwinpr-io.so.0.1' is an uninstalled dependency wync W: Referenced library 'libfreerdp-locale.so.1.1' is an uninstalled dependency wync W: Referenced library 'libwinpr-synch.so.0.1' is an uninstalled dependency wync W: Referenced library 'libfreerdp-utils.so.1.1' is an uninstalled dependency wync W: Referenced library 'libwinpr-heap.so.0.1' is an uninstalled dependency wync W: Referenced library 'libicutu.so.52' is an uninstalled dependency wync W: Referenced library 'libwinpr-error.so.0.1' is an uninstalled dependency wync W: Referenced library 'libicuuc.so.52' is an uninstalled dependency wync W: Referenced library 'libwinpr-pool.so.0.1' is an uninstalled dependency wync W: Referenced library 'libfreerdp-primitives.so.1.1' is an uninstalled dependency wync W: Referenced library 'libicudata.so.52' is an uninstalled dependency wync W: Referenced library 'libfreerdp-codec.so.1.1' is an uninstalled dependency wync W: Referenced library 'libicui18n.so.52' is an uninstalled dependency wync W: Referenced library 'libwinpr-path.so.0.1' is an uninstalled dependency wync W: Referenced library 'libmysqlclient_r.so.16' is an uninstalled dependency wync W: Referenced library 'libfreerdp-rail.so.1.1' is an uninstalled dependency wync W: Referenced library 'libwinpr-utils.so.0.1' is an uninstalled dependency wync W: Referenced library 'libsipw.so.1' is an uninstalled dependency wync W: Referenced library 'libwinpr-handle.so.0.1' is an uninstalled dependency wync W: Referenced library 'libwinpr-input.so.0.1' is an uninstalled dependency wync W: Referenced library 'libfreerdp-gdi.so.1.1' is an uninstalled dependency wync W: Referenced library 'libicule.so.52' is an uninstalled dependency wync W: Referenced library 'libwinpr-sspi.so.0.1' is an uninstalled dependency wync W: Referenced library 'libfreerdp-cache.so.1.1' is an uninstalled dependency wync W: Referenced library 'libfreerdp-crypto.so.1.1' is an uninstalled dependency wync W: Referenced library 'libxfreerdp-server.so.1.1' is an uninstalled dependency wync W: Referenced library 'libwinpr-interlocked.so.0.1' is an uninstalled dependency wync W: Referenced library 'libfreerdp-client.so.1.1' is an uninstalled dependency wync W: Referenced library 'libwinpr-rpc.so.0.1' is an uninstalled dependency wync W: Referenced library 'libwinpr-sysinfo.so.0.1' is an uninstalled dependency wync W: Referenced library 'libwinpr-crt.so.0.1' is an uninstalled dependency wync W: Referenced library 'libwinpr-file.so.0.1' is an uninstalled dependency wync W: Referenced library 'libxfreerdp-client.so.1.1' is an uninstalled dependency wync W: Referenced library 'libwinpr-nt.so.0.1' is an uninstalled dependency wync W: Referenced library 'libwinpr-library.so.0.1' is an uninstalled dependency wync E: ELF file ('opt/wync_linux/wync') outside of a valid path. wync E: ELF file ('opt/wync_linux/generic/libqevdevmouseplugin.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/generic/libqevdevtouchplugin.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/generic/libqevdevkeyboardplugin.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/generic/libqevdevtabletplugin.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/bearer/libqgenericbearer.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/bearer/libqconnmanbearer.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/bearer/libqnmbearer.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/qmltooling/libqmldbg_qtquick2.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/qmltooling/libqmldbg_tcp.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/qml1tooling/libqmldbg_inspector.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/qml1tooling/libqmldbg_tcp_qtdeclarative.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-wtsapi.so.0.1') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libQt5Concurrent.so.5.3.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-path.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libavformat.so.53.32.100') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-rpc.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libsipw.so.1.0.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libxfreerdp-client.so.1.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-heap.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libQt5Widgets.so.5.3.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libsqlite3.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libsmime3.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-com.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-library.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libQt5Positioning.so.5.3.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libpostproc.so.52.0.100') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libssl3.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libiculx.so.52.1') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libQt5Core.so.5.3.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libfreerdp-codec.so.1.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libfreerdp-crypto.so.1.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libfreerdp-gdi.so.1.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-sspi.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libQt5Bluetooth.so.5.3.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libnssckbi.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-nt.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-dsparse.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libswscale.so.2.1.100') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-synch.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libXss.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libfreerdp-core.so.1.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libQt5SerialPort.so.5.3.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-bcrypt.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libfreerdp-server.so.1.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-crypto.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libXss.so.1') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libfreerdp-client.so.1.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-input.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-pool.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libfreerdp-common.so.1.1.0-beta1') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libQt5X11Extras.so.5.3.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libQt5Network.so.5.3.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-sspicli.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libnssutil3.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libfreerdp-cache.so.1.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libicui18n.so.52.1') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libxfreerdp-server.so.1.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libcurl.so.4.3.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libicuio.so.52.1') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libQt5DBus.so.5.3.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-winhttp.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libfreebl3.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libavcodec.so.53.61.100') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-wtsapi.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libSDL-1.3.so.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-credui.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libnsssysinit.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libicuuc.so.52.1') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-credentials.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-asn1.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-winsock.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libfreerdp-locale.so.1.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libSDL-1.3.so.0.0.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-nt.so.0.1') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-handle.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-timezone.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libSDL.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-file.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libnssdbm3.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libsoftokn3.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-crt.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libnss3.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libavfilter.so.2.61.100') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libicutu.so.52.1') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-io.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libQt5WebSockets.so.5.3.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-thread.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libicutest.so.52.1') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libfreerdp-rail.so.1.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-utils.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libqgsttools_p.so.1.0.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libfreerdp-primitives.so.1.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libavutil.so.51.35.100') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libavdevice.so.53.4.100') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libQt5OpenGL.so.5.3.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libEnginio.so.1.0.4') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-sysinfo.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libswresample.so.0.6.100') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libicule.so.52.1') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-interlocked.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-registry.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libXss.so.1.0.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libQt5Nfc.so.5.3.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-com.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-nt.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-error.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-com.so.0.1') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libfreerdp-utils.so.1.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-pipe.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-wtsapi.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libQt5Gui.so.5.3.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libwinpr-environment.so.0.1.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libicudata.so.52.1') outside of a valid path. wync E: ELF file ('opt/wync_linux/lib/libQt5Svg.so.5.3.0') outside of a valid path. wync E: ELF file ('opt/wync_linux/platforms/libqlinuxfb.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/platforms/libqminimalegl.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/platforms/libqminimal.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/platforms/libqxcb.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/platforms/libqoffscreen.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/platforms/libqeglfs.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/audio/libqtmedia_pulse.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/sqldrivers/libqsqlmysql.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/sqldrivers/libqsqlite.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/sqldrivers/libqsqlpsql.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/mediaservice/libgstmediacapture.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/mediaservice/libgstcamerabin.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/mediaservice/libgstaudiodecoder.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/mediaservice/libgstmediaplayer.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/printsupport/libcupsprintersupport.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/playlistformats/libqtmultimedia_m3u.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/designer/libqdeclarativeview.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/designer/libqwebview.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/designer/libqquickwidget.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/position/libqtposition_positionpoll.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/iconengines/libqsvgicon.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/platformthemes/libqgtk2.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/imageformats/libqtiff.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/imageformats/libqdds.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/imageformats/libqgif.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/imageformats/libqtga.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/imageformats/libqwbmp.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/imageformats/libqjpeg.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/imageformats/libqico.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/imageformats/libqsvg.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/imageformats/libqicns.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/imageformats/libqwebp.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/imageformats/libqjp2.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/imageformats/libqmng.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/sensorgestures/libqtsensorgestures_plugin.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/sensorgestures/libqtsensorgestures_shakeplugin.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/accessible/libqtaccessiblequick.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/accessible/libqtaccessiblewidgets.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/sensors/libqtsensors_generic.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/sensors/libqtsensors_dummy.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/sensors/libqtsensors_linuxsys.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/platforminputcontexts/libcomposeplatforminputcontextplugin.so') outside of a valid path. wync E: ELF file ('opt/wync_linux/platforminputcontexts/libibusplatforminputcontextplugin.so') outside of a valid path. wync W: Dependency libxkbfile included but already satisfied

ImNtReal commented on 2014-10-20 15:58 (UTC)

I'm not sure what causes it. I get the errors, also, but it seems to work, anyway. When I look at what the wync binary is linked to, it shows everything is there.

konig commented on 2014-10-20 15:54 (UTC)

I run into the same errors described by mrhanman when I run wync - any idea what could be causing it? /opt/wync_linux/wync: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/wync_linux/lib/libxfreerdp-server.so.1.1) /opt/wync_linux/wync: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/wync_linux/lib/libfreerdp-core.so.1.1) /opt/wync_linux/wync: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/wync_linux/lib/libwinpr-utils.so.0.1) /opt/wync_linux/wync: /usr/lib/libssl.so.1.0.0: no version information available (required by /opt/wync_linux/lib/libfreerdp-crypto.so.1.1) /opt/wync_linux/wync: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/wync_linux/lib/libfreerdp-crypto.so.1.1) /opt/wync_linux/wync: /usr/lib/libssl.so.1.0.0: no version information available (required by /opt/wync_linux/lib/libwinpr-sspi.so.0.1) /opt/wync_linux/wync: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/wync_linux/lib/libwinpr-sspi.so.0.1) /opt/wync_linux/wync: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/wync_linux/lib/libwinpr-rpc.so.0.1) "Qt Warning - invalid keysym: dead_actute" /opt/wync_linux/wync.sh: line 7: 5103 Segmentation fault (core dumped) LD_LIBRARY_PATH=/opt/wync_linux/lib /opt/wync_linux/wync "$@"

zikkeddu commented on 2014-08-30 10:41 (UTC)

This is strange. I tried when i wrote and after next full update of my installation.

ImNtReal commented on 2014-08-28 14:53 (UTC)

I'm running the .deb version without any special openssl version.

zikkeddu commented on 2014-08-28 00:38 (UTC)

ehm now i see. change wget address with http://fisil.com/linux/wync_redhat64_v2.0.180.rpm

zikkeddu commented on 2014-08-28 00:12 (UTC)

solved installing rpm fedora version, manually now: cd /tmp wget http://192.168.5.150:8080/wync_redhat64_v2.0.180.rpm rpmextract.sh wync_redhat64_v2.0.180.rpm sudo cp -a /tmp/usr/bin /usr/bin sudo cp -a /tmp/usr/share/applications /usr/share/applications sudo cp -a /tmp/usr/share/pixmaps /usr/share/pixmaps sudo cp -a /tmp/usr/share/menu /usr/share/menu sudo cp -a /tmp/opt /opt rm -rf /tmp/usr rm -rf /tmp/opt sudo ln -s /usr/lib/libssl.so.0.9.8 /usr/lib/libssl.so.10 sudo ln -s /usr/lib/libcrypto.so.1.0.0 /usr/lib/libcrypto.so.10 If you want .deb version you need a particular openssl version for ubuntu. And that isn't in AUR now. I haven't skills now, so if someone want to make an easy pkgbuild starting from my manual installation, we have found a good guy. :-)

dot commented on 2014-08-26 19:35 (UTC)

I'm no longer interested in this software, please continue further maintenance if needed.

pcfreak commented on 2014-08-12 19:30 (UTC)

Maybe this helps. Installed wync 2.0.162-1 from AUR with its dependencies yesterday but did not work so removed it. Today downloaded "wync_debian64_v2.0.147.deb" from official site, extracted deb with "ar xv" and then extracted the "data.tar.gz". Then deleted everything except ./opt Then changed the following files /opt/wync_linux/wync.sh to 7c7,8 < LD_LIBRARY_PATH=/opt/wync_linux/lib /opt/wync_linux/wync "$@" --- > export LD_LIBRARY_PATH=$PWD/lib > $PWD/wync "$@" and /opt/wync_linux/man.sh 12c12 < sh /opt/wync_linux/wync.sh & --- > sh $PWD/wync.sh & It now works out of the local folder by running ./wync.sh on Arch with latest kernel and latest Gnome. Enough for me at the moment but maybe somone yould use the information for building a package that puts everything into /opt/wync and make it usable?

dot commented on 2014-06-17 08:53 (UTC)

@zikkeddu, @mrhanman - could you get a backtrace from threads by the time signal is received, so that I can report this bug upstream? A backtrace can be obtained from the coredump file (extracted with systemd-coredumpctl if you are using systemd) as explained at: http://stackoverflow.com/questions/5745215/getting-stacktrace-from-core-dump (use "thread apply all bt full" or "thread apply all bt"). Or a running program when launched with debugger: LD_LIBRARY_PATH=/opt/wync_linux/lib gdb /opt/wync_linux/wync "run" gdb command will start Wync, and after a signal is received the same command as above may be used. For both cases you will need gdb.

zikkeddu commented on 2014-06-15 01:10 (UTC)

i had the same problem of mrhanman. Solved installing 64bit version for debian. Practically a downgrade.

dot commented on 2014-06-14 01:12 (UTC)

PKGBUILD updated. Note: i686 version number provided by upstream differs from that of the x86_64 package, thus 32bit wync has been submitted as a different package: wync32 (https://aur.archlinux.org/packages/wync32/)

mrhanman commented on 2014-05-23 17:15 (UTC)

Using pietro's PKGBUILD, I get the following when running /opt/wync_linux/wync.sh: /opt/wync_linux/wync: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/wync_linux/lib/libxfreerdp-server.so.1.1) /opt/wync_linux/wync: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/wync_linux/lib/libfreerdp-core.so.1.1) /opt/wync_linux/wync: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/wync_linux/lib/libwinpr-utils.so.0.1) /opt/wync_linux/wync: /usr/lib/libssl.so.1.0.0: no version information available (required by /opt/wync_linux/lib/libfreerdp-crypto.so.1.1) /opt/wync_linux/wync: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/wync_linux/lib/libfreerdp-crypto.so.1.1) /opt/wync_linux/wync: /usr/lib/libssl.so.1.0.0: no version information available (required by /opt/wync_linux/lib/libwinpr-sspi.so.0.1) /opt/wync_linux/wync: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/wync_linux/lib/libwinpr-sspi.so.0.1) /opt/wync_linux/wync: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /opt/wync_linux/lib/libwinpr-rpc.so.0.1) "Qt Warning - invalid keysym: dead_actute" /opt/wync_linux/wync.sh: line 7: 5103 Segmentation fault (core dumped) LD_LIBRARY_PATH=/opt/wync_linux/lib /opt/wync_linux/wync "$@" Running /opt/wync_linux/wync gives this: /opt/wync_linux/wync: error while loading shared libraries: libsipw.so.1: cannot open shared object file: No such file or directory

pietro commented on 2014-05-19 14:40 (UTC)

the following PKGBUILD works for me: {{{ pkgname=wync pkgver=2.0.101 pkgrel=1 pkgdesc="Microsoft Lync client for Linux" arch=('x86_64' 'i686') license=('custom:"Copyright (c) 2014 Fisil LLC"') url="http://fisil.com/products.html" options=('!strip' 'staticlibs') if [ "${CARCH}" = "x86_64" ]; then md5sums=('ab233365b89552d5f334b45934b6e7eb') _arch="64" elif [ "${CARCH}" = "i686" ]; then md5sums=('6f94ad21809048c24692175aed4f3cd3') _arch="32" fi source=("http://fisil.com/linux/wync_ubuntu${_arch}_v${pkgver}.deb") package() { cd "${srcdir}" ar x "wync_ubuntu${_arch}_v${pkgver}.deb" > /dev/null tar -xzf data.tar.gz -C "${pkgdir}" # Clean find "${pkgdir}" -type f -name '*~' -delete rm -rf "${pkgdir}"/etc rm -rf "${pkgdir}"/usr/bin # Rights chmod -R 755 "${pkgdir}"/opt chmod -R 755 "${pkgdir}"/usr } }}}

berot3 commented on 2014-04-29 09:26 (UTC)

update: to install 64bit version we have to update the PKBUILD like this: update to "pkgver=2.0.85" update to "md5sums=('b932f799be1621f4643e9c0a35bd1ef7')" oh and the URL is case-sensitiv, so it does not work like this for 64bit: change the following lines source=("http://fisil.com/linux/Wync_Ubuntu${_arch}_v${pkgver}.deb") "ar x "Wync_Ubuntu${_arch}_v${pkgver}.deb" > /dev/null" to source=("http://fisil.com/linux/wync_ubuntu${_arch}_v${pkgver}.deb") "ar x "wync_ubuntu${_arch}_v${pkgver}.deb" > /dev/null" maybe someone clever can make this work again? ;)

zikkeddu commented on 2014-04-05 10:37 (UTC)

to install 64bit version we have to update the PKBUILD like this: 1. Changed "pkgver=2.0.59" to "pkgver=2.0.73" 2. Changed "md5sums=('e652e05f12f94c85011b4ea734aa4e73')" to "md5sums=('df098c575175b526a2ec8281c912532b')". thanks to Techbolt for the first suggestion for 32bit

techbolt commented on 2014-03-28 14:45 (UTC)

Couldn't install without changing the PKGBUILD. I updated the following and it installed perfectly and worked flawless. 1. Changed "pkgver=2.0.59" to "pkgver=2.0.66" 2. Changed "md5sums=('6f94ad21809048c24692175aed4f3cd3')" to "md5sums=('c597b64566eb00e078ee392bbf07b4bc')". Note that I have the 32 bit install so I changed md5 only for that but if you are on 64 bit, you may need to find the MD5sum for that and replace that MD5. I wasn't sure if I should change pkgrel so I left it as is and continued building and like I said it worked fine.

Stanley_00 commented on 2014-03-28 04:08 (UTC)

Need to update to 2.0.66 This package contain many unnecessary libraries, or already have in other package. For example, it included .so file of libqt5-*, freerdp, etc

duckunix commented on 2014-03-07 18:32 (UTC)

need to update to 2.0.47

duckunix commented on 2014-02-24 20:31 (UTC)

Need to uprev to 2.0.37...

commented on 2014-02-20 10:58 (UTC)

It seems it should depend on the package 'gstreamer0.10-base'.

lervag commented on 2014-02-20 07:56 (UTC)

It seems to work. I used the wrong executable, that is, i tried /opt/wync/wync, not /opt/wync/wync.sh. In any case, I think it would be better to add an executable to /usr/bin (if only a symlink).

stef312 commented on 2014-02-14 16:37 (UTC)

lervagn, can you paste here the error ?

lervag commented on 2014-02-14 08:33 (UTC)

Update: For some reason, I don't get this to work. I tested on a Ubuntu machine, where it seems to work very well. A couple of remarks: 1. It seems the binary is not added to /usr/bin. 2. There seems to be a problem with a missing libsip (or something similar). Does this work for anyone else? stef312?

lervag commented on 2014-02-14 07:58 (UTC)

It seems like this package updates quite often, and it is already out-of-date. I had to update the version number and the md5sum to get it working.