Package Details: sky 2.1.6918-201708040144

Git Clone URL: https://aur.archlinux.org/sky.git (read-only)
Package Base: sky
Description: Lync and Skype for Business client on Linux
Upstream URL: http://tel.red
Licenses: custom: Copyright © 2015-2017 TEL.RED LLC
Submitter: telred
Maintainer: telred
Last Packager: telred
Votes: 45
Popularity: 1.316866
First Submitted: 2015-05-13 14:01
Last Updated: 2017-08-04 02:09

Latest Comments

SanskritFritz commented on 2017-09-19 08:50

Just use the official upstream appimage: https://tel.red/linux/sky-latest-x86_64.AppImage

pezz commented on 2017-08-07 23:45

2.1.6918 just locks up when attempting to sign in.

It's like a crap shoot these days on whether Sky works or not, can't believe how buggy this software still is.

trillanewhero commented on 2017-06-15 03:57

Hello, i'm getting the error:

Selected style: "Windows"
QSS file loaded: "/usr/lib/sky/stylesheets/stylesheet_default.qss"
2017-06-15 08:48:46.099 pjsua_core.c thr0x7f86159DEBUG: !.pjsua_core, start image_stack
2017-06-15 08:48:46.099 pjsua_core.c thr0x7f86159DEBUG: .create pjsua_var.mutex
2017-06-15 08:48:46.099 pjsua_core.c thr0x7f86159DEBUG: .create SIP endpoint
2017-06-15 08:48:46.100 pjsua_core.c thr0x7f86159DEBUG: .Create timer mutex
2017-06-15 08:48:46.100 pjsua_core.c thr0x7f86159DEBUG: .pjsua created successfully
2017-06-15 08:48:46.167 msw_reg.c thr0x7f86159DEBUG: Initiating pjsua ...
DBUS API INITIALIZED
QObject::connect: No such slot WSessionManager::onSetOffHookJabraHeadsetButton()
sky: malloc.c:2369: sysmalloc: Assertion `(old_top == initial_top (av) && old_size == 0) || ((unsigned long) (old_size) >= MINSIZE && prev_inuse (old_top) && ((unsigned long) old_end & (pagesize - 1)) == 0)' failed.

How can i fix it?

syaorandroid commented on 2017-06-13 01:37

to fix the error, must install this version of qt5-base:
https://www.archlinux.org/packages/extra/x86_64/qt5-base/

Hope it helps!

syaorandroid commented on 2017-06-09 20:22

is that fixed? I'm getting the error
sky: /usr/lib/libQt5Core.so.5: version `Qt_5.9' not found (required by sky)
sky: /usr/lib/libQt5Core.so.5: version `Qt_5.9' not found (required by /usr/lib/sky/lib/libsipw.so.1)

GI_Jack commented on 2017-06-08 19:04

qt-base 5.9 is out, package breaks, please fix

YHVH commented on 2017-05-28 19:21

Updated but still broken, crashes when signing in

GI_Jack commented on 2017-04-25 17:35

openssl-1.0 is in [extra], should base off that.

jevv commented on 2017-04-24 17:34

openssl 1.1.0 already reached Arch, and now Sky is in trouble:

++++
error: failed to prepare transaction (could not satisfy dependencies)
:: sky: installing openssl (1.1.0.e-1) breaks dependency 'openssl<1.1.0'
++++

jevv commented on 2017-04-23 01:58

Moreover, openssl 1.* is about to be released from testing... See:

https://lists.archlinux.org/pipermail/arch-dev-public/2017-April/028806.html

And as sky indicates when installing, it won't work with openssl 1.*

All comments