Package Details: skype 4.3.0.37-10

Git Clone URL: https://aur.archlinux.org/skype.git (read-only)
Package Base: skype
Description: P2P software for high-quality voice communication
Upstream URL: http://www.skype.com/
Licenses: custom
Submitter: Rhinoceros
Maintainer: Rhinoceros
Last Packager: Rhinoceros
Votes: 135
Popularity: 12.434637
First Submitted: 2016-07-30 06:34
Last Updated: 2017-04-25 12:02

Pinned Comments

Rhinoceros commented on 2017-05-14 01:49

lib32-qt4 4.8.7-13 has been updated to fix the lib32-openssl issues. lib32-openssl-1.0 is no longer required. If you are still having issues with skype, please make sure everything is up to date.

Rhinoceros commented on 2017-03-03 11:30

For those wanting to install the beta version (web version in a wrapper), see https://wiki.archlinux.org/index.php/Skype

Latest Comments

Rhinoceros commented on 2017-05-18 22:34

@alexandre-mbm Please enquire on the lib32-qt4 page for the first part. I'm not sure if you are talking about the skype PKGBUILD, but there certainly is a 64-bit version. If you are talking about the lib32-qt4 PKGBUILD, then that is *only* for 64-bit systems. (That's what an explicit `lib32-` implies.) But this is the wrong page to discuss that.

alexandre-mbm commented on 2017-05-18 20:34

Even without know of this, I was reinstalling Skype. But rebuild lib32-qt4 is impossible in a /tmp with only 1,5 GB. Now, by looking the PKGBUILD, I also get that there is not a 64 bit version. Sorry but I can not continue using this package.

Rhinoceros commented on 2017-05-18 08:43

@biosin I think you've posted on the wrong page. The skype PKGBUILD doesn't even source that file, nor use sha512.

biosin commented on 2017-05-18 08:07

Validating source files with sha512sums...
qt-everywhere-opensource-src-4.8.7.tar.gz ... FAILED

Rhinoceros commented on 2017-05-16 22:37

@dluciv What version of lib32-qt4 are you running?

dluciv commented on 2017-05-16 15:27

/usr/lib32/skype/skype: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory

On recently updated x86_64 machine

Rhinoceros commented on 2017-05-14 01:49

lib32-qt4 4.8.7-13 has been updated to fix the lib32-openssl issues. lib32-openssl-1.0 is no longer required. If you are still having issues with skype, please make sure everything is up to date.

Ihor commented on 2017-05-10 09:37

Looks like libQtWebKit.so.4 and lib32-qt4-4.8.7-4-x86_64.pkg.tar.xz could be removed as dependencies. I've created lib32-qt4 package without -no-webkit flag in PKGBUILD and skype seems to work without issues.

Rhinoceros commented on 2017-05-07 04:03

@alexandre-mbm Right, but again, as per the sticky, lib32-openssl-1.0 is already in the dependency chain.

alexandre-mbm commented on 2017-05-07 02:45

Regarding error with OpenSSL 1.0.0

We have updated to openssl 1.1.1. So Skype (32 bits) requires lib32-openssl-1.0.

$ gpg --recv-keys --keyserver hkp://pgp.mit.edu D9C4D26D0E604491
$ yaourt -S lib32-openssl-1.0

If your trustdb.gpg is currupted, before make this:

$ cd ~/.gnupg
$ gpg --export-ownertrust > otrust.tmp
$ mv trustdb.gpg trustdb.gpg-backup

Now must be all okay. You can run:

$ skype

Becase here Skype is not 64 bits. But if it was:

$ sudo pacman -S openssl-1.0

All comments