Package Details: slade 3.2.6-2

Git Clone URL: https://aur.archlinux.org/slade.git (read-only, click to copy)
Package Base: slade
Description: SLADE3 Doom editor
Upstream URL: http://slade.mancubus.net/
Licenses: GPL
Submitter: grubber
Maintainer: grubber
Last Packager: grubber
Votes: 32
Popularity: 0.016226
First Submitted: 2011-08-16 11:58 (UTC)
Last Updated: 2024-06-10 11:52 (UTC)

Latest Comments

1 2 3 4 Next › Last »

SteelT commented on 2024-06-06 16:26 (UTC) (edited on 2024-06-06 16:26 (UTC) by SteelT)

webkit2gtk needs to be replaced with webkit2gtk-4.1 as dependency, fails to build with a lot of undefined references to webkit functions without it installed.

maxlefou commented on 2024-01-30 13:48 (UTC)

please add the AUR package zdbsp as UDMF node builder as optional since it is required for the internal map editor.

gamezelda commented on 2024-01-02 21:47 (UTC)

NB: For the SLADE 3.2.5 upgrade you will need to add -DBUILD_PK3=ON to the CMake command, otherwise the install will fail, see: https://github.com/sirjuddington/SLADE/issues/1620

gamezelda commented on 2023-05-04 21:11 (UTC)

The build fails with GCC13. To fix it you can add a prepare() function with:

sed -i '1i #include <cstdint>' "SLADE-${pkgver}"/thirdparty/lunasvg/source/canvas.h "SLADE-${pkgver}"/thirdparty/lunasvg/include/lunasvg.h

Related upstream fix: https://github.com/sammycage/lunasvg/pull/129

ratSprite commented on 2023-04-04 04:19 (UTC) (edited on 2023-04-04 04:19 (UTC) by ratSprite)

New release with a big fix for linux (thanks Eevee!) is out and compiles/runs fine with minimal changes:

4,5c4,5
< pkgver=3.2.1
< pkgrel=2
---
> pkgver=3.2.2
> pkgrel=1
26c26
< sha256sums=('c327fa62ba491ac481d769700261d810128910007297fd9d9dbe26ac0e78bb2c')
---
> sha256sums=('9d2b4f177ac18c1110c7ed36a5ea6e47814b65f26aeaaf6a9959e72309cb5a87')

Deudz commented on 2022-07-21 02:20 (UTC)

it just gets stuck at compiling the graphics.cpp file

andrewlin16 commented on 2022-07-15 08:39 (UTC)

This package at version 3.2.1-1 was blocking my system upgrade due to the recent wxWidgets 3.2 update, failing with this error:

error: failed to prepare transaction (could not satisfy dependencies)
:: removing wxgtk3 breaks dependency 'wxgtk3>=3.0' required by slade

I worked around this by uninstalling slade, then doing the upgrade, then editing the PKGBUILD with this patch:

diff --git a/PKGBUILD b/PKGBUILD
index 5715920..5b650f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@

 pkgname=slade
 pkgver=3.2.1
-pkgrel=1
+pkgrel=2
 pkgdesc='SLADE3 Doom editor'
 arch=('i686' 'x86_64')
 url='http://slade.mancubus.net/'
@@ -18,7 +18,7 @@ depends=('bzip2'
          'mpg123'
          'sfml>=2.5'
          'webkit2gtk'
-         'wxgtk3>=3.0'
+         'wxwidgets-gtk3'
          'zlib')
 makedepends=('cmake'
              'p7zip')
@@ -31,7 +31,7 @@ build() {
     export CCACHE_SLOPPINESS=pch_defines,time_macros
     cmake -DCMAKE_BUILD_TYPE=Release \
           -DCMAKE_INSTALL_PREFIX=/usr \
-          -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 \
+          -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config \
           .
     make
 }

then running makepkg and installing the resulting package. I don't know of a cleaner way to get current users on 3.2.1-1 past the wxWidgets upgrade other than what I did here, but hopefully this comment helps.

ax34 commented on 2022-04-17 00:09 (UTC) (edited on 2022-04-17 00:14 (UTC) by ax34)

yay thinks 3.2.0 is a downgrade compared to 3.2.0_b4. Please increase epoch, also please use versions like 3.2.0b4 (without _) next time.

Pol_M commented on 2019-09-11 11:26 (UTC) (edited on 2019-09-11 11:27 (UTC) by Pol_M)

5c5
< pkgver=3.1.5
---
> pkgver=3.1.6
27c27
< sha256sums=('ddab2c5bde9939dd74505fa4f021995e35f00ead0124ce19cbf72f908445aec4')
---
> sha256sums=('f435b5f51899d4f98dc767262e053dec0cc3ad415923a08e75e0fdad0a3168b5')