Package Details: slap 0.1.61-2

Git Clone URL: https://aur.archlinux.org/slap.git (read-only)
Package Base: slap
Description: Sublime-like terminal-based text editor.
Upstream URL: https://github.com/slap-editor/slap/
Licenses: MIT
Submitter: psychoticmeow
Maintainer: SolarAquarion
Last Packager: SolarAquarion
Votes: 5
Popularity: 0.000004
First Submitted: 2015-06-06 15:37
Last Updated: 2017-02-09 15:27

Dependencies (2)

Required by (1)

Sources (1)

Latest Comments

Sachiko commented on 2017-06-17 04:57

If you remove the "=6.9.4" part from the nodejs-lts-boron dependency, it compiles fine, otherwise you're left unable to install it or build it. So, I am informing people who wish to use it to do so themselves momentarily and for the Maintainer to fix the PKGBUILD accordingly.

flaketill commented on 2016-11-16 05:04

It's because on https://github.com/slap-editor/slap/blob/master/package.json

The package called node-gyp it's not declare like dependencie on package.json, I don't know if are just need on arch linux

If run the follow comman:

$ ls /usr/lib/node_modules | grep "node-gyp" | wc -l

You can look 1 if are install with npm node-gyp, 0 if are not installed like as node module

Or if you already have NodeJS installed on your Arch Linux you can do it with the follow comman:

$ sudo npm install -g slap@latest

It's better install with yaourt on Arch but if you want test the slap, you could use npm to install it

Note:

build-essential equivalent in Arch:

$ sudo pacman -Sy base-devel

stoatally commented on 2016-08-22 18:08

@nashley odd that it should do that. Can you check your /tmp partition with df and make sure it's a decent size? I expect it'll just be a tempfs mount like mine.

Anyway, it won't compile right now npm being a memory hog aside. This is the issue I'm currently experiencing: https://github.com/slap-editor/slap/issues/325

nashley commented on 2016-08-22 17:47

I'm also having issues building the package. I've uploaded the console output and relevant log here:
https://gist.github.com/nashley/710cf989147d52c4f9b0aa7ab7564d57
https://gist.github.com/nashley/1268e606c4103f52762f2df8725ab36f

It complains about not having enough free space, but I have 8GB of RAM and 10GB of swap, and according to htop, my memory usage barely increases. Do I really need to feed it more swap?

stef204 commented on 2015-09-22 20:31

this fails to build with various error messages. installing direct via git fails as well (on my system.) can you check upstream?

stef204 commented on 2015-09-22 20:17

npm ERR! Linux 4.1.6-1-ARCH
npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install" "--python=/usr/bin/python2"
npm ERR! node v4.1.0
npm ERR! npm v3.3.3
npm ERR! code ELIFECYCLE

npm ERR! runas@2.0.0 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the runas@2.0.0 install script 'node-gyp rebuild'.
npm ERR! This is most likely a problem with the runas package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get their info via:
npm ERR! npm owner ls runas
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /var/cache/pacman/pkg/slap29583/slap/src/slap-0.1.42/npm-debug.log
==> ERROR: A failure occurred in build().
Aborting...