Package Details: slic3r-git a-20

Git Clone URL: (read-only)
Package Base: slic3r-git
Description: Slic3r is an STL-to-GCODE translator for RepRap 3D printers, aiming to be a modern and fast alternative to Skeinforge.
Upstream URL:
Licenses: GPL
Conflicts: slic3r, slic3r-xs, slic3r-xs-git
Provides: slic3r, slic3r-xs, slic3r-xs-git
Submitter: swiftgeek
Maintainer: swiftgeek (nickoe)
Last Packager: swiftgeek
Votes: 20
Popularity: 0.000044
First Submitted: 2012-06-23 10:45
Last Updated: 2019-09-13 15:28

Dependencies (27)

Required by (2)

Sources (3)

Pinned Comments

swiftgeek commented on 2016-04-19 00:37

If something breaks on PKGBUILD side, please bother me directly on freenode (usually available at #slic3r) XS compilation requires more than 512MiB of installed RAM, adding same amount of swap makes it build (tested on armv7h, Allwinner A13)

Perl update guide:

or since 5.26:

pacman -Qqo '/usr/lib/perl5/5.26' where 5.26 is OLD version of perl

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

basil commented on 2015-10-29 18:04

After installing this package, when trying to run --gui, I get the following error:
Warning: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1008,wx containers,compatible with 2.6),
and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1009,wx containers,compatible with 2.6).
Base class package "Wx::GLCanvas" is empty.
(Perhaps you need to 'use' the module which defines that package first,
or make that module available in @INC (@INC contains: /usr/bin/vendor_perl/lib /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .).
at /usr/share/perl5/vendor_perl/Slic3r/GUI/Plater/ line 121.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Slic3r/GUI/Plater/ line 121.
Compilation failed in require at /usr/share/perl5/vendor_perl/Slic3r/ line 16.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Slic3r/ line 16.
Compilation failed in require at (eval 66) line 1.

swiftgeek commented on 2015-06-29 09:34

Perl 5.22 state:
After patching perl-extutils-cppguess slic3r:xs compiles, and passes both sets of tests
As for GUI though, perl-opengl is broken - but if you are brave enough you can just disable check stage of that package

swiftgeek commented on 2015-06-16 21:07

Rebuild reminder and update script for perl 5.22:

swiftgeek commented on 2015-02-28 07:58

New optdep: perl-net-bonjour for octoprint discovery

swiftgeek commented on 2015-02-11 21:08

Brought back prerequisites checking, just for info for now (|| true)

swiftgeek commented on 2015-01-25 01:28

a-14 shouldn't break $pkgver standards anymore (a-13 produced package with invalid '-' character in $pkgver; i.e 1.2.6-dev . If this happens again pkgver() will fail)

I also moved git/dialog stuff to pkgver() and finally disabled that useless message about detached head, so if it fails with with pacaur or similar aur helper - please reach me directly over mail/irc [swiftgeek, #slic3r @freenode]

From slic3r related news - please test new plater/gcode 3D previews
1.2.x is going to hit stable soon™

swiftgeek commented on 2015-01-04 05:35

Quick reminder - whenever you recompile perl-wx, recompile perl-wx-glcanvas too (no need to recompile slic3r though)

swiftgeek commented on 2015-01-02 16:57

Ugh… bad news - slic3r version moved to ./xs/src/libslic3r/libslic3r.h
#define SLIC3R_VERSION "1.2.4"
(was ./lib/
Which means that i need to add some logic there (the other purpose of this package is semi-automatic bisecting of printing issues)
#Comment to be removed upon resolving issue

swiftgeek commented on 2015-01-02 16:49

1. Cannot fix that, binary repo's packaging of perl package is ultra weird, perl-*-aur packages are provided as temporary workarounds (until resolved/updated in binary repo)
2. I need to fix awk line separately, i procrastinated on this issue for way too long (31C1 happened and…)
I cannot reproduce »anymore« that warning happening in tests - 69da8b09997c58c3f47d1e676fe578f68cbb96e9

pzl commented on 2015-01-02 16:26

two things I currently have to do to get master (69da8b0) to build correctly:

1: I installed perl-threads-aur
2: I added another sed line to the PKGBUILD, just below the others, to remove the line that parrots out the " >= 1.96 required" warning. ( sed -i '/^\s*warn \"threads\.pm/d' ./lib/ )

There seems to be a logic problem in lib/ that makes this warning print out no matter what. I believe I have the threads dependency satisfied, but the warning prints out anyway, and disturbs the version number checking, which leads to a corrupt package. The warning had to be silenced for makepkg to build correctly, and end up with a tar package that didn't have the warning itself in the filename.

Here's a small gist I created that prints each of the tests used in the Slic3r check before it prints the warning:

If anyone else can shed some light on what's wrong here, I'd love to hear. I'm not too familiar with perl